Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 756685 - net-libs/libkvkontakte depends on deprecated kde-frameworks/kdewebkit and dev-qt/qtwebkit
Summary: net-libs/libkvkontakte depends on deprecated kde-frameworks/kdewebkit and dev...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://invent.kde.org/libraries/libk...
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: qtwebkit-removal kf5-portingaids-removal
  Show dependency tree
 
Reported: 2020-11-25 10:13 UTC by Andreas Sturmlechner
Modified: 2020-12-24 23:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-11-25 10:13:02 UTC
Upstream patch is pending and we know it builds, but it needs someone with an account to test it actually works.

- Patch can be obtained via `wget https://invent.kde.org/libraries/libkvkontakte/-/merge_requests/1.patch`
- Apply to the package as a user patch: https://wiki.gentoo.org/wiki//etc/portage/patches#Adding_user_patches
- Make sure dev-qt/qtwebengine:5 is installed and emerge the package
- Runtime test using the Share/SendTo function in kde-apps/gwenview or kde-apps/spectacle using the KIPI interface (USE=kipi)
Comment 1 Larry the Git Cow gentoo-dev 2020-11-25 10:25:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d714ccfb91aee04c67212a9ff248b492347b4f75

commit d714ccfb91aee04c67212a9ff248b492347b4f75
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-11-25 10:22:42 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-11-25 10:24:25 +0000

    profiles: Mask net-libs/libkvkontakte for removal
    
    Bug: https://bugs.gentoo.org/756685
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/package.mask | 7 +++++++
 1 file changed, 7 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fa0300bcbc0193e00daf7906e1eff779557b7004

commit fa0300bcbc0193e00daf7906e1eff779557b7004
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-10-15 21:11:45 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-11-25 10:24:25 +0000

    profiles: Mask kde-apps/kipi-plugins[vkontakte] in p.use.mask
    
    Depends on masked net-libs/libkvkontakte.
    
    Bug: https://bugs.gentoo.org/756685
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/base/package.use.mask | 4 ++++
 1 file changed, 4 insertions(+)
Comment 2 Larry the Git Cow gentoo-dev 2020-12-24 23:42:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d4faa896bcb56d3682404ead6381e25649154b01

commit d4faa896bcb56d3682404ead6381e25649154b01
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-12-24 23:42:19 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-12-24 23:42:19 +0000

    net-libs/libkvkontakte: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/756685
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 net-libs/libkvkontakte/Manifest                    |   1 -
 .../files/libkvkontakte-5.0.0-fix-warnings.patch   | 386 ---------------------
 .../libkvkontakte/libkvkontakte-5.0.0-r1.ebuild    |  35 --
 net-libs/libkvkontakte/metadata.xml                |   8 -
 profiles/package.mask                              |   7 -
 5 files changed, 437 deletions(-)