Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 75664 - Can't boot the livecd on a G5 xserve
Summary: Can't boot the livecd on a G5 xserve
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: PPC64 Linux
: High critical (vote)
Assignee: ppc64 architecture team
Depends on:
Blocks: 75140
  Show dependency tree
Reported: 2004-12-25 17:53 UTC by Marko Djukic
Modified: 2005-04-16 18:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Marko Djukic 2004-12-25 17:53:02 UTC
Having started yaboot I get the following:

Press <tab> to show the boot options
Welcome to yaboot version 1.3.11
Enter "help" to get some basic usage information
  G3                       * G4                         G5                      
  G3-SMP                     G4-SMP                     G5-SMP                  
boot: G5-SMP debug
Please wait, loading kernel...
   Elf32 kernel loaded...
Loading ramdisk...
ramdisk loaded at 01b00000, size: 441 Kbytes
copying OF device tree...done
starting cpu /cpus/PowerPC,G5...failed: 00000000 
Calling quiesce ...
DO-QUIESCE finishedreturning 0x01400000 from prom_init                          

After this the system seems to hang, and after 5mins the fans get a lot louder and still nothing happens.

I have tried with the different boot options and the minimal CDs too, but always the same result.

Reproducible: Always
Steps to Reproduce:
Comment 1 Marko Djukic 2004-12-25 18:00:57 UTC
Forgot to mention, this is all using the 2004.3 versions of the livecds.
Comment 2 Marko Djukic 2004-12-25 18:33:20 UTC
actually, just realised that the ppc64 minimal livecd for G5 displays somewhat different messages:

boot: G5-devfs debug
Please wait, loading kernel...                                                  
   Elf64 kernel loaded...                                                       
Loading ramdisk...                                                              
ramdisk loaded at 01d00000, size: 917 Kbytes                                    
OF stdout device is: /ht@0,f2000000/pci@3/mac-io@7/escc@13000/ch-a@13020        
command line: root=/dev/ram rw ramdisk_size=11000 cdroot devfs init=/linuxrc dey
memory layout at init:                                                          
  alloc_bottom : 0000000001de6000                                               
  alloc_top    : 0000000040000000                                               
  alloc_top_hi : 0000000080000000                                               
  rmo_top      : 0000000020000000                                               
  ram_top      : 0000000080000000                                               
Looking for displays                                                            
copying OF device tree ...                                                      
Building dt strings...                                                          
Building dt structure...                                                        
Device tree strings 0x00000000021e7000 -> 0x00000000021e835c                    
Device tree struct  0x00000000021e9000 -> 0x0000000002200000                    
Calling quiesce ...                                                             
DO-QUIESCE finishedreturning from prom_init                                     
Comment 3 Tom Gall (RETIRED) gentoo-dev 2005-03-31 19:53:25 UTC
could you please validate this is still the case with the xserve kernel on
Comment 4 Tom Gall (RETIRED) gentoo-dev 2005-04-16 18:42:13 UTC
alrighyt, I'm going to mark this bug as fixed. I've had two reports of success with the named livecd in the previous comment.  
Comment 5 Tom Gall (RETIRED) gentoo-dev 2005-04-16 18:42:30 UTC
stick a fork in it!