Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 756382 - dev-db/redis-6.0.9 - [exception]: Executing test client: ERR Invalid argument 'yes' for CONFIG SET 'oom-score-adj' - Failed t o set current oom_score_adj
Summary: dev-db/redis-6.0.9 - [exception]: Executing test client: ERR Invalid argument...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2020-11-24 21:58 UTC by ernsteiswuerfel
Modified: 2020-11-26 15:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_756382.txt,6.14 KB, text/plain)
2020-11-24 21:58 UTC, ernsteiswuerfel
Details
build.log (redis-6.0.9:20201124-192435.log,252.06 KB, text/plain)
2020-11-24 21:59 UTC, ernsteiswuerfel
Details
build.log (redis-6.0.9:20201126-152218.log,251.20 KB, text/x-log)
2020-11-26 15:28 UTC, ernsteiswuerfel
Details
emerge --info (file_756382.txt,6.09 KB, text/plain)
2020-11-26 15:29 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2020-11-24 21:58:31 UTC
Created attachment 674761 [details]
emerge --info

[...]
[exception]: Executing test client: ERR Invalid argument 'yes' for CONFIG SET 'oom-score-adj' - Failed t
o set current oom_score_adj. Check server logs..
ERR Invalid argument 'yes' for CONFIG SET 'oom-score-adj' - Failed to set current oom_score_adj. Check s
erver logs.
    while executing
"[srv $level "client"] {*}$args"
    (procedure "r" line 7)
    invoked from within
"r config set oom-score-adj yes"
    ("uplevel" body line 6)
    invoked from within
"uplevel 1 $code"
    (procedure "test" line 51)
    invoked from within
"test {CONFIG SET oom-score-adj works as expected} {
            set base [get_oom_score_adj]

            # Enable oom-score-adj, check defaults
     ..."
    ("uplevel" body line 13)
    invoked from within
"uplevel 1 $code "
    (procedure "start_server" line 3)
    invoked from within
"start_server {tags {"oom-score-adj"}} {
        proc get_oom_score_adj {{pid ""}} {
            if {$pid == ""} {
                set pid [srv 0 pid]
..."
    (file "tests/unit/oom-score-adj.tcl" line 5)
    invoked from within
"source $path"
    (procedure "execute_test_file" line 4)
    invoked from within
"execute_test_file $data"
    (procedure "test_client_main" line 10)
    invoked from within
"test_client_main $::test_server_port "
Comment 1 ernsteiswuerfel 2020-11-24 21:59:40 UTC
Created attachment 674764 [details]
build.log
Comment 2 Tomáš Mózes 2020-11-25 19:58:42 UTC
Can you please test with FEATURES=-usersandbox?

>>> Source compiled.
>>> Test phase: dev-db/redis-6.0.9
You are emerging redis-6.0.9 with 'usersandbox' enabled. Expect some test failures or emerge with 'FEATURES=-usersandbox'!
Comment 3 ernsteiswuerfel 2020-11-26 15:28:23 UTC
Re-tested with 'FEATURES=-usersandbox' but still the same test-error.
Comment 4 ernsteiswuerfel 2020-11-26 15:28:46 UTC
Created attachment 675109 [details]
build.log
Comment 5 ernsteiswuerfel 2020-11-26 15:29:08 UTC
Created attachment 675112 [details]
emerge --info