Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 755956 (kf5-portingaids-removal) - [TRACKER] KDE Frameworks PortingAids removal: Code and utilities for transition from kdelibs 4 to Frameworks 5
Summary: [TRACKER] KDE Frameworks PortingAids removal: Code and utilities for transiti...
Status: CONFIRMED
Alias: kf5-portingaids-removal
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://community.kde.org/Frameworks/...
Whiteboard:
Keywords: Tracker
Depends on: 759766 759769 759772 759775 759778 759793 760555 766333 752456 756685 frameworks-5.77-stable 759763 759781 759784 760543 780087
Blocks:
  Show dependency tree
 
Reported: 2020-11-21 15:05 UTC by Andreas Sturmlechner
Modified: 2021-04-04 20:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-11-21 15:05:48 UTC
These are packages that are not going to be part of KF6 so all packages must port away to KF5 proper.

No more revdeps:
kde-frameworks/kjsembed:5
kde-frameworks/kxmlrpcclient:5
Remove KJSEmbed: https://phabricator.kde.org/T11548
Remove KXMLRPCClient: https://phabricator.kde.org/T12157

Remaining list of packages:
kde-frameworks/kdelibs4support:5
kde-frameworks/kdesignerplugin:5
kde-frameworks/kdewebkit:5
kde-frameworks/khtml:5
kde-frameworks/kjs:5
kde-frameworks/kmediaplayer:5
kde-frameworks/kross:5

Remove KHtml:
https://phabricator.kde.org/T11542
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/khtml

Remove Kross:
https://phabricator.kde.org/T11545
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kross

Remove KDE4 Support:
https://phabricator.kde.org/T11552
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kdelibs4support

Remove KDEWebKit:
https://phabricator.kde.org/T11588
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kdewebkit

Remove KJS:
https://phabricator.kde.org/T11589
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kjs

Remove KDesignerPlugin:
https://phabricator.kde.org/T11590
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kdesignerplugin

Remove KMediaPlayer:
https://phabricator.kde.org/T11591
https://qa-reports.gentoo.org/output/genrdeps/rindex/kde-frameworks/kmediaplayer
Comment 1 Larry the Git Cow gentoo-dev 2020-11-25 11:29:57 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ff3170e6fc6076e7c3542b7a0413fc6f94d85453

commit ff3170e6fc6076e7c3542b7a0413fc6f94d85453
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-11-25 10:54:37 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-11-25 11:29:43 +0000

    profiles: Mask unused KF5 PortingAids for removal
    
    Bug: https://bugs.gentoo.org/755956
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/package.mask | 8 ++++++++
 1 file changed, 8 insertions(+)
Comment 2 Larry the Git Cow gentoo-dev 2020-12-24 23:42:57 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=46c17dcda3172a638f6c396a70ce65344988db23

commit 46c17dcda3172a638f6c396a70ce65344988db23
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-12-24 23:42:22 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-12-24 23:42:22 +0000

    kde-frameworks: Remove last-rited packages
    
    - kde-frameworks/kdewebkit
    - kde-frameworks/kjsembed
    - kde-frameworks/kmediaplayer
    - kde-frameworks/kxmlrpcclient
    
    Bug: https://bugs.gentoo.org/755956
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-frameworks/kdewebkit/Manifest                  |  2 --
 kde-frameworks/kdewebkit/kdewebkit-5.74.0.ebuild   | 40 ----------------------
 kde-frameworks/kdewebkit/kdewebkit-5.76.0.ebuild   | 40 ----------------------
 kde-frameworks/kdewebkit/metadata.xml              | 11 ------
 kde-frameworks/kjsembed/Manifest                   |  2 --
 kde-frameworks/kjsembed/kjsembed-5.74.0.ebuild     | 28 ---------------
 kde-frameworks/kjsembed/kjsembed-5.76.0.ebuild     | 28 ---------------
 kde-frameworks/kjsembed/metadata.xml               |  8 -----
 kde-frameworks/kmediaplayer/Manifest               |  2 --
 .../kmediaplayer/kmediaplayer-5.74.0.ebuild        | 23 -------------
 .../kmediaplayer/kmediaplayer-5.76.0.ebuild        | 23 -------------
 kde-frameworks/kmediaplayer/metadata.xml           |  8 -----
 kde-frameworks/kxmlrpcclient/Manifest              |  2 --
 .../kxmlrpcclient/kxmlrpcclient-5.74.0.ebuild      | 22 ------------
 .../kxmlrpcclient/kxmlrpcclient-5.76.0.ebuild      | 22 ------------
 kde-frameworks/kxmlrpcclient/metadata.xml          |  8 -----
 profiles/package.mask                              |  8 -----
 17 files changed, 277 deletions(-)
Comment 3 Larry the Git Cow gentoo-dev 2021-01-11 12:28:31 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cb74ede3a62de5ee3a1627d83fe349a2198bde81

commit cb74ede3a62de5ee3a1627d83fe349a2198bde81
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-01-09 09:43:14 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-01-11 12:28:01 +0000

    profiles: Mask kde-frameworks/kdesignerplugin for removal
    
    Bug: https://bugs.gentoo.org/755956
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 4 Michael Moon 2021-01-14 19:42:38 UTC
# emerge -avc kdesignerplugin

Calculating dependencies                                 ... done!
kde-frameworks/kdesignerplugin-5.74.0 pulled in by:
kde-frameworks/kdelibs4support-5.74.0 requires =kde-frameworks/kdesignerplugin-5.74*:5

# emerge -avc kdesignerplugin kdelibs4support

Calculating dependencies                      ... done!      
kde-frameworks/kdelibs4support-5.74.0 pulled in by:
kde-apps/konqueror-20.08.3 requires >=kde-frameworks/kdelibs4support-5.74.0:5
kde-plasma/khotkeys-5.19.5 requires >=kde-frameworks/kdelibs4support-5.71.0:5[X]
kde-plasma/plasma-desktop-5.19.5 requires >=kde-frameworks/kdelibs4support-5.71.0:5
kde-plasma/plasma-workspace-5.19.5-r2 requires >=kde-frameworks/kdelibs4support-5.71.0:5

kde-frameworks/kdesignerplugin-5.74.0 pulled in by:
kde-frameworks/kdelibs4support-5.74.0 requires =kde-frameworks/kdesignerplugin-5.74*:5

# emerge -avt1 konqueror khotkeys plasma-desktop plasma-workspace

These are the packages that would be merged, in reverse order:

Calculating dependencies                       ... done!
[ebuild   R    ] kde-plasma/plasma-desktop-5.19.5:5::gentoo  USE="-debug -emoji fontconfig handbook -ibus -scim semantic-desktop -test" 0 KiB
[ebuild   R    ] kde-plasma/khotkeys-5.19.5:5::gentoo  USE="-debug handbook" 0 KiB
[ebuild   R    ] kde-apps/konqueror-20.08.3:5::gentoo  USE="X activities -debug handbook -speech -test" 0 KiB
[ebuild   R    ] kde-plasma/plasma-workspace-5.19.5-r2:5::gentoo  USE="-appstream calendar -debug -geolocation -gps handbook -qalculate -qrcode semantic-desktop -systemd -telemetry -test" 0 KiB

Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB

Is my portage confused?
Comment 5 Andreas Sturmlechner gentoo-dev 2021-01-14 19:44:32 UTC
No one said you could remove kdelibs4support.

This is not a bug for user support.
Comment 6 Igor Franchuk 2021-01-26 10:33:25 UTC
> Is my portage confused?

No, kdelibs4support-5.77.0.ebuild kdelibs4support-5.78.0.ebuild were both patched with 

kdelibs4support-5.78.0-no-kdesignerplugin.patch
kdelibs4support-5.77.0-no-kdesignerplugin.patch

and your 5.74 is still depends on kdesignerplugin, to continue to use 5.74 you would need to move kdesignerplugin to a local portage tree, alternatively you may try to upgrade 5.74 framework to the latest with

emerge -pv $(eix --only-names -I kde-frameworks/)
Comment 7 Igor Franchuk 2021-01-26 11:37:06 UTC
(In reply to Michael Moon from comment #4)
> # emerge -avc kdesignerplugin
> 

in other words you would still have to keep kdelibs4support but starting from 
kdelibs4support-5.77 it's not longer depends on kdesignerplugin, once kdelibs4support-5.77 is upgraded to >=kdelibs4support-5.77 you can safely unmerge
kdesignerplugin which is deprecated by KDE team
Comment 8 Larry the Git Cow gentoo-dev 2021-02-12 12:01:57 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ad7861af53156bb6b607c03756363a4aaf6a4241

commit ad7861af53156bb6b607c03756363a4aaf6a4241
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-02-12 10:34:42 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-02-12 11:57:12 +0000

    kde-frameworks/kdesignerplugin: Remove last-rited package
    
    Bug: https://bugs.gentoo.org/755956
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-frameworks/kdesignerplugin/Manifest            |  2 --
 .../kdesignerplugin/kdesignerplugin-5.74.0.ebuild  | 25 ----------------------
 .../kdesignerplugin/kdesignerplugin-5.77.0.ebuild  | 25 ----------------------
 kde-frameworks/kdesignerplugin/metadata.xml        |  8 -------
 profiles/package.mask                              |  5 -----
 5 files changed, 65 deletions(-)