Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 755944 - net-im/signal-desktop-bin - Audio calling does not work with media-sound/apulse
Summary: net-im/signal-desktop-bin - Audio calling does not work with media-sound/apulse
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robert G. Siebeck
Depends on:
Reported: 2020-11-21 14:10 UTC by Daniel Pielmeier
Modified: 2021-02-18 15:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

signal desktop call log (signal-desktop.log,116.67 KB, text/plain)
2020-11-25 18:29 UTC, Daniel Pielmeier
signal desktop call log (signal-desktop.log,91.52 KB, text/plain)
2020-11-25 18:41 UTC, Daniel Pielmeier

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Pielmeier gentoo-dev 2020-11-21 14:10:07 UTC
In bug #745216 media-sound/pulseaudio was added to enable audio calling in signal-desktop-bin. With bug #747775 media-sound/apulse was added as an alternative to pulseaudio.

As I don't want pulseaudio on my system I tried to get it work wit apulse. However never got audio calling to work.

The call is established, video from the other side is working. Can not test own video as there is no camera. However there is no sound on either side. Looking at the device settings neither microphone nor speaker is detected.

For completeness camera and microphone access is granted.

Would be great if someone has a solution to this problem!
Comment 1 Robert G. Siebeck 2020-11-24 22:49:43 UTC
Do you have any logs from Signal or apulse?

Does audio work with any other applications using apulse?
Comment 2 Daniel Pielmeier gentoo-dev 2020-11-25 18:29:16 UTC
Created attachment 674998 [details]
signal desktop call log

Don't know if there are any logs from apulse but I can give you the log from signal-desktop.

At 2020-11-25T17:26:41.022Z I start an audio call.
At 2020-11-25T17:27:16.282Z I am receiving an audio call

The only errors from the log are what I already reported. No audio devices are detected:
ERROR 2020-11-25T17:26:41.045Z src/webrtc/ getAudioRecordingDevices() returned -1
ERROR 2020-11-25T17:26:41.046Z src/webrtc/ getAudioPlayoutDevices() returned -1

Also would be great for any hints on how to try apulse with other applications. There is only a handful around. Also how do I verify that I am actually using apulse?

I run firefox wit "apulse /usr/bin/firefox" and was able to listen to audio.

Don't have a lot of experience her as I always tried to avoid pulseaudio and apulse.
Comment 3 Daniel Pielmeier gentoo-dev 2020-11-25 18:41:34 UTC
Created attachment 675001 [details]
signal desktop call log

Oh I was stupid!

I forgot to add apulse to my starter as I do not start signal-desktop from the start menu.

Now the devices are detected but it still does not work!

If I get called and I answer signal freezes and I have to kill it. If I call somebody and he answers the call it continues ringing on my side even if the other side discontinues the call and I also have to kill it.

However there are no errors any more in the log!

Outgoing call 2020-11-25T18:34:01.267Z
Incoming call 2020-11-25T18:35:05.105Z
Comment 4 Robert G. Siebeck 2020-11-27 22:41:00 UTC
(In reply to Daniel Pielmeier from comment #2)
> I run firefox wit "apulse /usr/bin/firefox" and was able to listen to audio.

Have you tried whether recording audio works? You could check with Firefox.
Comment 5 Daniel Pielmeier gentoo-dev 2020-11-29 13:28:56 UTC
I think I found the issue.

I use two sound cards:
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]

In my .asoundrc I use the dmix plugin to enable output on more than one application and the multi plugin to enable the output on both devices PCH and HDMI at once.

While dmixing was okay, as soon as I enabled the multi plugin it fails. Furthermore it even fails when setting HDMI as default device (without multi plugin). So it seems signal-desktop has problems with HDMI devices.

If I set the PCH device as default, audio calling works fine.