Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 7554 - PySol cannot find the Tkinter Python libraries.
Summary: PySol cannot find the Tkinter Python libraries.
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Nick Hadaway
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-05 15:03 UTC by Jan Schubert
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Schubert 2002-09-05 15:03:33 UTC
This bugs refers to the closed bug 4849. Because no one is responding to my  
additional comment there i've to open a new one. My system is up to date, i've 
also tried to (un)merge pysol and python some times... 
 
TiA, 
Jan 
 
------------- 
  
jan@toral jan $ pysol  
Traceback (most recent call last):  
  File "pysol.py", line 117, in ?  
  File "/usr/lib/python2.2/lib-tk/Tkinter.py", line 35, in ?  
    import _tkinter # If this fails your Python may not be configured for Tk  
ImportError: No module named _tkinter  
  
PySol cannot find the Tkinter Python libraries.  
Please check your Python installation.
Comment 1 Jan Schubert 2002-09-05 15:45:20 UTC
It will be solved if you recompile python using USE="tcltk". I had to do it  
more than one times until it worked, is ther anything different netween  
"emerge python" and "emerge -u python"?. 
 
However, it should be checked while installing pysol... 
Comment 2 Jon Nelson (RETIRED) 2002-09-24 15:56:47 UTC
Python should just need to be rebuilt using the "tcltk" 
Try to build using python-2.2.1-r4, which is currently masked.

Comment 3 Scott Robbins 2002-09-30 20:03:41 UTC
That solution, of re-emerging python with USE tcltk worked perfectly for me.  
Is it worth considering adding some sort of mesage to the ebuild, something 
like echo "Before emerging pysol, please be sure...blah blah"

Thanks--very simple and efficient fix.

Scott
Comment 4 Grant Goodyear (RETIRED) gentoo-dev 2002-12-04 10:57:48 UTC
Efforts to add USE flags to dependencies in portage are in the works; see bug
#2272.  I'm going to mark this bug as a duplicate of 2272, now that I've added a
note in the pysol ebuild.

*** This bug has been marked as a duplicate of 2272 ***