Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 754879 - virtual/jack: is not satified by jack2 on user's system (because of missing ABI_X86 USE flag not shown)
Summary: virtual/jack: is not satified by jack2 on user's system (because of missing A...
Status: RESOLVED DUPLICATE of bug 164457
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-16 07:41 UTC by José Pekkarinen
Modified: 2020-11-16 19:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Pekkarinen 2020-11-16 07:41:27 UTC
Hi,

I have removed virtual/jack and jack-audio-connection-kit by
brute force(emerge -C) and pulled in jack2. Despite that virtual/jack
stating the following:

|| (
                media-sound/jack2[${MULTILIB_USEDEP}]
                media-sound/jack-audio-connection-kit[${MULTILIB_USEDEP}]
        )

When I do an emerge -puND world I can see this:

[blocks B      ] media-sound/jack-audio-connection-kit:0 ("media-sound/jack-audio-connection-kit:0" is blocking media-sound/jack2-1.9.14)
                                                           
 * Error: The above package list contains packages which cannot be                                                    
 * installed at the same time on the same system.          
                                                           
  (media-sound/jack-audio-connection-kit-0.125.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by                                                                                                                                   
    media-sound/jack-audio-connection-kit[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-sound/jack-audio-connection-kit[abi_x86_32(-),abi_x86_64(
-)]) required by (virtual/jack-1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="32 (64) (-x32)"             
                                                           
  (media-sound/jack2-1.9.14:2/2::gentoo, installed) pulled in by                                                      
    media-sound/jack2 required by @selected

The expected would be that virtual/jack would find jack2 and be happy,
instead it tries the rollback to jack-1.

Thanks!

José.
Comment 1 Sam James archtester gentoo-dev Security 2020-11-16 07:47:27 UTC
We need to find out what needs jack-audio-connection-kit (see bug 602898).

Do you use mednafen (bug 684088) on your system?

Note that this is more of a support question but it is possible there's some vague actual problem here so I'll keep it open for now.
Comment 2 Sam James archtester gentoo-dev Security 2020-11-16 07:48:12 UTC
Ohhh, and check media-sound/jack2 is installed with the same ABI_X86 flags.
Comment 3 José Pekkarinen 2020-11-16 08:04:42 UTC
I'm not using mednafen at all, so I would discard 684088, abi differs
though, jack2 goes to 64 only, jack-1 to 32 and 64, buy me some time
and I'll let you know if it fixes the thing by adding the abi to jack2.

José.
Comment 4 José Pekkarinen 2020-11-16 08:06:28 UTC
indeed, by adding the abi my emerge -puND world says this:

[ebuild   R    ] media-sound/jack2-1.9.14  ABI_X86="32*" 
[ebuild  N     ] virtual/jack-1  ABI_X86="32 (64) (-x32)"

Thanks!

José.
Comment 5 Sam James archtester gentoo-dev Security 2020-11-16 19:15:41 UTC
Great!

*** This bug has been marked as a duplicate of bug 164457 ***