Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 75442 - Setting proxy auto-configuration (from a PAC) in Konqueror doesn't work properly
Summary: Setting proxy auto-configuration (from a PAC) in Konqueror doesn't work properly
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2004-12-23 06:38 UTC by Sean E Russell
Modified: 2005-02-14 10:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sean E Russell 2004-12-23 06:38:47 UTC
This is an odd one, and one I thought was a KDE bug until recently.

My corporate firewall requires password authentication to use the proxy, and provides a PAC file for the proxy configuration.  I set up Konqueror to use this PAC file with the "Use the following proxy configuration URL" option in the "Proxy" tab of Konfigure; however, it never prompts me for the proxy password, and eventually gives me a "Timeout on server" error when I try to access any web sites.  If, on the other hand, I manually configure the proxy settings, it *does* prompt me for the password and allow me to access internet sites.  The downside to this is that I can no longer access intranet sites, as Konquerer attempts to route all traffic through the proxy.

Auto-configuration works as it should under Mozilla, so I thought the problem was with KDE.  However, I was recently running the latest version of Knoppix, and configured Konqueror to auto-configure from the PAC -- and it worked!  The version of KDE on Knoppix is 3.3.2, the same version that I'm running under Gentoo, so I'm now thinking that this is a Gentoo specific issue.

The only errors that I see being generated (WRT this issue) are:

konqueror: ERROR: Error in BrowserExtension::actionSlotMap(), unknown action : searchProvider
kio (KRun): ERROR: 0x8a05c90 ERROR 49 Timeout on server
Connection was to at port 80

Is there a way I can further debug this?

Reproducible: Always
Steps to Reproduce:
1. Have an authenticated proxy
2. Provide a PAC file for the proxy
3. Set Konqueror to use the PAC file for proxy settings configuration
4. Attempt to access web sites through the proxy

Actual Results:  
Konqueror responds with "Timeout on server" error. 

Expected Results:  
Web sites should be accessible through a proxy, configured with a PAC file. 

*  kde-base/kdebase 
      Latest version available: 3.3.2 
      Latest version installed: 3.3.2 
Portage 2.0.51-r8 (default-linux/x86/2004.3, gcc-3.3.2, 
glibc-, 2.6.9-gentoo-r9 i686) 
System uname: 2.6.9-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz 
Gentoo Base System version 1.6.7 
Python:              dev-lang/python-2.2.3-r1,dev-lang/python-2.3.4 [2.3.4 
(#1, Dec 14 2004, 23:35:34)] 
dev-lang/python:     2.2.3-r1, 2.3.4 
sys-devel/autoconf:  2.13, 2.59-r6 
sys-devel/automake:  1.5, 1.6.3, 1.8.5-r2, 1.7.9, 1.4_p6, 1.9.3 
sys-devel/libtool:   1.5.10-r1 
virtual/os-headers:  2.4.19-r1, 2.4.22 
CFLAGS="-march=i586 -funroll-loops" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
CXXFLAGS="-march=i586 -funroll-loops" 
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms" 
USE="16bit X alsa avi bash-completion bdf berkdb bitmap-fonts bootsplash 
cdparanoia crypt cups dbmdirectfb divx4linux dnd droproot dv dvd dvdread 
encode escreen exif f77 fam fbcon fbdev ffmpeg flac fluidsynth foomaticdb 
fortran freetype gcj ggi gif gnuplot gpm iconv imagemagick imap imlib j2ee 
jabber java javacomm javadoc javamail javascript jce jikes jit jpeg jpeg2k 
junit jython kde koffice-plugin lcd ldap libg++ libwww lzw lzw-tiff mad 
maildir md5sum mime mjpeg mng mpeg ncurses ocaml oggvorbis openal opengl 
openntpd openssh oracle pam perl physfs png posix python qmail qt readline 
real rhino ruby samba sdl servlet-2.4 slang speex spell sqlite sqlite3 ssl svg 
tcpd tiff transparent-proxy truetype truetype-fonts unicode usb vim vim-pager 
vim-with-x vnc wxwindows x86 xml2 xmlrpc xmms xsl xv yp zlib"
Comment 1 Gregorio Guidi (RETIRED) gentoo-dev 2004-12-23 08:33:18 UTC
Well, this could still be a kde bug that's not triggered by knoppix default
configuration. There are bugs similar to this one in, such as
which suggest to run
# KDE_NO_IPV6=1 konqueror
Comment 2 Sean E Russell 2004-12-23 09:15:52 UTC
Yes, that bug does look similar (although my Konquerer never locked up; it just timed out).  I tried 'KDE_NO_IPV6=1 konqueror', and when that didn't work, I went in and modified startkde and added an export there.  After logging out and back in again, I made sure that KDE_NO_IPV6 was set in Konsole, and then fired up konquerer -- and it still didn't work.  So I don't think that the IPV6 issue is one that is biting me.

Thanks for the reply, though.
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2004-12-24 03:57:00 UTC
Since we cannot reproduce your setup, it's difficult for us to be helpful, 
sorry. I can only suggest to start editing your .pac file to see if you can
point out a troublesome part. You can start from a minimal config, such as:

function FindProxyForURL(url, host) 
    return "PROXY your.proxy:port";

or something like that (I'm no expert). If you find something interesting, it
could be worth reporting the bug at kde.
Comment 4 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-12 09:49:22 UTC
See previous comment.
Comment 5 Sean E Russell 2005-02-14 10:11:41 UTC
Well, I'm recently running KDE3.4 beta 2, and it seems that the problem has been solved in that branch.  The last KDE 3.3 version I tried, Konqueror crashed regularly and had really bizarre behavior with the document references toolbar, but KDE3.4 is -- so far -- much more stable.  So, as far as I'm concerned, you can close this bug.