Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 753629 - x11-drivers/nvidia-drivers-455.38 modules do not load with kernel >5.8
Summary: x11-drivers/nvidia-drivers-455.38 modules do not load with kernel >5.8
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: David Seifert
Depends on:
Reported: 2020-11-09 01:56 UTC by Saul Peebsen
Modified: 2021-03-02 22:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Saul Peebsen 2020-11-09 01:56:25 UTC
Kernel module nvidia_uvm fails to load with following error:
nvidia_uvm: Unknown symbol radix_tree_preloads (err -2)
nVidia announcement: "Due to an incompatibility issue, we advise customers to defer updating to Linux Kernel 5.9+ until mid-November when an NVIDIA Linux GPU driver update with Kernel 5.9+ support is expected to be available. Linux Kernel 5.9+ is incompatible with current and previous NVIDIA Linux GPU drivers."

Reproducible: Always

Steps to Reproduce:
1. Install kernel 5.9
2. Build nvidia modules
3. Load nvidia modules
Actual Results:  
Module nvidia loads, nvidia_uvm fails to load. As a result CUDA will not execute.

Expected Results:  
All modules load and are functional.
Comment 1 Ionen Wolkens 2020-11-09 03:30:52 UTC
More precisely this bug applies to >=nvidia-drivers-450.80.02[uvm]

May be good to keep the bug open for reference until nvidia fix it but don't think much can done here, or at most "maybe" a ebuild warning when USE=uvm + kernel >=5.9.

It's possible to workaround by patching the kernel (see bug #747028 comment #8), not that a patch to circumvent license restrictions is something gentoo should add, but users are free to do what they want.

Otherwise, if you need USE=uvm / cuda / opencl / nvenc / etc..., do as nvidia advise. For common usage (games, vdpau) then 5.9 is known to be fine.
Comment 2 Ionen Wolkens 2021-03-02 22:32:57 UTC
All in-tree modules now have full 5.10 support and I don't believe this is relevant anymore.