Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 753242 (kde-apps-20.08.3-stable) - KDE Release Service 20.08.3 stabilisation
Summary: KDE Release Service 20.08.3 stabilisation
Status: RESOLVED FIXED
Alias: kde-apps-20.08.3-stable
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2020-11-26
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: CC-ARCHES
Depends on: 751337 754159 755107
Blocks: qtwebkit-removal 735368
  Show dependency tree
 
Reported: 2020-11-05 19:11 UTC by Andreas Sturmlechner
Modified: 2020-11-27 08:58 UTC (History)
5 users (show)

See Also:
Package list:
kde-apps/kdialog-20.08.3 amd64 arm64 x86 kde-apps/keditbookmarks-20.08.3 amd64 arm64 x86 kde-apps/kfind-20.08.3 amd64 arm64 x86 kde-apps/konqueror-20.08.3 amd64 arm64 x86 kde-apps/baloo-widgets-20.08.3 amd64 arm64 x86 kde-apps/dolphin-20.08.3 amd64 arm64 x86 kde-apps/kate-20.08.3 amd64 arm64 x86 media-gfx/kgraphviewer-2.4.3-r1 amd64 arm64 x86 kde-apps/kde-apps-meta-20.08.3 amd64 arm64 x86 kde-apps/kdecore-meta-20.08.3 amd64 arm64 x86 kde-apps/khelpcenter-20.08.3 amd64 arm64 x86 kde-apps/konsole-20.08.3 amd64 arm64 x86 kde-apps/kwrite-20.08.3 amd64 arm64 x86 kde-apps/kdeaccessibility-meta-20.08.3 amd64 arm64 x86 app-accessibility/kontrast-1.0.2 amd64 arm64 x86 kde-apps/kmag-20.08.3 amd64 arm64 x86 kde-apps/kmousetool-20.08.3 amd64 arm64 x86 kde-apps/kmouth-20.08.3 amd64 arm64 x86 kde-apps/kdeadmin-meta-20.08.3 amd64 arm64 x86 kde-apps/kcron-20.08.3 amd64 arm64 x86 kde-apps/ksystemlog-20.08.3 amd64 arm64 x86 kde-apps/analitza-20.08.3 amd64 arm64 x86 kde-apps/artikulate-20.08.3 amd64 arm64 x86 kde-apps/blinken-20.08.3 amd64 arm64 x86 kde-apps/cantor-20.08.3 amd64 arm64 x86 kde-apps/kalgebra-20.08.3 amd64 arm64 x86 kde-apps/kalzium-20.08.3 amd64 arm64 x86 kde-apps/kanagram-20.08.3 amd64 arm64 x86 kde-apps/kbruch-20.08.3 amd64 arm64 x86 kde-apps/kdeedu-data-20.08.3 amd64 arm64 x86 kde-apps/kdeedu-meta-20.08.3 amd64 arm64 x86 kde-apps/kgeography-20.08.3 amd64 arm64 x86 kde-apps/khangman-20.08.3 amd64 arm64 x86 kde-apps/kig-20.08.3 amd64 arm64 x86 kde-apps/kiten-20.08.3 amd64 arm64 x86 kde-apps/klettres-20.08.3 amd64 arm64 x86 kde-apps/kmplot-20.08.3 amd64 arm64 x86 kde-apps/kqtquickcharts-20.08.3 amd64 arm64 x86 kde-apps/ktouch-20.08.3 amd64 arm64 x86 kde-apps/kturtle-20.08.3 amd64 arm64 x86 kde-apps/kwordquiz-20.08.3 amd64 arm64 x86 kde-apps/libkeduvocdocument-20.08.3 amd64 arm64 x86 kde-apps/marble-20.08.3 amd64 arm64 x86 kde-apps/minuet-20.08.3 amd64 arm64 x86 kde-apps/parley-20.08.3 amd64 arm64 x86 kde-apps/rocs-20.08.3 amd64 arm64 x86 kde-apps/step-20.08.3 amd64 arm64 x86 kde-apps/bomber-20.08.3 amd64 arm64 x86 kde-apps/bovo-20.08.3 amd64 arm64 x86 kde-apps/granatier-20.08.3 amd64 arm64 x86 kde-apps/kajongg-20.08.3 amd64 arm64 x86 kde-apps/kapman-20.08.3 amd64 arm64 x86 kde-apps/katomic-20.08.3 amd64 arm64 x86 kde-apps/kblackbox-20.08.3 amd64 arm64 x86 kde-apps/kblocks-20.08.3 amd64 arm64 x86 kde-apps/kbounce-20.08.3 amd64 arm64 x86 kde-apps/kbreakout-20.08.3 amd64 arm64 x86 kde-apps/kdegames-meta-20.08.3 amd64 arm64 x86 kde-apps/kdiamond-20.08.3 amd64 arm64 x86 kde-apps/kfourinline-20.08.3 amd64 arm64 x86 kde-apps/kgoldrunner-20.08.3 amd64 arm64 x86 kde-apps/kigo-20.08.3 amd64 arm64 x86 kde-apps/killbots-20.08.3 amd64 arm64 x86 kde-apps/kiriki-20.08.3 amd64 arm64 x86 kde-apps/kjumpingcube-20.08.3 amd64 arm64 x86 kde-apps/klickety-20.08.3 amd64 arm64 x86 kde-apps/klines-20.08.3 amd64 arm64 x86 kde-apps/kmahjongg-20.08.3 amd64 arm64 x86 kde-apps/kmines-20.08.3 amd64 arm64 x86 kde-apps/knavalbattle-20.08.3 amd64 arm64 x86 kde-apps/knetwalk-20.08.3 amd64 arm64 x86 kde-apps/knights-20.08.3 amd64 arm64 x86 kde-apps/kolf-20.08.3 amd64 arm64 x86 kde-apps/kollision-20.08.3 amd64 arm64 x86 kde-apps/konquest-20.08.3 amd64 arm64 x86 kde-apps/kpat-20.08.3 amd64 arm64 x86 kde-apps/kreversi-20.08.3 amd64 arm64 x86 kde-apps/kshisen-20.08.3 amd64 arm64 x86 kde-apps/ksirk-20.08.3 amd64 arm64 x86 kde-apps/ksnakeduel-20.08.3 amd64 arm64 x86 kde-apps/kspaceduel-20.08.3 amd64 arm64 x86 kde-apps/ksquares-20.08.3 amd64 arm64 x86 kde-apps/ksudoku-20.08.3 amd64 arm64 x86 kde-apps/ktuberling-20.08.3 amd64 arm64 x86 kde-apps/kubrick-20.08.3 amd64 arm64 x86 kde-apps/libkdegames-20.08.3 amd64 arm64 x86 kde-apps/libkmahjongg-20.08.3 amd64 arm64 x86 kde-apps/lskat-20.08.3 amd64 arm64 x86 kde-apps/palapeli-20.08.3 amd64 arm64 x86 kde-apps/picmi-20.08.3 amd64 arm64 x86 kde-apps/gwenview-20.08.3 amd64 arm64 x86 kde-apps/kamera-20.08.3 amd64 arm64 x86 kde-apps/kcolorchooser-20.08.3 amd64 arm64 x86 kde-apps/kdegraphics-meta-20.08.3 amd64 arm64 x86 kde-apps/kdegraphics-mobipocket-20.08.3 amd64 arm64 x86 kde-apps/kipi-plugins-20.08.3 amd64 arm64 x86 kde-apps/kolourpaint-20.08.3 amd64 arm64 x86 kde-apps/kruler-20.08.3 amd64 arm64 x86 kde-apps/libkdcraw-20.08.3 amd64 arm64 x86 kde-apps/libkexiv2-20.08.3 amd64 arm64 x86 kde-apps/libkipi-20.08.3 amd64 arm64 x86 kde-apps/libksane-20.08.3 amd64 arm64 x86 kde-apps/okular-20.08.3 amd64 arm64 x86 kde-apps/spectacle-20.08.3 amd64 arm64 x86 kde-apps/svgpart-20.08.3 amd64 arm64 x86 kde-apps/thumbnailers-20.08.3 amd64 arm64 x86 kde-apps/audiocd-kio-20.08.3 amd64 arm64 x86 kde-apps/dragon-20.08.3 amd64 arm64 x86 kde-apps/ffmpegthumbs-20.08.3 amd64 arm64 x86 kde-apps/juk-20.08.3 amd64 arm64 x86 kde-apps/k3b-20.08.3 amd64 arm64 x86 kde-apps/kamoso-20.08.3 amd64 arm64 x86 kde-apps/kdemultimedia-meta-20.08.3 amd64 arm64 x86 kde-apps/kdenlive-20.08.3 amd64 arm64 x86 kde-apps/kmix-20.08.3 amd64 arm64 x86 kde-apps/kwave-20.08.3 amd64 arm64 x86 kde-apps/libkcddb-20.08.3 amd64 arm64 x86 kde-apps/libkcompactdisc-20.08.3 amd64 arm64 x86 media-sound/elisa-20.08.3 amd64 arm64 x86 kde-apps/dolphin-plugins-dropbox-20.08.3 amd64 x86 kde-apps/kaccounts-integration-20.08.3 amd64 arm64 x86 kde-apps/kaccounts-providers-20.08.3 amd64 arm64 x86 kde-apps/kdenetwork-meta-20.08.3-r1 amd64 arm64 x86 kde-apps/kdenetwork-filesharing-20.08.3 amd64 arm64 x86 kde-apps/kget-20.08.3 amd64 arm64 x86 kde-apps/kio-extras-20.08.3 amd64 arm64 x86 kde-apps/krdc-20.08.3 amd64 arm64 x86 kde-apps/krfb-20.08.3 amd64 arm64 x86 kde-apps/kopete-20.08.3 amd64 arm64 x86 kde-apps/ktp-accounts-kcm-20.08.3 amd64 arm64 x86 kde-apps/ktp-approver-20.08.3 amd64 arm64 x86 kde-apps/ktp-auth-handler-20.08.3 amd64 arm64 x86 kde-apps/ktp-call-ui-20.08.3 amd64 arm64 x86 kde-apps/ktp-common-internals-20.08.3 amd64 arm64 x86 kde-apps/ktp-contact-list-20.08.3 amd64 arm64 x86 kde-apps/ktp-contact-runner-20.08.3 amd64 arm64 x86 kde-apps/ktp-desktop-applets-20.08.3 amd64 arm64 x86 kde-apps/ktp-filetransfer-handler-20.08.3 amd64 arm64 x86 kde-apps/ktp-kded-module-20.08.3 amd64 arm64 x86 kde-apps/ktp-send-file-20.08.3 amd64 arm64 x86 kde-apps/ktp-text-ui-20.08.3 amd64 arm64 x86 kde-apps/plasma-telepathy-meta-20.08.3 amd64 arm64 x86 kde-apps/signon-kwallet-extension-20.08.3 amd64 arm64 x86 kde-apps/zeroconf-ioslave-20.08.3 amd64 arm64 x86 kde-misc/kdeconnect-20.08.3 amd64 arm64 x86 kde-misc/kio-gdrive-20.08.3 amd64 arm64 x86 kde-apps/akonadi-20.08.3 amd64 arm64 x86 kde-apps/akonadi-calendar-20.08.3 amd64 arm64 x86 kde-apps/akonadi-contacts-20.08.3 amd64 arm64 x86 kde-apps/akonadi-import-wizard-20.08.3 amd64 arm64 x86 kde-apps/akonadi-mime-20.08.3 amd64 arm64 x86 kde-apps/akonadi-notes-20.08.3 amd64 arm64 x86 kde-apps/akonadi-search-20.08.3 amd64 arm64 x86 kde-apps/akonadiconsole-20.08.3 amd64 arm64 x86 kde-apps/akregator-20.08.3 amd64 arm64 x86 kde-apps/calendarjanitor-20.08.3 amd64 arm64 x86 kde-apps/calendarsupport-20.08.3 amd64 arm64 x86 kde-apps/eventviews-20.08.3 amd64 arm64 x86 kde-apps/grantlee-editor-20.08.3 amd64 arm64 x86 kde-apps/grantleetheme-20.08.3 amd64 arm64 x86 kde-apps/incidenceeditor-20.08.3 amd64 arm64 x86 kde-apps/kaddressbook-20.08.3 amd64 arm64 x86 kde-apps/kalarm-20.08.3 amd64 arm64 x86 kde-apps/kalarmcal-20.08.3 amd64 arm64 x86 kde-apps/kcalutils-20.08.3 amd64 arm64 x86 kde-apps/kdepim-addons-20.08.3 amd64 arm64 x86 kde-apps/kdepim-apps-libs-20.08.3 amd64 arm64 x86 kde-apps/kdepim-meta-20.08.3 amd64 arm64 x86 kde-apps/kdepim-runtime-20.08.3 amd64 arm64 x86 kde-apps/kidentitymanagement-20.08.3 amd64 arm64 x86 kde-apps/kimap-20.08.3 amd64 arm64 x86 kde-apps/kitinerary-20.08.3 amd64 arm64 x86 media-libs/zxing-cpp-1.1.1 amd64 arm64 x86 kde-apps/kldap-20.08.3 amd64 arm64 x86 kde-apps/kleopatra-20.08.3 amd64 arm64 x86 kde-apps/kmail-20.08.3 amd64 arm64 x86 kde-apps/kmail-account-wizard-20.08.3 amd64 arm64 x86 kde-apps/kmailtransport-20.08.3 amd64 arm64 x86 kde-apps/kmbox-20.08.3 amd64 arm64 x86 kde-apps/kmime-20.08.3 amd64 arm64 x86 kde-apps/knotes-20.08.3 amd64 arm64 x86 kde-apps/konsolekalendar-20.08.3 amd64 arm64 x86 kde-apps/kontact-20.08.3 amd64 arm64 x86 kde-apps/kontactinterface-20.08.3 amd64 arm64 x86 kde-apps/korganizer-20.08.3 amd64 arm64 x86 kde-apps/kpimtextedit-20.08.3 amd64 arm64 x86 kde-apps/kpkpass-20.08.3 amd64 arm64 x86 kde-apps/ksmtp-20.08.3 amd64 arm64 x86 kde-apps/libgravatar-20.08.3 amd64 arm64 x86 kde-apps/libkdepim-20.08.3 amd64 arm64 x86 kde-apps/libkgapi-20.08.3 amd64 arm64 x86 kde-apps/libkleo-20.08.3 amd64 arm64 x86 kde-apps/libksieve-20.08.3 amd64 arm64 x86 kde-apps/libktnef-20.08.3 amd64 arm64 x86 kde-apps/mailcommon-20.08.3 amd64 arm64 x86 kde-apps/mailimporter-20.08.3 amd64 arm64 x86 kde-apps/mbox-importer-20.08.3 amd64 arm64 x86 kde-apps/messagelib-20.08.3 amd64 arm64 x86 kde-apps/pim-data-exporter-20.08.3 amd64 arm64 x86 kde-apps/pim-sieve-editor-20.08.3 amd64 arm64 x86 kde-apps/pimcommon-20.08.3 amd64 arm64 x86 kde-apps/cervisia-20.08.3 amd64 arm64 x86 kde-apps/dolphin-plugins-git-20.08.3 amd64 arm64 x86 kde-apps/dolphin-plugins-mercurial-20.08.3 amd64 arm64 x86 kde-apps/dolphin-plugins-subversion-20.08.3 amd64 arm64 x86 kde-apps/kapptemplate-20.08.3 amd64 arm64 x86 kde-apps/kcachegrind-20.08.3 amd64 arm64 x86 kde-apps/kde-dev-scripts-20.08.3 amd64 arm64 x86 kde-apps/kde-dev-utils-20.08.3 amd64 arm64 x86 kde-apps/kdesdk-meta-20.08.3 amd64 arm64 x86 kde-apps/kdesdk-kioslaves-20.08.3 amd64 arm64 x86 kde-apps/kdesdk-thumbnailers-20.08.3 amd64 arm64 x86 kde-apps/kompare-20.08.3 amd64 arm64 x86 kde-apps/kross-interpreters-20.08.3 amd64 arm64 x86 kde-apps/libkomparediff2-20.08.3 amd64 arm64 x86 kde-apps/lokalize-20.08.3 amd64 arm64 x86 kde-apps/poxml-20.08.3 amd64 arm64 x86 kde-apps/umbrello-20.08.3 amd64 arm64 x86 kde-apps/ark-20.08.3 amd64 arm64 x86 kde-apps/filelight-20.08.3 amd64 arm64 x86 kde-apps/kbackup-20.08.3 amd64 arm64 x86 kde-apps/kcalc-20.08.3 amd64 arm64 x86 kde-apps/kcharselect-20.08.3 amd64 arm64 x86 kde-apps/kdebugsettings-20.08.3 amd64 arm64 x86 kde-apps/kdeutils-meta-20.08.3 amd64 arm64 x86 app-cdr/dolphin-plugins-mountiso-20.08.3 amd64 arm64 x86 kde-apps/kdf-20.08.3 amd64 arm64 x86 kde-apps/kfloppy-20.08.3 amd64 arm64 x86 kde-apps/kgpg-20.08.3 amd64 arm64 x86 kde-apps/kimagemapeditor-20.08.3 amd64 arm64 x86 kde-apps/kteatime-20.08.3 amd64 arm64 x86 kde-apps/ktimer-20.08.3 amd64 arm64 x86 kde-apps/kwalletmanager-20.08.3 amd64 arm64 x86 kde-apps/print-manager-20.08.3 amd64 arm64 x86 kde-apps/sweeper-20.08.3 amd64 arm64 x86 kde-apps/yakuake-20.08.3 amd64 arm64 x86 app-admin/system-config-printer-1.5.13 app-cdr/kcdemu-0.8.0 amd64 x86 app-office/libalkimia-8.0.4 amd64 x86 dev-games/freecell-solver-6.2.0 amd64 arm64 x86 dev-perl/Moo-2.3.3 amd64 arm64 x86 dev-perl/Class-Method-Modifiers-2.130.0 amd64 arm64 x86 dev-libs/rinutils-0.6.0 amd64 arm64 x86 kde-misc/krename-5.0.1 amd64 x86 net-irc/konversation-1.7.7-r1 amd64 x86 dev-util/clazy-1.7-r1 amd64 arm64 x86 kde-misc/markdownpart-0.1.1 arm64 x86
Runtime testing required: ---
nattka: sanity-check+


Attachments
logs_test_errors.tar.gz (logs_test_errors.tar.gz,277.09 KB, application/octet-stream)
2020-11-20 23:39 UTC, Frank Krömmelbein
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2020-11-05 19:11:43 UTC
In preparation.
Comment 1 NATTkA bot gentoo-dev 2020-11-05 19:12:51 UTC Comment hidden (obsolete)
Comment 2 Andreas Sturmlechner gentoo-dev 2020-11-05 19:27:36 UTC
Adding:
app-admin/system-config-printer-1.5.12-r2
app-cdr/kcdemu-0.8.0
app-office/libalkimia-8.0.4
dev-games/freecell-solver-6.2.0
dev-libs/rinutils-0.6.0
dev-python/iniparse-0.5
dev-python/translate-toolkit-2.5.1
kde-misc/krename-5.0.1
net-irc/konversation-1.7.7-r1

Dropping:
kde-apps/kde-meta
kde-apps/kdebase-meta
Comment 3 NATTkA bot gentoo-dev 2020-11-05 19:31:00 UTC Comment hidden (obsolete)
Comment 4 Andreas Sturmlechner gentoo-dev 2020-11-05 19:35:15 UTC
Adding:
sci-mathematics/octave-5.2.0
dev-perl/Moo-2.3.3
Comment 5 NATTkA bot gentoo-dev 2020-11-05 19:38:28 UTC Comment hidden (obsolete)
Comment 6 Andreas Sturmlechner gentoo-dev 2020-11-05 20:00:47 UTC
Moved sci-mathematics/octave-5.2.0 arm64 to bug 709830

Added dev-perl/Class-Method-Modifiers-2.130.0.
Comment 7 NATTkA bot gentoo-dev 2020-11-05 20:02:31 UTC Comment hidden (obsolete)
Comment 8 NATTkA bot gentoo-dev 2020-11-05 20:06:47 UTC Comment hidden (obsolete)
Comment 9 Andreas Sturmlechner gentoo-dev 2020-11-06 15:24:40 UTC
Adding:
app-accessibility/kontrast-1.0.2
dev-util/clazy-1.7-r1
kde-misc/markdownpart-0.1.1
dev-util/kdevelop-php-5.6.0
Comment 10 NATTkA bot gentoo-dev 2020-11-08 10:00:53 UTC
Resetting sanity check; keywords are not fully specified and arches are not CC-ed.
Comment 11 NATTkA bot gentoo-dev 2020-11-08 19:36:52 UTC
Unable to check for sanity:

> no match for package: kde-apps/kdenetwork-meta-20.08.3
Comment 12 Andreas Sturmlechner gentoo-dev 2020-11-08 19:40:23 UTC
Adding:
media-gfx/kgraphviewer-2.4.3-r1
Bumping:
kde-apps/kdenetwork-meta-20.08.3-r1
app-admin/system-config-printer-1.5.13
Comment 13 NATTkA bot gentoo-dev 2020-11-08 19:40:56 UTC
Resetting sanity check; keywords are not fully specified and arches are not CC-ed.
Comment 14 Frank Krömmelbein 2020-11-19 15:38:58 UTC
1) kde-apps/kdebase-meta-20.08.3 and kde-apps/kde-meta-20.08.3 should removed from the list, both are masked for removal
# Andreas Sturmlechner <asturm@gentoo.org> (2020-10-26)
# Historical metapackage that exists in slot 5 only for transition from KDE SC4.
# Masked for removal on 2021-08-31.
Typo in the date or should the two meta packages really stay in the tree that long ;-)


2) dev-python/iniparse-0.5 and dev-python/translate-toolkit-2.5.1 could also removed from the list, both are already stable on all relevant archs.
Keywords for dev-python/iniparse:
       |                             |   u   |  
       | a   a     p s     a   r     |   n   |  
       | m   r h   p p   s l i i m m | e u s | r
       | d a m p p c a x 3 p a s 6 i | a s l | e
       | 6 r 6 p p 6 r 8 9 h 6 c 8 p | p e o | p
       | 4 m 4 a c 4 c 6 0 a 4 v k s | i d t | o
-------+-----------------------------+-------+-------
0.4-r2 | + o + o o o o + o o o o o o | 7 # 0 | gentoo
0.5    | + o + o o o o + o o o o o o | 7 o   | gentoo

Keywords for dev-python/translate-toolkit:
      |                             |   u   |  
      | a   a     p s     a   r     |   n   |  
      | m   r h   p p   s l i i m m | e u s | r
      | d a m p p c a x 3 p a s 6 i | a s l | e
      | 6 r 6 p p 6 r 8 9 h 6 c 8 p | p e o | p
      | 4 m 4 a c 4 c 6 0 a 4 v k s | i d t | o
------+-----------------------------+-------+-------
2.5.1 | + o + o o o o + o o o o o o | 7 o 0 | gentoo
3.2.0 | ~ o ~ o o o o ~ o o o o o o | 7 o   | gentoo


3) Arch specific changes to the stable list
-media-gfx/kgraphviewer-2.4.3-r1 ^
+media-gfx/kgraphviewer-2.4.3-r1 arm64 x86

-dev-perl/Moo-2.3.3 ^
+dev-perl/Moo-2.3.3 arm64

-dev-perl/Class-Method-Modifiers-2.130.0 ^
+dev-perl/Class-Method-Modifiers-2.130.0 arm64


4) For the sake of completeness, automagic dependencies for umbrello
>>> Unmerging (1 of 2) media-libs/woff2-1.0.2-r2...
>>> needed   obj /usr/lib64/libwoff2common.so.1.0.2
>>> needed   obj /usr/lib64/libwoff2dec.so.1.0.2
>>> Unmerging (2 of 2) dev-qt/qtwebkit-5.212.0_pre20200309-r1...
>>> needed   sym /usr/lib64/libQt5WebKit.so.5
>>> needed   obj /usr/lib64/libQt5WebKit.so.5.212.0
>>> needed   sym /usr/lib64/libQt5WebKitWidgets.so.5
>>> needed   obj /usr/lib64/libQt5WebKitWidgets.so.5.212.0

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-qt/qtwebkit-5.212.0_pre20200309-r1
 *  - /usr/lib64/libQt5WebKitWidgets.so.5
 *  - /usr/lib64/libQt5WebKitWidgets.so.5.212.0
 *      used by /usr/bin/umbrello5 (kde-apps/umbrello-20.08.3)
 *  - /usr/lib64/libQt5WebKit.so.5
 *  - /usr/lib64/libQt5WebKit.so.5.212.0
>>> package: media-libs/woff2-1.0.2-r2
 *  - /usr/lib64/libwoff2dec.so.1.0.2
 *      used by /usr/lib64/libQt5WebKit.so.5 (preserved)
 *      used by /usr/lib64/libQt5WebKit.so.5.212.0 (preserved)
 *  - /usr/lib64/libwoff2common.so.1.0.2
Use emerge @preserved-rebuild to rebuild packages using these libraries



The rest will follow on the weekend.
Comment 15 Andreas Sturmlechner gentoo-dev 2020-11-20 12:35:58 UTC
(In reply to Frank Krömmelbein from comment #14)
> 1) kde-apps/kdebase-meta-20.08.3 and kde-apps/kde-meta-20.08.3 should
> removed from the list, both are masked for removal
Both were already dropped since comment #2, did you use some outdated list?

(In reply to Frank Krömmelbein from comment #14)
> Typo in the date or should the two meta packages really stay in the tree
> that long ;-)
Indeed not a typo, no one should get an excuse why depclean removed all their KDE packages, so there's a long transition period.

(In reply to Frank Krömmelbein from comment #14)
> 2) dev-python/iniparse-0.5 and dev-python/translate-toolkit-2.5.1 could also
> removed from the list, both are already stable on all relevant archs.
Thanks, both dropped.

(In reply to Frank Krömmelbein from comment #14)
> 3) Arch specific changes to the stable list
> -media-gfx/kgraphviewer-2.4.3-r1 ^
> +media-gfx/kgraphviewer-2.4.3-r1 arm64 x86
> 
> -dev-perl/Moo-2.3.3 ^
> +dev-perl/Moo-2.3.3 arm64
> 
> -dev-perl/Class-Method-Modifiers-2.130.0 ^
> +dev-perl/Class-Method-Modifiers-2.130.0 arm64
NATTkA bot will do that for us ;)

(In reply to Frank Krömmelbein from comment #14)
> 4) For the sake of completeness, automagic dependencies for umbrello
> >>> Unmerging (1 of 2) media-libs/woff2-1.0.2-r2...
> >>> needed   obj /usr/lib64/libwoff2common.so.1.0.2
> >>> needed   obj /usr/lib64/libwoff2dec.so.1.0.2
> >>> Unmerging (2 of 2) dev-qt/qtwebkit-5.212.0_pre20200309-r1...
> >>> needed   sym /usr/lib64/libQt5WebKit.so.5
> >>> needed   obj /usr/lib64/libQt5WebKit.so.5.212.0
> >>> needed   sym /usr/lib64/libQt5WebKitWidgets.so.5
> >>> needed   obj /usr/lib64/libQt5WebKitWidgets.so.5.212.0
Very interesting, shouldn't be, will look into it. ;)
Comment 16 NATTkA bot gentoo-dev 2020-11-20 12:38:17 UTC
Sanity check failed:

> kde-apps/kig-20.08.3
>   depend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (3 total)
>     >=dev-libs/boost-1.70:=[python,python_targets_python3_9(-)]
>   depend amd64 stable profile default/linux/amd64/17.1 (34 total)
>     >=dev-libs/boost-1.70:=[python,python_targets_python3_9(-)]
>   rdepend amd64 dev profile default/linux/amd64/17.0/no-multilib/prefix/kernel-3.2+ (3 total)
>     >=dev-libs/boost-1.70:=[python,python_targets_python3_9(-)]
>   rdepend amd64 stable profile default/linux/amd64/17.1 (34 total)
>     >=dev-libs/boost-1.70:=[python,python_targets_python3_9(-)]
Comment 17 NATTkA bot gentoo-dev 2020-11-20 12:54:36 UTC
All sanity-check issues have been resolved
Comment 18 NATTkA bot gentoo-dev 2020-11-20 14:13:03 UTC
Unable to check for sanity:

> dependent bug #755716 has errors
Comment 19 NATTkA bot gentoo-dev 2020-11-20 14:19:15 UTC
All sanity-check issues have been resolved
Comment 20 Frank Krömmelbein 2020-11-20 23:39:07 UTC
Created attachment 673981 [details]
logs_test_errors.tar.gz

>Both were already dropped since comment #2, did you use some outdated list?
To verify the following test errors, I checked them on a second system. I then use this 2nd system for transferring to bugzilla. Unfortunately there was still a file with the old list :-(


5) Some test failures, all of them i could reproduce on a second system.

 FEATURES=' test' failed for =kde-apps/kget-20.08.3
 FEATURES=' test' failed for =kde-apps/kpat-20.08.3
 FEATURES=' test' failed for =kde-apps/libkgapi-20.08.3
 FEATURES=' test' failed for =kde-apps/okular-20.08.3
 FEATURES=' test' failed for =kde-apps/pim-data-exporter-20.08.3

Ignored use flags: +systemd, +gles2-only
Comment 21 NATTkA bot gentoo-dev 2020-11-23 03:58:34 UTC Comment hidden (obsolete)
Comment 22 Andreas Sturmlechner gentoo-dev 2020-11-25 13:55:57 UTC
As always, thanks for testing Frank!
Comment 23 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-11-25 16:18:43 UTC
amd64 stable
Comment 24 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-11-25 16:21:53 UTC
x86 stable
Comment 25 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-11-25 16:40:18 UTC
arm64 stable
Comment 26 Sam James archtester gentoo-dev Security 2020-11-26 14:35:54 UTC
ppc64 done
Comment 27 Sergei Trofimovich gentoo-dev 2020-11-26 23:15:15 UTC
ppc stable
Comment 28 Andreas Sturmlechner gentoo-dev 2020-11-27 08:58:43 UTC
Thanks everyone.