Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 752771 - media-video/vlc: migrate to lua eclasses
Summary: media-video/vlc: migrate to lua eclasses
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: slotted-lua
  Show dependency tree
 
Reported: 2020-11-03 15:37 UTC by Marek Szuba
Modified: 2020-12-07 19:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Szuba gentoo-dev 2020-11-03 15:37:10 UTC
In order for Gentoo Linux to properly support side-by-side installation of
different versions of Lua (including LuaJIT), please migrate this package as
to lua.eclass (for packages which should support multiple Lua implementations
at the same time, i.e. most likely Lua modules) or lua-single.eclass (for
packages which only have to support one Lua implementation at a time). For
details, consult documentation of respective eclasses as well as
already-migrated ebuilds in the tree.

Please note that since slotted dev-lang/lua is currently masked, your
migrated ebuilds should be masked as well. There is a section of package.mask,
created in September 2020, which you can use for this purpose so that it will
be easier in the future to unmask them all in one go.

Thank you in advance for your effort!
Comment 1 Larry the Git Cow gentoo-dev 2020-12-07 18:57:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=797e22a344c611216f9a503a5f5c3dedfd50c220

commit 797e22a344c611216f9a503a5f5c3dedfd50c220
Author:     Marek Szuba <marecki@gentoo.org>
AuthorDate: 2020-12-07 18:54:25 +0000
Commit:     Marek Szuba <marecki@gentoo.org>
CommitDate: 2020-12-07 18:57:20 +0000

    media-video/vlc: migrate to lua-single.eclass
    
    Both the release (build-tested for both supported Lua implementations)
    and the two live ebuilds (not build-tested because git.videolan.org is
    extremely slow now but have confirmed in configure.ac that Lua-detection
    logic hasn't changed and the associated patch applies cleanly - exactly
    for 3.0.9999, with an offset for 9999). Supports 5.1 and 5.2 as per
    upstream checks in configure.ac.
    
    Closes: https://bugs.gentoo.org/752771
    Signed-off-by: Marek Szuba <marecki@gentoo.org>

 .../files/vlc-3.0.11.1-configure_lua_version.patch |  47 ++
 media-video/vlc/vlc-3.0.11.1-r100.ebuild           | 496 +++++++++++++++++++++
 media-video/vlc/vlc-3.0.9999.ebuild                |   9 +-
 media-video/vlc/vlc-9999.ebuild                    |   9 +-
 profiles/package.mask                              |   1 +
 5 files changed, 558 insertions(+), 4 deletions(-)
Comment 2 Marek Szuba gentoo-dev 2020-12-07 19:00:08 UTC
Note that LUA_DEPS appearing in both RDEPEND and BDEPEND is not a typo, vlc build scripts invoke the Lua compiler and we want to make sure the compiler used at build time and the interpreter/library used at run time are the same, just in case,