Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 751766 - www-client/falkon-3.1.0-r1 - libQt5Quick.so.5.14.2: undefined reference to QRhi::newSampler
Summary: www-client/falkon-3.1.0-r1 - libQt5Quick.so.5.14.2: undefined reference to QR...
Status: RESOLVED DUPLICATE of bug 749777
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 751772 751778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-29 16:49 UTC by Silvio
Modified: 2020-10-30 13:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.bz2,41.04 KB, application/x-bzip)
2020-10-29 16:51 UTC, Silvio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio 2020-10-29 16:49:28 UTC
The lines with error


-Wsuggest-override -Wlogical-op -fdiagnostics-color=always  -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed    -rdynamic src/main/CMakeFiles/falkon.dir/falkon_autogen/mocs_compilation.cpp.o src/main/CMakeFiles/falkon.dir/main.cpp.o src/main/CMakeFiles/falkon.dir/ECMQmLoader-falkon_qt.cpp.o  -o bin/falkon  -Wl,-rpath,/var/tmp/portage/www-client/falkon-3.1.0-r1/work/falkon-3.1.0_build/bin:  bin/libFalkonPrivate.so.3.1.0  /usr/lib64/libQt5WebEngineWidgets.so.5.14.2  /usr/lib64/libQt5WebEngineCore.so.5.14.2  /usr/lib64/libQt5Sql.so.5.15.1  /usr/lib64/libQt5PrintSupport.so.5.14.2  /usr/lib64/libQt5QuickWidgets.so.5.14.2  /usr/lib64/libQt5Widgets.so.5.15.1  /usr/lib64/libQt5Quick.so.5.14.2  /usr/lib64/libQt5QmlModels.so.5.14.2  /usr/lib64/libQt5WebChannel.so.5.14.2  /usr/lib64/libQt5Qml.so.5.14.2  /usr/lib64/libQt5Network.so.5.15.1  -lcrypto  /usr/lib64/libxcb.so  /usr/lib64/libQt5X11Extras.so.5.15.1  /usr/lib64/libQt5Gui.so.5.15.1  /usr/lib64/libQt5DBus.so.5.15.1  /usr/lib64/libQt5Core.so.5.15.1 && :
FAILED: bin/falkon 
: && /usr/bin/x86_64-pc-linux-gnu-g++  -march=native -O2 -pipe -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always  -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed    -rdynamic src/main/CMakeFiles/falkon.dir/falkon_autogen/mocs_compilation.cpp.o src/main/CMakeFiles/falkon.dir/main.cpp.o src/main/CMakeFiles/falkon.dir


and the final lines


qt5/QtX11Extras -isystem /usr/include/qt5/QtDBus  -DQT_NO_DEBUG -march=native -O2 -pipe -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -fPIC -fvisibility=hidden -fvisibility-inlines-hidden   -fPIC -std=gnu++11 -MD -MT src/plugins/AutoScroll/CMakeFiles/AutoScroll.dir/ECMQmLoader-falkon_autoscroll_qt.cpp.o -MF src/plugins/AutoScroll/CMakeFiles/AutoScroll.dir/ECMQmLoader-falkon_autoscroll_qt.cpp.o.d -o src/plugins/AutoScroll/CMakeFiles/AutoScroll.dir/ECMQmLoader-falkon_autoscroll_qt.cpp.o -c src/plugins/AutoScroll/ECMQmLoader-falkon_autoscroll_qt.cpp
ninja: build stopped: subcommand failed.
 

Reproducible: Always
Comment 1 Silvio 2020-10-29 16:49:55 UTC
emerge --info '=www-client/falkon-3.1.0-r1::gentoo'
Portage 3.0.8 (python 3.7.8-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-10.2.0, glibc-2.32-r2, 5.9.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.9.1-gentoo-x86_64-Intel-R-_Core-TM-_i7-7500U_CPU_@_2.70GHz-with-gentoo-2.7
KiB Mem:    16277604 total,  14834428 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Wed, 28 Oct 2020 14:00:02 +0000
Head commit of repository gentoo: 22e8d8de65ccbd3b917376569b72380670a1bee1
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p4) 2.34.0
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18::gentoo, 3.6.10-r2::gentoo, 3.7.8::gentoo, 3.8.3::gentoo, 3.9.0::gentoo
dev-util/cmake:           3.17.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.34-r1::gentoo, 2.35.1::gentoo
sys-devel/gcc:            9.2.0-r4::gentoo, 9.3.0::gentoo, 10.2.0-r2::gentoo
sys-devel/gcc-config:     2.3.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 

betagarden
    location: /var/lib/layman/betagarden
    masters: gentoo
    priority: 50

flow
    location: /var/lib/layman/flow
    sync-type: laymansync
    sync-uri: https://gitlab.com/Flow/flow-s-ebuilds.git
    masters: gentoo
    priority: 50

rion
    location: /var/lib/layman/rion
    sync-type: laymansync
    sync-uri: https://github.com/rion-overlay/rion-overlay.git
    masters: gentoo
    priority: 50

salfter
    location: /var/lib/layman/salfter
    sync-type: laymansync
    sync-uri: https://gitlab.com/salfter/portage.git
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    sync-type: laymansync
    sync-uri: https://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

vortex
    location: /var/lib/layman/vortex
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it en it_IT en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus declarative dell dri dri3 dts dvd dvdr egl elogind emboss encode exif ffmpeg fftw flac fortran gdbm gif gpm gtk gui hidpi iconv icu id3tag ipv6 javafx jpeg kde kdesu kipi kwallet lcms libglvnd libinput libnotify libtirpc mad mng mp3 mp4 mpeg mtp multilib ncurses networkmanager nls nptl ntfs objc ogg opengl openmp opus pam pango pcre pcsc-lite pdf phonon plasma png policykit ppds pulseaudio python qml qt5 readline s3tc sdl seccomp semantic-desktop spell split-usr ssl startup-notification svg tcpd theora tiff touchpad truetype udev udisks unicode upower usb uxa v4l vaapi vdpau vorbis vpx widgets wxwidgets x264 xattr xcb xml xv xvid xvmc zlib" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="snd_hda_intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 ssse3 sse4_1 sse4_2 glamor" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="joystick wacom synaptics evdev libinput" KERNEL="linux" L10N="it en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7 python3_6" RUBY_TARGETS="ruby25 ruby26 ruby27" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="intel i965 i915 vesa v4l v4l2 modesetting fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

www-client/falkon-3.1.0-r1::gentoo was built with the following:
USE="X dbus kde -debug -libressl -test" ABI_X86="(64)"
FEATURES="binpkg-docompress protect-owned xattr merge-sync binpkg-dostrip news multilib-strict usersandbox network-sandbox userpriv usersync parallel-fetch unknown-features-warn pid-sandbox sandbox sfperms ebuild-locks strict assume-digests unmerge-orphans binpkg-logs ipc-sandbox config-protect-if-modified distlocks userfetch fixlafiles unmerge-logs preserve-libs qa-unresolved-soname-deps"
Comment 2 Silvio 2020-10-29 16:51:02 UTC
Created attachment 669194 [details]
build.log
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2020-10-29 16:59:49 UTC
Originating error:

ld: /usr/lib64/libQt5Quick.so.5.14.2: undefined reference to `QRhi::newSampler(QRhiSampler::Filter, QRhiSampler::Filter, QRhiSampler::Filter, QRhiSampler::AddressMode, QRhiSampler::AddressMode)@Qt_5_PRIVATE_API'
collect2: error: ld returned 1 exit status
Comment 4 Andreas Sturmlechner gentoo-dev 2020-10-29 17:28:34 UTC
Mixed Qt 5.14.2/5.15.1 system.

*** This bug has been marked as a duplicate of bug 749777 ***
Comment 5 Andreas Sturmlechner gentoo-dev 2020-10-29 17:34:44 UTC
*** Bug 751772 has been marked as a duplicate of this bug. ***
Comment 6 Andreas Sturmlechner gentoo-dev 2020-10-29 17:36:18 UTC
*** Bug 751778 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Sturmlechner gentoo-dev 2020-10-30 08:53:17 UTC
*** Bug 751778 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Sturmlechner gentoo-dev 2020-10-30 13:51:29 UTC
Before trying any workarounds you can also --sync and try again to see if the world upgrade is now (after commit d4e2b952c7451abe3e073ea1b4df4dd496ba0126) picking up more Qt libraries before their revdeps. Don't try to emerge individual packages as long as this situation is not solved.