Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74947 - media-sound/beep-media-player does not display bookmarks in all file menus
Summary: media-sound/beep-media-player does not display bookmarks in all file menus
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL: http://www.sosdg.org/~larne/bugs/show...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-19 09:56 UTC by postmodern
Modified: 2004-12-20 03:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description postmodern 2004-12-19 09:56:05 UTC
When adding bookmarks to the bookmark list in the "File Menu" said bookmarks do not appear in other "File Menus" (lets say from the "Load List" or "Add Files" bottuns). When readding the directories to the bookmark list I get an error message stating that they are already there.

Reproducible: Always
Steps to Reproduce:
1. while in a "File Menu" add some directories
2. open a "File Menu" from another place

Actual Results:  
The bookmarks are no longer there.

Expected Results:  
My bookmarks stay.

Gentoo Base System version 1.4.16
Portage 2.0.51-r3 (default-linux/amd64/2004.3, gcc-3.4.3,
glibc-2.3.4.20040808-r1, 2.6.9-gentoo-r9 x86_64)
=================================================================
System uname: 2.6.9-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3400+
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-pipe -O3 -march=k8"
CHOST="x86_64-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-pipe -O3 -march=k8"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X acpi alsa berkdb bitmap-fonts cdr crypt encode esd f77 fam flac
fortran gif gpm gtk gtk2 imlib ipv6 java jp2 jpeg lzw lzw-tiff mozilla multilib
ncurses network nls oggvorbis opengl oss pam perl png python readline samba
speex spell sqlite ssl tcpd theora tiff truetype usb userlocales xml xml2 xmms
xpm xrandr xv zlib"
Comment 1 Tony Vroon gentoo-dev 2004-12-19 11:45:41 UTC
Indeed, when adding a bookmark from any other program it is not visible in the file dialog that BMP displays. I will report this bug upstream and add you to the CC list.
Comment 2 postmodern 2004-12-19 11:49:32 UTC
Not just that but if you click the open/play button (next to the shuffle button) and add some bookmarks or go to some directory then click on the "Load List" bottun in the play list window they don't show up, but when readding them there it complains that they already are added.
Comment 3 Tony Vroon gentoo-dev 2004-12-19 11:51:54 UTC
Even nicer, I just added a bookmark in BMP, and the "missing" bookmark turned up as well. It looks like they just do not do a necessary refresh of that widget. Anyhow, bug reported upstream with you on the CC list, please add any comments there.
Comment 4 postmodern 2004-12-20 03:33:17 UTC
Hmmm the bug no longer appears to be occuring in the latest portage release of bmp, also no one over at the BMP dev team can confirm it.