Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 749342 - sys-apps/portage: multiple merges for same package with some use-flags disabled to resolve deadlocks
Summary: sys-apps/portage: multiple merges for same package with some use-flags disabl...
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-15 18:40 UTC by Nikita Zlobin
Modified: 2020-10-16 02:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Zlobin 2020-10-15 18:40:41 UTC
Portage fails to resolve cases when two packages depend on each other due to some use flags enabled.

Reproducible: Always

Steps to Reproduce:
These loops are actual:
freetype[harfbuzz] -> harfbuzz[freetype] -> freetype
ncurses[gpm] -> gpm -> ncurses
mesa[vaapi] -> libva; libva[opengl] -> virtual/opengl -> mesa

Also cups[zeroconf] caused problems in past, but now it seems to be fixed (I just can't track it by look into ebuilds).
Actual Results:  
At least it reports, where is problem, propose manual solution by disabling flags, masking, etc.

Expected Results:  
Should try multiple emerges for same package. First time with USE=-flag for whatever flag causing circular dependency, second time with this flag on.
Comment 1 Sam James archtester gentoo-dev Security 2020-10-16 02:41:36 UTC

*** This bug has been marked as a duplicate of bug 175808 ***