Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74916 - gxine 0.4.1 released
Summary: gxine 0.4.1 released
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 75857 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-19 01:30 UTC by athli
Modified: 2005-05-26 09:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New ebuild (gxine-0.4.1.ebuild,1.12 KB, text/plain)
2004-12-23 14:36 UTC, ingenius
Details
gxine-0.4.1.ebuild (gxine-0.4.1.ebuild,1.25 KB, text/plain)
2005-01-13 13:09 UTC, Ed Catmur
Details
gxine-0.4.1-menu-fix.patch (gxine-0.4.1-menu-fix.patch,873 bytes, patch)
2005-01-13 13:09 UTC, Ed Catmur
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description athli 2004-12-19 01:30:15 UTC
gxine 0.4.1 released

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 ingenius 2004-12-23 14:36:47 UTC
Created attachment 46734 [details]
New ebuild
Comment 2 Sumit Khanna 2004-12-27 10:47:51 UTC
I've tested this ebuild in my local portage overlay. It works fine and the bug fixes are incredible. gxine nolonger crashes in full-screen and works perfectly with the new xorg-6.8 extensions (xcompmgr shadow effects). I've tested it on a large variety of media files and it works very well.

I hope to see it in ~x86 soon.

Portage 2.0.51-r8 (default-linux/x86/2004.2, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.9 i686)
=================================================================
System uname: 2.6.9 i686 AMD Athlon(tm) MP 1900+
Gentoo Base System version 1.6.8
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Aug 30 2004, 04:30:41)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.4_p6, 1.9.3, 1.6.3, 1.5, 1.7.9, 1.8.5-r2
sys-devel/binutils:  2.15.92.0.2-r2
sys-devel/libtool:   1.5.10-r2
virtual/os-headers:  2.4.22
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=athlon-mp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-mp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo http://gentoo.binarycompass.org http://mirror.datapipe.net/gentoo http://www.gigaload.org/gentoo.org/"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X aalib acl acpi aim alsa apm arts audiofile avi berkdb bitmap-fonts cdr crypt cups divx4linux dvd dvdr dvdread encode esd fam flac flash foomaticdb fortran ftp gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml imagemagick imap imlib ipv6 java jpeg junit kde libwww mad mikmod mmx motif mozilla mpeg msn ncurses nls oggvorbis opengl pam pda pdflib perl png python qt quicktime readline samba sdl slang spell sse ssl svg svga tcltk tcpd tiff truetype xml2 xmms xpm xv xvid yahoo zlib"
Comment 3 Ed Catmur 2005-01-13 13:09:15 UTC
Created attachment 48424 [details]
gxine-0.4.1.ebuild

Updated ebuild incorporating suggestions from bug 75857 including:

* Adds mime types to .desktop file
* Uses correct .desktop category
* Install logo to /usr/share/pixmaps
* Add "noplugin" USE flag to not install Mozilla plugin
Comment 4 Ed Catmur 2005-01-13 13:09:45 UTC
Created attachment 48425 [details, diff]
gxine-0.4.1-menu-fix.patch

Patch used by above ebuild
Comment 5 Benoit Boissinot 2005-01-14 00:47:40 UTC
*** Bug 75857 has been marked as a duplicate of this bug. ***
Comment 6 Markus Rothe (RETIRED) gentoo-dev 2005-01-23 02:42:31 UTC
chris seems to have no time to get this into portage. So I commited it. =)

Thx for ebuild and patch!

Markus
Comment 7 Markus Rothe (RETIRED) gentoo-dev 2005-01-23 02:42:40 UTC
closing
Comment 8 Markus Rothe (RETIRED) gentoo-dev 2005-01-23 02:46:48 UTC
Just a note: I changed from noplugin to mozilla useflag, as this is already available
and doesn't expand the amount of useflags. So if you have mozilla in your useflags
the plugin gets installed.

Markus
Comment 9 Roland Everaert 2005-05-26 09:50:28 UTC
When compiling gxine 0.4.1-r1, I got the following error on x86:

i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include
-I../include -I/usr/include -I../pixmaps    -I/usr/include -DXTHREADS
-D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -DLOCALEDIR=\"/usr/share/locale\" -O2 -march=i686
-fomit-frame-pointer -pipe -D_GNU_SOURCE -c `test -f 'infobar.c' || echo
'./'`infobar.c
playlist.c: In function `xine_event_cb':
playlist.c:1389: error: `XINE_MSG_PERMISSION_ERROR' undeclared (first use in
this function)
playlist.c:1389: error: (Each undeclared identifier is reported only once
playlist.c:1389: error: for each function it appears in.)
make[2]: *** [playlist.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/gxine-0.4.1-r1/work/gxine-0.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gxine-0.4.1-r1/work/gxine-0.4.1/src'
make: *** [all-recursive] Error 1

!!! ERROR: media-video/gxine-0.4.1-r1 failed.
!!! Function src_compile, Line 41, Exitcode 2
!!! (no error message)