Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74823 - Error compiling net-news/slrn-0.9.8.1
Summary: Error compiling net-news/slrn-0.9.8.1
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: net-news Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-18 04:33 UTC by gentoolinux
Modified: 2004-12-19 05:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gentoolinux 2004-12-18 04:33:55 UTC
When I try to update net-news/slrn to the latest version 0.9.8.1, the emerge command quits with the following error:

misc.c: In function `slrn_write_nchars':
misc.c:461: error: `SLsmg_Is_Unicode' undeclared (first use in this function)
misc.c:461: error: (Each undeclared identifier is reported only once
misc.c:461: error: for each function it appears in.)
if gcc -Dunix -DSLRN_LIB_DIR=\"/usr/lib/slrn\" -DSHAREDIR=\"/usr/share/slrn\" -DSYSCONFDIR=\"/etc\" -I. -I. -I. -I. -I../intl        -O3 -mcpu=pentium4 -march=pentium4 -pipe -fomit-frame-pointer -MT post.o -MD -MP -MF ".deps/post.Tpo" -c -o post.o post.c; \
then mv -f ".deps/post.Tpo" ".deps/post.Po"; else rm -f ".deps/post.Tpo"; exit 1; fi
make[2]: *** [misc.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/slrn-0.9.8.1/work/slrn-0.9.8.1/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/slrn-0.9.8.1/work/slrn-0.9.8.1/src'
make: *** [all-recursive] Error 1

Any help appreciated.

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge -u slrn
Comment 1 Sven Wegener gentoo-dev 2004-12-18 08:47:16 UTC
If you want to compile net-news/slrn with USE="unicode" for unicode support, you
need to have your sys-libs/slang also compiled with USE="unicode".

I've added some built_with_use magic to that ebuild, so that emerge breaks once
this requirement isn't fullfilled.
Comment 2 gentoolinux 2004-12-19 05:18:16 UTC
Many thanks! Now everything works fine.