Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 747430 - dev-lang/julia-1.5.2 does not respect CFLAGS
Summary: dev-lang/julia-1.5.2 does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags
  Show dependency tree
 
Reported: 2020-10-09 11:07 UTC by Agostino Sarubbo
Modified: 2020-12-25 21:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,152.71 KB, application/x-xz)
2020-10-09 11:07 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-10-09 11:07:38 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-lang/julia-1.5.2 does not respect CFLAGS.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-10-09 11:07:41 UTC
Created attachment 664450 [details]
build.log.xz

build log and emerge --info (compressed because it exceeds attachment limit, use 'xzless' to read it)
Comment 2 Larry the Git Cow gentoo-dev 2020-12-25 21:56:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f7ec33492f40a1b612a6d293202a690c7ff7409b

commit f7ec33492f40a1b612a6d293202a690c7ff7409b
Author:     Matthias Maier <tamiko@gentoo.org>
AuthorDate: 2020-12-25 21:45:10 +0000
Commit:     Matthias Maier <tamiko@gentoo.org>
CommitDate: 2020-12-25 21:56:15 +0000

    dev-lang/julia: version bump to 1.5.3
    
     * export AR environment variable
    
     * silence warning about unused CFLAGS - julia modules are not compiled
       using the CFLAGS environment variable
    
    Closes: https://bugs.gentoo.org/747430
    Closes: https://bugs.gentoo.org/746254
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Matthias Maier <tamiko@gentoo.org>

 dev-lang/julia/Manifest           |   2 +
 dev-lang/julia/julia-1.5.3.ebuild | 209 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 211 insertions(+)