Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 747334 - media-video/ffmpeg-4.3.1 fails to compile
Summary: media-video/ffmpeg-4.3.1 fails to compile
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-08 14:51 UTC by Ted Marston
Modified: 2020-10-08 17:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Gzipped build log (ffmpeg-4.3.1:20201007-222819.log.gz,64.68 KB, application/octet-stream)
2020-10-08 14:55 UTC, Ted Marston
Details
tail end of build log (tailend,3.13 KB, text/plain)
2020-10-08 15:04 UTC, Ted Marston
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ted Marston 2020-10-08 14:51:46 UTC
src/libswscale/x86/yuv2rgb.c:120:20: error: yuv420_bgr24_mmxext undeclared

Reproducible: Always




emerge --info
Portage 3.0.4 (python 3.7.8-final-0, default/linux/amd64/17.1, gcc-9.3.0, glibc-2.31-r6, 5.4.60-gentoo-nder-11 x86_64)
=================================================================
System uname: Linux-5.4.60-gentoo-nder-11-x86_64-Intel-R-_Core-TM-_i7-9700_CPU_@_3.00GHz-with-gentoo-2.7
KiB Mem:    32815668 total,   2953604 free
KiB Swap:          0 total,         0 free
Head commit of repository torbrowser: c4d5ff4dc48f49ef5f10222fb2c55a22753fbb4a

Timestamp of repository gentoo: Wed, 07 Oct 2020 22:00:01 +0000
Head commit of repository gentoo: e2e130d21a32000855d1f75fe272497ac8290a06
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
ccache version 3.7.11 [disabled]
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r2::gentoo, 3.7.8-r2::gentoo, 3.8.5::gentoo
dev-util/ccache:          3.7.11::gentoo
dev-util/cmake:           3.17.4-r1::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r6::gentoo
Repositories:

torbrowser
    location: /var/lib/layman/torbrowser
    sync-type: git
    sync-uri: https://github.com/MeisterP/torbrowser-overlay.git
    masters: gentoo
    priority: 50

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 60
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 

Installed sets: @kernels
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS=" --jobs=8 --load-average=8 --with-bdeps=y --autounmask=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="--jobs=8"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X Xaw3d acl alsa amd64 bash-completion berkdb bluetooth bzip2 cairo cddb cli colord crypt cups curl cxx dbus dga dri dts dvb dvd emacs fbcon ffmpeg flac fontconfig fortran gdbm gif gnutls gpm gstreamer gtk iconv icu id3tag jack jbig jpeg jpeg2k kpathsea ladspa lash latex lcms libass libglvnd libsamplerate libtirpc luajit mad matroska mikmod mmx mng modplug motif mp3 mpeg mtp multilib musepack nas ncurses nls nptl nsplugins ogg openal opengl openmp opus oss pam pcre png qt5 readline sdl seccomp sndfile spell split-usr ssl startup-notification svg taglib tcl tcpd theora tiff timidity tk truetype udev unicode vaapi vdpau vorbis webp xattr xemacs xml xv zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon pentax samsung sony_dscf1 sony_dscf55" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma fma3 mmx pni sse sse2 sse3 sse4_1 sse4_2 ssse3 no-3dnowext no-xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="emu efi-32 efi-64 pc" INPUT_DEVICES="evdev libinput" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby25 ruby26" SANE_BACKENDS="canon pixma" USERLAND="GNU" VIDEO_CARDS="fbdev intel i915 i965 vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ted Marston 2020-10-08 14:55:42 UTC
Created attachment 664384 [details]
Gzipped build log
Comment 2 Ted Marston 2020-10-08 15:04:58 UTC
Created attachment 664387 [details]
tail end of build log
Comment 3 Stephan Hartmann gentoo-dev 2020-10-08 16:27:27 UTC
(In reply to Ted Marston from comment #2)
> Created attachment 664387 [details]
> tail end of build log

Why have you disabled mmxext? All amd64 CPUs have mmxext instructions.
Comment 4 Ted Marston 2020-10-08 16:38:26 UTC
(In reply to Stephan Hartmann from comment #3)
> (In reply to Ted Marston from comment #2)
> > Created attachment 664387 [details]
> > tail end of build log
> 
> Why have you disabled mmxext? All amd64 CPUs have mmxext instructions.

Because mmxext is not in /proc/cpuinfo
Comment 5 Ted Marston 2020-10-08 16:53:05 UTC
(In reply to Ted Marston from comment #4)
> (In reply to Stephan Hartmann from comment #3)
> > (In reply to Ted Marston from comment #2)
> > > Created attachment 664387 [details]
> > > tail end of build log
> > 
> > Why have you disabled mmxext? All amd64 CPUs have mmxext instructions.
> 
> Because mmxext is not in /proc/cpuinfo

Never-the-less, with mmxext added to USE flags, ffmpeg-4.3.1 now builds.
Thanks!
Comment 6 Ted Marston 2020-10-08 17:00:49 UTC
(In reply to Ted Marston from comment #5)
> Never-the-less, with mmxext added to USE flags, ffmpeg-4.3.1 now builds.

Oops! mmxext was added to CPU_FLAGS_X86

> Thanks!
Comment 7 Jonas Stein gentoo-dev 2020-10-08 17:20:42 UTC
seems we can close it.