Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 744985 - dev-ruby/stringex-2.8.5 fails tests (dep on dev-ruby/sqlite3 needs lower bound)
Summary: dev-ruby/stringex-2.8.5 fails tests (dep on dev-ruby/sqlite3 needs lower bound)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2020-09-27 23:40 UTC by Jonathan Lovelace
Modified: 2022-04-04 05:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-ruby:stringex-2.8.5:20200927-220217.log (dev-ruby:stringex-2.8.5:20200927-220217.log,5.15 KB, text/plain)
2020-09-27 23:40 UTC, Jonathan Lovelace
Details
emerge-info.txt (emerge-info.txt,8.05 KB, text/plain)
2020-09-27 23:41 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2020-09-27 23:40:54 UTC
Created attachment 662701 [details]
dev-ruby:stringex-2.8.5:20200927-220217.log

When rebuilding =dev-ruby/stringex-2.8.5 for ruby26, and against =dev-ruby/activerecord-6.0.3.2, its tests fail (against ruby25) with the error "Error loading the 'sqlite3' Active Record adapter. Missing a gem it depends on? Could not find 'sqlite3' (~> 1.4) - did find: [sqlite3-1.3.13]"
Comment 1 Jonathan Lovelace 2020-09-27 23:41:20 UTC
Created attachment 662704 [details]
emerge-info.txt
Comment 2 Hans de Graaff gentoo-dev 2022-04-03 07:14:39 UTC
The sqlite version can vary depending on the activerecord version, so I've fixed this in a different way.
Comment 3 Larry the Git Cow gentoo-dev 2022-04-04 05:41:12 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9f5d6621f6802d864a5f1889be1b08131afb0656

commit 9f5d6621f6802d864a5f1889be1b08131afb0656
Author:     Hans de Graaff <graaff@gentoo.org>
AuthorDate: 2022-04-03 07:13:01 +0000
Commit:     Hans de Graaff <graaff@gentoo.org>
CommitDate: 2022-04-04 05:41:06 +0000

    dev-ruby/stringex: update EAPI 6 -> 8, add ruby30
    
    Fix sqlite version issue by using the activerecord USE flag for it
    rather than a separate dependency.
    
    Closes: https://bugs.gentoo.org/744985
    Signed-off-by: Hans de Graaff <graaff@gentoo.org>

 dev-ruby/stringex/stringex-2.8.5-r1.ebuild | 32 ++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)