Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 742731 - dev-util/cgdb-0.7.1 calls ar directly
Summary: dev-util/cgdb-0.7.1 calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jakov Smolic
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly 742719
  Show dependency tree
 
Reported: 2020-09-16 05:50 UTC by Agostino Sarubbo
Modified: 2020-09-17 06:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,18.85 KB, text/plain)
2020-09-16 05:50 UTC, Agostino Sarubbo
Details
context (context,58 bytes, text/plain)
2020-09-16 05:50 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-09-16 05:50:51 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-util/cgdb-0.7.1 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-09-16 05:50:53 UTC
Created attachment 660465 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-09-16 05:50:54 UTC
Created attachment 660468 [details]
context

context
Comment 3 Jakov Smolic 2020-09-16 09:15:23 UTC
Interestingly, the patch was working when the ebuild was using ./autogen.sh as I tested it initially, but when changed to `eautoreconf`, this happens again. I'll look into this ASAP.
Comment 4 Agostino Sarubbo gentoo-dev 2020-09-16 09:28:29 UTC
no problem, the CI is here to help :)
Comment 5 Jakov Smolic 2020-09-16 12:04:55 UTC
Apologies, my mistake for not spotting this before, but I should not have called `cp` before `default` in src_prepare, as that leads to the ebuild using unpatched configure.init file
Comment 6 Larry the Git Cow gentoo-dev 2020-09-17 06:06:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5e101aa053b245bf7f4833e1a10fb57b73a4d236

commit 5e101aa053b245bf7f4833e1a10fb57b73a4d236
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2020-09-16 11:52:45 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-17 06:06:40 +0000

    dev-util/cgdb: call default at the beginning of src_prepare
    
    `default` should be called before `cp` in src_prepare as not doing that results in copying unpatched configure.init file, leading to
    the ebuild again calling ar directly
    
    Closes: https://bugs.gentoo.org/742731
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Closes: https://github.com/gentoo/gentoo/pull/17563
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/cgdb/cgdb-0.6.8.ebuild    | 2 +-
 dev-util/cgdb/cgdb-0.7.0-r2.ebuild | 2 +-
 dev-util/cgdb/cgdb-0.7.1.ebuild    | 2 +-
 dev-util/cgdb/cgdb-9999.ebuild     | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)