Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 741432 - sci-libs/gdal-3.0.4-r1 fails to compile
Summary: sci-libs/gdal-3.0.4-r1 fails to compile
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-09 14:01 UTC by Agostino Sarubbo
Modified: 2020-12-26 15:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,22.00 KB, text/plain)
2020-09-09 14:01 UTC, Agostino Sarubbo
Details
1-config.log (1-config.log,116.14 KB, text/plain)
2020-09-09 14:01 UTC, Agostino Sarubbo
Details
emerge --info '=sci-geosciences/gmt-5.4.4::gentoo' (emerge_info.txt,6.79 KB, text/plain)
2020-11-05 20:39 UTC, Uwe Scholz
Details
build.log on gcc machine (build.log,27.35 KB, text/plain)
2020-11-05 20:43 UTC, Uwe Scholz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-09-09 14:01:05 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-libs/gdal-3.0.4-r1 fails to compile.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
This machine uses a clang/LLVM toolchain.
If you think that this issue is strictly related to clang/LLVM please block bug 408963. If you think that this issue is strictly related to the LLD linker, please block bug 731004.
This machine uses also GLIBC-2.32. If you think that this issue is strictly related to GLIBC please block bug 736174.
Comment 1 Agostino Sarubbo gentoo-dev 2020-09-09 14:01:07 UTC
Created attachment 659262 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-09-09 14:01:09 UTC
Created attachment 659264 [details]
1-config.log

1-config.log
Comment 3 Uwe Scholz 2020-11-05 20:39:03 UTC
Created attachment 670103 [details]
emerge --info '=sci-geosciences/gmt-5.4.4::gentoo'

I have also a problem with building this application. I am building with gcc. Attached is my emerge info file. I will attach the build log shortly. The error message is different from the original attached file.
Comment 4 Uwe Scholz 2020-11-05 20:43:45 UTC
Created attachment 670106 [details]
build.log on gcc machine

I tried to build the project with all use flags disabled. It fails.
Comment 5 Uwe Scholz 2020-11-05 20:53:14 UTC
Additional info: Also with [FEATURES="-distcc" emerge -av gmt] the build fails with the same error message.
Comment 6 Uwe Scholz 2020-11-05 20:55:43 UTC
Arghhh, please forgive me and ignore all my messages. I have this problem for sci-geosciences/gmt and NOT for sci-libs/gdal. Excuse me!