Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 739568 - sci-geosciences/foxtrotgps-1.2.2: version bump
Summary: sci-geosciences/foxtrotgps-1.2.2: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL: https://lists.osgeo.org/pipermail/fos...
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks: EAPI5Removal
  Show dependency tree
 
Reported: 2020-08-29 23:03 UTC by Maciej S. Szmigiero
Modified: 2021-08-14 20:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
foxtrotgps ebuild (foxtrotgps-1.2.2.ebuild,679 bytes, text/plain)
2020-10-16 17:07 UTC, Alexander Bezrukov
Details
patch which fixes compilation with gcc-9 and gcc-10 (gcc-9-compile-fix.patch,727 bytes, patch)
2020-10-16 17:08 UTC, Alexander Bezrukov
Details | Diff
patch which adapts foxtrotgps to gpsd API version 9 (gpsd-api-fix.patch,1.31 KB, patch)
2020-10-16 17:19 UTC, Alexander Bezrukov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej S. Szmigiero 2020-08-29 23:03:03 UTC
sci-geosciences/foxtrotgps-1.2.2 is available upstream, please bump.

In addition to this, patches from
https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/320
https://bugs.launchpad.net/foxtrotgps/+bug/1893537
and
https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/323
are needed to build / use the package successfully with recent versions of sci-geosciences/gpsd and GCC 10.
Comment 1 Alexander Bezrukov 2020-10-16 17:07:07 UTC
Created attachment 666053 [details]
foxtrotgps ebuild

This is an ebuild for the new version. I will attach the patches in the couple of the next comments.

Please note that existing in-tree foxtrotgps ebuild is broken (incompatible with recent gpsd and gcc).
Comment 2 Alexander Bezrukov 2020-10-16 17:08:31 UTC
Created attachment 666056 [details, diff]
patch which fixes compilation with gcc-9 and gcc-10
Comment 3 Alexander Bezrukov 2020-10-16 17:19:12 UTC
Created attachment 666062 [details, diff]
patch which adapts foxtrotgps to gpsd API version 9
Comment 4 Maciej S. Szmigiero 2020-12-19 22:31:13 UTC
Updated the gpsd API patch at https://bugs.launchpad.net/foxtrotgps/+bug/1893537
to also support gpsd API 10, which places the fix status field in a different place.
Comment 5 Larry the Git Cow gentoo-dev 2021-08-14 19:59:37 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=97455176ec93f2d4f072e058918c28f9e02d359d

commit 97455176ec93f2d4f072e058918c28f9e02d359d
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-08-14 19:58:46 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-08-14 19:59:14 +0000

    sci-geosciences/foxtrotgps: Drop broken 1.2.0
    
    Broken for months with GCC-10 and gpsd API 9 yet no one noticed.
    Demoting to ~arch.
    
    Closes: https://bugs.gentoo.org/739568
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 sci-geosciences/foxtrotgps/Manifest                |  1 -
 sci-geosciences/foxtrotgps/foxtrotgps-1.2.0.ebuild | 28 ----------------------
 2 files changed, 29 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e5b3ec269d0eae0d2370ae33c4236e7d3341c74a

commit e5b3ec269d0eae0d2370ae33c4236e7d3341c74a
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-08-14 19:56:42 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-08-14 19:59:14 +0000

    sci-geosciences/foxtrotgps: 1.2.2 version bump, EAPI-7 bump
    
    Thanks-to: Alexander Bezrukov <phmagic@mail.ru>
    Closes: https://bugs.gentoo.org/739568
    Closes: https://bugs.gentoo.org/806986
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 sci-geosciences/foxtrotgps/Manifest                |  1 +
 .../foxtrotgps/files/foxtrotgps-1.2.2-gcc10.patch  | 24 ++++++++++++++
 .../files/foxtrotgps-1.2.2-gpsd-api9.patch         | 37 ++++++++++++++++++++++
 sci-geosciences/foxtrotgps/foxtrotgps-1.2.2.ebuild | 33 +++++++++++++++++++
 4 files changed, 95 insertions(+)
Comment 6 Maciej S. Szmigiero 2021-08-14 20:30:33 UTC
Thanks for bumping, however the patch committed is slightly incorrect:
it has "libgps_gpsdata.status" move to "libgps_gpsdata.fix.status" guarded by API version 9 instead of 10.
This means that the package won't build against sci-geosciences/gpsd that has API version 9.

For reference please see the upstream fix [1] and the gpsd commit that introduced API version 10 and moved this status field [2].

[1]: https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/327
[2]: https://gitlab.com/gpsd/gpsd/-/commit/29991d6ffeb41ecfc8297db68bb68be0128c8514#fbec23e759c01a5d296e7d1e3a17e9b131df6ae4