Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 738928 - media-gfx/openvdb-7.0.0 Could NOT find Python (missing: Interpreter Development NumPy) (found version "2.7")
Summary: media-gfx/openvdb-7.0.0 Could NOT find Python (missing: Interpreter Developme...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Adrian
URL:
Whiteboard:
Keywords: PullRequest
: 739052 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-08-25 12:30 UTC by Adrian
Modified: 2020-10-17 20:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
openvdb-7.0.0 build.log (opendb-build.log,7.98 KB, text/x-log)
2020-08-26 04:21 UTC, Adrian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian 2020-08-25 12:30:31 UTC
When compiling openvdb-7.0.0 with numpy and python USE flags, configure fails to find the NumPy component. Note that it is finding python 2.7 rather than 3.6-3.8 against which I have numpy compiled.

I have boost-1.74 with python targets 2_7, 3_{6,7,8} and python versions 2_7, 3_{6,7,8,9} and numpy-1.19.0 with python targets 3_{6-8}.

Changing -DPython_EXECUTABLE="${EPYTHON}" to -DPython_EXECUTABLE="${PYTHON}" fixes the error.

Reproducible: Always

Steps to Reproduce:
1. emerge boost, numpy and python versions with use flags as above
2. emerge openvdb
3.
Actual Results:  
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
  Could NOT find Python (missing: Interpreter Development NumPy) (found
  version "2.7")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindPython.cmake:347 (find_package_handle_standard_args)
  openvdb/python/CMakeLists.txt:107 (find_package)



Expected Results:  
Configure should find python 3_{6-8} which have numpy, and then compile successfully.
Comment 1 Adrian 2020-08-25 12:31:06 UTC
Portage 2.3.103 (python 3.7.8-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-8.4.0, glibc-2.31-r6, 5.4.48-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.4.48-gentoo-x86_64-AMD_Ryzen_7_1800X_Eight-Core_Processor-with-gentoo-2.6
KiB Mem:    16351504 total,  10948228 free
KiB Swap:   20971516 total,  20971516 free
Timestamp of repository gentoo: Mon, 24 Aug 2020 17:00:01 +0000
Head commit of repository gentoo: 52cd22049764361c8f6f185e324c98d281e221e9
Head commit of repository dotnet: 52f513b6ed06f1b85262e8f1c5f12ec7f78c19dd

Head commit of repository ebuild-overlay: 9fc479764c43a6f00ccf1b6bd127553f6e388419

Head commit of repository sakaki-tools: b40dc95312804e3bfd1b991657c2356607b71f59

sh bash 5.0_p18
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18-r1::gentoo, 3.6.11-r2::gentoo, 3.7.8-r2::gentoo, 3.8.5::gentoo, 3.9.0_rc1::gentoo
dev-util/cmake:           3.16.5::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            8.4.0-r1::gentoo, 9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://portage.redchillipadi.com/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

crossdev
    location: /usr/local/portage/crossdev
    masters: gentoo
    priority: 10

dotnet
    location: /usr/local/portage/dotnet
    sync-type: git
    sync-uri: https://github.com/gentoo/dotnet.git
    masters: gentoo
    priority: 50

ebuild-overlay
    location: /usr/local/portage/ebuild-overlay
    sync-type: git
    sync-uri: https://github.com/redchillipadi/ebuild-overlay.git
    masters: gentoo
    priority: 50

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=znver1 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=znver1 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo"
LANG="en_AU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cuda cups dbus dri dts dvd dvdr eds emboss encode evo exif flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv icu introspection ipv6 jpeg lcms ldap libglvnd libnotify libsecret libtirpc mad mng mp3 mp4 mpeg multilib nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp spell split-usr ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis wayland wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en-GB en-AU" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_8 python3_7 python3_6 python2_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Adrian 2020-08-25 12:31:39 UTC
emerge -pvq openvdb:

[ebuild  N    ] media-gfx/openvdb-7.0.0  USE="abi7-compat doc numpy python static-libs test utils -abi5-compat -abi6-compat" CPU_FLAGS_X86="avx sse4_2" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8 -python3_9"
Comment 3 Sam James archtester gentoo-dev Security 2020-08-25 17:22:47 UTC
The full build.log is still helpful because all of the information is one place -- it makes it a lot easier to handle because I'm used to looking in certain places ;)

EPYTHON is strongly preferred, but obviously if PYTHON is the only way to make it work, we'll do that.

I'm playing with this but hitting bug 733830 right now.
Comment 4 Adrian 2020-08-26 04:20:46 UTC
As far as bug 733830 is concerned, you can either disable python 3.9 (as I have done above), or downgrade to numpy 1.18.5 (which was removed from the tree a few days ago).

I am planning to request that it be returned to the tree until the bug is fixed as it must be helpful for others as well to be able to test python 3.9 with numpy and boost.

Apologies about the build log, I thought I had attached it earlier and have since deleted it. I am attaching it now.
Comment 5 Adrian 2020-08-26 04:21:22 UTC
Created attachment 656758 [details]
openvdb-7.0.0 build.log
Comment 6 Sam James archtester gentoo-dev Security 2020-08-27 12:55:00 UTC
*** Bug 739052 has been marked as a duplicate of this bug. ***
Comment 7 Adrian 2020-10-17 20:11:13 UTC
This was fixed in commit https://github.com/gentoo/gentoo/commit/fbc9f9ae432d2a6a45c2618f217302350cb3ddfc which was merged on Sep 9. Marking resolved.