Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 738398 - x11-misc/shutter misses dependency on dev-perl/Goo-Canvas
Summary: x11-misc/shutter misses dependency on dev-perl/Goo-Canvas
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexey
URL: https://itsfoss.com/shutter-edit-butt...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-21 13:30 UTC by skobk.in
Modified: 2020-08-22 09:53 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skobk.in 2020-08-21 13:30:49 UTC
x11-misc/shutter misses dependency on dev-perl/Goo-Canvas

Without dev-perl/Goo-Canvas installed Shutter has "Edit" button disabled with tooltip about missing dependency.

Reproducible: Always
Comment 1 Alexey 2020-08-22 09:46:47 UTC
Works as intended. It's an optional feature, and is marked as such: https://cgit.gentoo.org/repo/gentoo.git/tree/x11-misc/shutter/shutter-0.94.3_p20200621.ebuild#n78

optfeature "drawing tool" dev-perl/Goo-Canvas

That shows a message after emerge if the dependency is not in fact installed.

It would better be a USE flag, but https://www.gentoo.org/glep/glep-0062.html is not implemented yet.

Related: I also have some work upstream to use gtk3, and it looks like GooCanvas2 will become a non-optional dependency, in which case this issue will be accidentally solved without need to install Goo-Canvas separately. But no guarantees there, and I don't yet have a timeline.
Comment 2 Alexey 2020-08-22 09:53:40 UTC
The workaround I currently use on my system:

$ cat /etc/portage/sets/optfeatures
# shutter drawing
dev-perl/Goo-Canvas
# shutter upload
dev-perl/JSON-MaybeXS
dev-perl/Net-OAuth
dev-perl/Path-Class

https://wiki.gentoo.org/wiki//etc/portage/sets