Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 738130 - dev-python/protobuf-python-3.12.2 fails tests
Summary: dev-python/protobuf-python-3.12.2 fails tests
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Arfrever Frehtes Taifersar Arahesis
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-20 05:08 UTC by Agostino Sarubbo
Modified: 2020-08-20 20:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,96.47 KB, text/plain)
2020-08-20 05:08 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-08-20 05:08:19 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-python/protobuf-python-3.12.2 fails tests.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
This machine uses a clang/LLVM toolchain.
If you think that this issue is strictly related to clang/LLVM please block bug 408963. If you think that this issue is strictly related to the LLD linker, please block bug 731004.
This machine uses also GLIBC-2.32. If you think that this issue is strictly related to GLIBC please block bug 736174.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-20 05:08:22 UTC
Created attachment 655602 [details]
build.log

build log and emerge --info
Comment 2 Arfrever Frehtes Taifersar Arahesis 2020-08-20 06:20:50 UTC
> Traceback (most recent call last):
>   File "setup.py", line 285, in <module>
>     ext_modules=ext_module_list,
>   File "/usr/lib64/python2.7/site-packages/setuptools/__init__.py", line 144, in setup
>     return distutils.core.setup(**attrs)
>   File "/usr/lib64/python2.7/distutils/core.py", line 151, in setup
>     dist.run_commands()
>   File "/usr/lib64/python2.7/distutils/dist.py", line 953, in run_commands
>     self.run_command(cmd)
>   File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
>     cmd_obj.run()
>   File "/usr/lib64/python2.7/site-packages/setuptools/command/test.py", line 238, in run
>     self.run_tests()
>   File "/usr/lib64/python2.7/site-packages/setuptools/command/test.py", line 260, in run_tests
>     exit=False,
>   File "/usr/lib64/python2.7/unittest/main.py", line 94, in __init__
>     self.parseArgs(argv)
>   File "/usr/lib64/python2.7/unittest/main.py", line 149, in parseArgs
>     self.createTests()
>   File "/usr/lib64/python2.7/unittest/main.py", line 158, in createTests
>     self.module)
>   File "/usr/lib64/python2.7/unittest/loader.py", line 130, in loadTestsFromNames
>     suites = [self.loadTestsFromName(name, module) for name in names]
>   File "/usr/lib64/python2.7/unittest/loader.py", line 103, in loadTestsFromName
>     return self.loadTestsFromModule(obj)
>   File "/usr/lib64/python2.7/site-packages/setuptools/command/test.py", line 55, in loadTestsFromModule
>     tests.append(self.loadTestsFromName(submodule))
>   File "/usr/lib64/python2.7/unittest/loader.py", line 100, in loadTestsFromName
>     parent, obj = obj, getattr(obj, part)
> AttributeError: 'module' object has no attribute 'message_test'


Maybe regression in dev-python/setuptools.
Which version of dev-python/setuptools?
Comment 3 Arfrever Frehtes Taifersar Arahesis 2020-08-20 20:04:40 UTC
Can you reproduce this problem with other versions of dev-python/protobuf-python?
Can you reproduce this problem with Python 3.7 or 3.8?

> emerge -1O =dev-libs/protobuf-3.11.4
> PYTHON_TARGETS="python2_7 python3_7 python3_8" emerge -1o =dev-python/protobuf-python-3.11.4
> PYTHON_TARGETS="python2_7" ebuild .../protobuf-python-3.11.4.ebuild clean test
> PYTHON_TARGETS="python3_7" ebuild .../protobuf-python-3.11.4.ebuild clean test
> PYTHON_TARGETS="python3_8" ebuild .../protobuf-python-3.11.4.ebuild clean test
> emerge -1O =dev-libs/protobuf-3.12.2
> PYTHON_TARGETS="python2_7 python3_7 python3_8" emerge -1o =dev-python/protobuf-python-3.12.2
> PYTHON_TARGETS="python2_7" ebuild .../protobuf-python-3.12.2.ebuild clean test
> PYTHON_TARGETS="python3_7" ebuild .../protobuf-python-3.12.2.ebuild clean test
> PYTHON_TARGETS="python3_8" ebuild .../protobuf-python-3.12.2.ebuild clean test

Do you have logs from the past which would say when this package was working last time for your?