Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 737832 - net-misc/iperf-2.0.14a calls ar directly
Summary: net-misc/iperf-2.0.14a calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-08-18 10:55 UTC by Agostino Sarubbo
Modified: 2020-08-18 11:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.58 KB, text/plain)
2020-08-18 10:55 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-08-18 10:55:40 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-misc/iperf-2.0.14a calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-18 10:55:42 UTC
Created attachment 655248 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-08-18 11:10:21 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d5af0ceadc4a82de135b5083fb1e028809e86ae0

commit d5af0ceadc4a82de135b5083fb1e028809e86ae0
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2020-08-18 11:10:00 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2020-08-18 11:10:19 +0000

    net-misc/iperf: Set AR
    
    Package-Manager: Portage-3.0.3, Repoman-3.0.0
    Closes: https://bugs.gentoo.org/737832
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-misc/iperf/iperf-2.0.14a.ebuild       | 7 ++++++-
 net-misc/iperf/iperf-2.99999.99999.ebuild | 8 ++++++--
 2 files changed, 12 insertions(+), 3 deletions(-)