Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 736974 - x11-terms/gnome-terminal - automagic depend on X11
Summary: x11-terms/gnome-terminal - automagic depend on X11
Status: RESOLVED DUPLICATE of bug 624960
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-13 11:58 UTC by Yaroslav Isakov
Modified: 2020-08-24 21:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Isakov 2020-08-13 11:58:39 UTC
If gtk is built with X11, gnome-terminal depends on libX11 as well:

for target in $($PKG_CONFIG --variable targets gdk-$GTK_API_VERSION); do
  case "$target" in
    x11) PLATFORM_DEPS="$PLATFORM_DEPS x11" ;;

pkg-config --variable targets gdk-3.0
x11 wayland
Comment 1 Yaroslav Isakov 2020-08-24 21:50:52 UTC

*** This bug has been marked as a duplicate of bug 624960 ***
Comment 2 Yaroslav Isakov 2020-08-24 21:51:33 UTC
Comment in gnome-terminal ebuild points to bug 624960 for gtk+[X] dep