Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 736116 - dev-libs/mpfr-4.1.0 - configure:14311: error: possibly undefined macro: AX_PTHREAD on prefix
Summary: dev-libs/mpfr-4.1.0 - configure:14311: error: possibly undefined macro: AX_PT...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-06 07:59 UTC by Camille Huot
Modified: 2021-01-24 15:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.47 KB, text/plain)
2020-08-07 15:48 UTC, Camille Huot
Details
emerge --info mpfr (mpfr.info.log,16.05 KB, text/plain)
2020-08-07 15:49 UTC, Camille Huot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Camille Huot 2020-08-06 07:59:34 UTC
When trying to upgrade a relatively new Gentoo Prefix, building mpfr fails with the following error:

 cd /home/chuot/gentoo/var/tmp/portage/dev-libs/mpfr-4.1.0/work/mpfr-4.1.0 && /home/chuot/gentoo/bin/bash /home/chuot/gentoo/var/tmp/portage/dev-libs/mpfr-4.1.0/work/mpfr-4.1.0/missing automake-1.16 --gnu
configure:14311: error: possibly undefined macro: AX_PTHREAD
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
make: *** [Makefile:432: /home/chuot/gentoo/var/tmp/portage/dev-libs/mpfr-4.1.0/work/mpfr-4.1.0/configure] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: dev-libs/mpfr-4.1.0::gentoo failed (compile phase):
 *   emake failed

This error is also described here: https://github.com/advancetoolchain/advance-toolchain/issues/243

After merging autoconf-archives, the compilation succeeded.

So I would suggest to add autoconf-archives as a build dependency for dev-libs/mpfr

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2020-08-06 09:51:01 UTC
What is wrong with your system that it keeps running into autotools problems when there shouldn't be any?
Comment 2 Sergei Trofimovich gentoo-dev 2020-08-06 18:20:14 UTC
Please provide a few details:
- full build.log
- emerge --info mpfr

As Jeroen noted ::gentoo's ebuild does not run automake. We need to find why it's  called.
Comment 3 Camille Huot 2020-08-07 15:48:01 UTC
Created attachment 653612 [details]
build.log
Comment 4 Camille Huot 2020-08-07 15:49:12 UTC
Created attachment 653614 [details]
emerge --info mpfr
Comment 5 Camille Huot 2020-08-07 15:51:55 UTC
I filled this bug because I thought it was a regular issue due to the version change.

But since you are surprised, I should mention that this is a Prefix amd64 installation running in a Docker container.
Comment 6 Fabian Groffen gentoo-dev 2020-08-08 07:18:29 UTC
@toolchain, this is a prefix version of the ebuild, feel free to reassign to us.
Comment 7 Sergei Trofimovich gentoo-dev 2020-08-08 07:30:22 UTC
Sounds good!
Comment 8 Fabian Groffen gentoo-dev 2020-08-09 17:49:31 UTC
Ok turns out I was wrong, we don't have mpfr cloned, so this should be the gx86 version.

@Camille: do you have any (user) patches defined for mpfr?  It shouldn't attempt to run autotools.  Are there any specifics about the filesystem you use?
Comment 9 Camille Huot 2020-08-10 13:02:18 UTC
(In reply to Fabian Groffen from comment #8)
> @Camille: do you have any (user) patches defined for mpfr?  It shouldn't
> attempt to run autotools.  Are there any specifics about the filesystem you
> use?

Hi Fabian

No patches. I also had issues with others packages (wget & diffutils). https://bugs.gentoo.org/show_bug.cgi?id=736118

This solved the issue:

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=295f0726179d16084e1bcfefb24ef90e23ebdbd9

The root Prefix (/home/chuot/gentoo) is a Docker volume, so basically it is a bind mount to /var/lib/docker/volumes/gentoo_prefix/_data, which /var/lib is an ext4 filesystem. (Docker for Mac: Linux docker-desktop 4.19.76-linuxkit)
Comment 10 Fabian Groffen gentoo-dev 2021-01-24 15:27:32 UTC
I'm wondering if this is still breaking, recent bootstraps did not indicate any issue of this sort.