When trying to update an old system from gnome 2.2 to 2.8, it got stuck on ORBit. During the build process it uses orbit-idl to compile some of its orb .idl files, but would get an error saying:
"Identifiers cannot start with an underscore"
on one of the files (I can't remember which one exactly but it's most likely irrelevent). I found that several .IDL files in some of the gnome packages have identifiers that start with underscores, so something weird was going on.
On a hunch, I updated my libIDL 0.8.0 to libIDL 0.8.4. Then the problem went away.
So I'm guessing that the ebuild should have required a newer version of libIDL. I could not find any official documentation on the versions required (ORBit docs don't seem to mention it), but my ebuild says libIDL-0.7.4 is required, which seems wrong.
Steps to Reproduce:
1. Have a version 0.8.0 or older of libIDL installed
2. Attempt to emerge orbit-2.12.0
Orbit build error
Detected that a newer version of libIDL is required, emerged it, and then
N/A (request if needed)
configure.in definitely specifies 0.7.4, and we don't have versions older than 0.8.2 in the tree anymore. I'm not going to alter the dep on this one because it'll just cause confusion next time we bump it and it mismatches with the configure.in, and this is a rare case now.
Thanks very much for your report, let us know if you have any more queries.
*** Bug 74142 has been marked as a duplicate of this bug. ***
fixed in cvs so nobody else hits this bug, thanks.
to fix comment #1 you really should file an upstream patch to configure.in .. might seem minor, but it'll get fixed for everyone then.
ooh sorry, forgot to link. It has been fixed upstream now as well: http://bugzilla.gnome.org/show_bug.cgi?id=161118