Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 73521 - orbit 2.12.0 build failure: Identifiers cannot start with an underscore (require newer libIDL?)
Summary: orbit 2.12.0 build failure: Identifiers cannot start with an underscore (requ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 74142 (view as bug list)
Depends on:
Reported: 2004-12-05 23:12 UTC by Nate Case
Modified: 2004-12-13 04:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nate Case 2004-12-05 23:12:35 UTC
When trying to update an old system from gnome 2.2 to 2.8, it got stuck on ORBit.  During the build process it uses orbit-idl to compile some of its orb .idl files, but would get an error saying:

"Identifiers cannot start with an underscore"

on one of the files (I can't remember which one exactly but it's most likely irrelevent).  I found that several .IDL files in some of the gnome packages have identifiers that start with underscores, so something weird was going on.

On a hunch, I updated my libIDL 0.8.0 to libIDL 0.8.4.  Then the problem went away.

So I'm guessing that the ebuild should have required a newer version of libIDL.  I could not find any official documentation on the versions required (ORBit docs don't seem to mention it), but my ebuild says libIDL-0.7.4 is required, which seems wrong.

Reproducible: Always
Steps to Reproduce:
1. Have a version 0.8.0 or older of libIDL installed
2. Attempt to emerge orbit-2.12.0
Actual Results:  
Orbit build error

Expected Results:  
Detected that a newer version of libIDL is required, emerged it, and then
emerged ORBit.

N/A (request if needed)
Comment 1 Mike Gardiner (RETIRED) gentoo-dev 2004-12-05 23:49:14 UTC definitely specifies 0.7.4, and we don't have versions older than 0.8.2 in the tree anymore. I'm not going to alter the dep on this one because it'll just cause confusion next time we bump it and it mismatches with the, and this is a rare case now.

Thanks very much for your report, let us know if you have any more queries.
Comment 2 Joe McCann (RETIRED) gentoo-dev 2004-12-11 20:31:59 UTC
*** Bug 74142 has been marked as a duplicate of this bug. ***
Comment 3 Joe McCann (RETIRED) gentoo-dev 2004-12-11 20:38:12 UTC
fixed in cvs so nobody else hits this bug, thanks.
Comment 4 foser (RETIRED) gentoo-dev 2004-12-12 06:24:24 UTC
to fix comment #1 you really should file an upstream patch to .. might seem minor, but it'll get fixed for everyone then.
Comment 5 Joe McCann (RETIRED) gentoo-dev 2004-12-13 04:13:37 UTC
ooh sorry, forgot to link. It has been fixed upstream now as well: