Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 734140 - app-text/xiphos calls strip directly
Summary: app-text/xiphos calls strip directly
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Marek Szuba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-07-27 19:53 UTC by Agostino Sarubbo
Modified: 2020-07-27 20:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.89 KB, text/plain)
2020-07-27 19:53 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-27 19:53:00 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-text/xiphos calls strip directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different STRIP implementation (like llvm-strip). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the STRIP variable to x86_64-pc-linux-gnu-strip.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-27 19:53:06 UTC
Created attachment 651062 [details]
build.log

build log and emerge --info
Comment 2 Marek Szuba gentoo-dev 2020-07-27 20:20:52 UTC
app-text/xiphos-4.1.0-r2 got removed from the tree around 18:40 UTC today; see commit 1bbecfd9f532b6e9e4a855f9eb0b04a5d281c1cc. Incidentally, you really should start including the version number in your ticket summaries.