Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733972 - media-sound/ardour-6.2-r1 - fails on startup when linked with gold - ardour: /usr/lib64/ardour6/ardour-6.0.0: symbol lookup error: /usr/lib64/ardour6/libardour.so.3: undefined symbol: fftwf_make_planner_thread_safe
Summary: media-sound/ardour-6.2-r1 - fails on startup when linked with gold - ardour: ...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gold-tracker
  Show dependency tree
 
Reported: 2020-07-26 13:01 UTC by Michelangelo Scopelliti
Modified: 2020-09-07 18:55 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michelangelo Scopelliti 2020-07-26 13:01:14 UTC
The installation of media-sound/ardour-6.0 is fine. After installing, launching ardour6 executable fails with message

WARNING: Your system has a limit for maximum amount of locked memory!
         This might cause Ardour to run out of memory before your system runs
         out of memory. You can view the memory limit with 'ulimit -l', and it
         is normally controlled by /etc/security/limits.conf

bind txt domain [gtk2_ardour6] to /usr/share/ardour6/locale
Ardour6.0.0 (built using 6.0 and GCC version 10.2.0)
/usr/lib64/ardour6/ardour-6.0.0: symbol lookup error: /usr/lib64/ardour6/libardour.so.3: undefined symbol: fftwf_make_planner_thread_safe

It seems to be related to fftw linking (I assume the package links only against libfftw3f.so, lacking such a symbol, and not libfftw3f_{omp,threads}.so).

Since it is a waf package, I have no idea how to change the linking to test a workaround.

Reproducible: Always




emerge --info

Portage 3.0.0 (python 3.7.8-final-0, default/linux/amd64/17.1, gcc-10.2.0, glibc-2.31-r6, 5.7.10 x86_64)
=================================================================
System uname: Linux-5.7.10-x86_64-Intel-R-_Core-TM-_i7-7700_CPU_@_3.60GHz-with-gentoo-2.7
KiB Mem:    32592440 total,  28464196 free
KiB Swap:   33554428 total,  33554428 free
Head commit of repository gentoo: 7620d4da951fccd3f701f1a3413bc13514693350

Head commit of repository libressl: 40e2ec24a753a94dbac9b2719ddee998c908563c

Head commit of repository ring-overlay: 4cdf2c9095598e772ed68f58433e7ecade05b6fc

sh bash 5.0_p18
ld GNU gold (Gentoo 2.34 p5 2.34.0) 1.16
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18-r1::gentoo, 3.7.8-r2::gentoo, 3.8.5::gentoo, 3.9.0_beta5::gentoo
dev-util/cmake:           3.18.0::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.34-r1::gentoo
sys-devel/gcc:            10.2.0::gentoo
sys-devel/gcc-config:     2.3.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r6::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: git
    sync-uri: https://github.com/gentoo/gentoo.git
    priority: -1000

kernelpanic
    location: /var/db/repos/kernelpanic
    masters: gentoo
    priority: 0

libressl
    location: /var/db/repos/libressl
    sync-type: git
    sync-uri: https://github.com/gentoo/libressl.git
    masters: gentoo

ring-overlay
    location: /var/db/repos/ring-overlay
    sync-type: git
    sync-uri: https://github.com/stefan-langenmaier/ring-overlay.git
    masters: gentoo
    priority: 9999

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE @BINARY-REDISTRIBUTABLE @EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -mtune=native -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs cgroup clean-logs compress-build-logs config-protect-if-modified distlocks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -mtune=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O2 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 ao berkdb blas bluray branding bzip2 cairo cdda cjk clang cli crypt cups curl dbus djvu dri dvb dvd elogind encode eselect-ldso exif ffmpeg fftw flac fontconfig fortran gdbm gif gimp gmp gnome-keyring gsm harfbuzz heif iconv icu imlib inotify ipv6 jbig jemalloc jit jpeg jpeg2k ladspa lapack latex lcms libass libnotify libressl libtirpc lto lv2 lz4 lzma lzo mms mng mp3 mpeg multilib natspec ncurses nls nptl nss offensive ogg openal opencl opencv openexr opengl openmp opus pam pango pcre pdf plotutils png policykit postproc postscript pulseaudio raw readline scanner seccomp smp sndfile sound sox speex spell spice split-usr ssl startup-notification svg theora threads tiff truetype udev udisks unicode usb vaapi vim-syntax vorbis vpx vulkan wavpack webp wmf x264 xattr xcb xcomposite xml xmp xpm xv xvid zip zlib zstd" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="libressl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="it en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby27" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel i965 iris" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Larry the Git Cow gentoo-dev 2020-08-12 18:05:03 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0b94703700b420be51b83e1d13b0b00a62677658

commit 0b94703700b420be51b83e1d13b0b00a62677658
Author:     Miroslav Šulc <fordfrog@gentoo.org>
AuthorDate: 2020-08-12 18:04:33 +0000
Commit:     Miroslav Šulc <fordfrog@gentoo.org>
CommitDate: 2020-08-12 18:04:51 +0000

    media-sound/ardour: bump to 6.2, dropped 5.12, py3
    
    Bug: https://bugs.gentoo.org/733972
    Bug: https://bugs.gentoo.org/640168
    Closes: https://bugs.gentoo.org/726042
    Package-Manager: Portage-3.0.2, Repoman-2.3.23
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

 media-sound/ardour/Manifest                        |   3 +-
 media-sound/ardour/ardour-5.12.ebuild              | 137 ---------------------
 .../{ardour-6.0.ebuild => ardour-6.2.ebuild}       |  17 ++-
 media-sound/ardour/ardour-9999.ebuild              |  17 ++-
 .../ardour/files/ardour-4.x-revision-naming.patch  |  38 ------
 5 files changed, 17 insertions(+), 195 deletions(-)
Comment 2 Miroslav Šulc gentoo-dev 2020-08-12 18:05:46 UTC
please test with 6.2
Comment 3 Watcom 2020-08-12 22:52:14 UTC
I'm getting the same, just tested it with Ardour 6.2:

<snip>

bind txt domain [gtk2_ardour6] to /usr/share/ardour6/locale
Ardour6.2.0 (built using 6.2 and GCC version 9.3.0)
/usr/lib64/ardour6/ardour-6.2.0: symbol lookup error: /usr/lib64/ardour6/libardour.so.3: undefined symbol: fftwf_make_planner_thread_safe
Comment 4 Watcom 2020-08-12 23:02:02 UTC
Also, worth mentioning I have Ardour 5.12 installed alongside (same system) and it runs without problems.
Comment 5 Miroslav Šulc gentoo-dev 2020-08-13 04:56:33 UTC
i have ardour-9999 installed atm and this is the linking which also contains libfftw3f_threads.so.3:

# lddtree /usr/lib64/ardour6/ardour-6.2.165
ardour-6.2.165 => /usr/lib64/ardour6/ardour-6.2.165 (interpreter => /lib64/ld-linux-x86-64.so.2)
    libboost_system.so.1.73.0 => /usr/lib64/libboost_system.so.1.73.0
        librt.so.1 => /lib64/librt.so.1
    libardourcp.so => not found
    libwaveview.so.0 => not found
    libardour.so.3 => not found
    libmidipp.so.4 => not found
    libevoral.so.0 => not found
    libaudiographer.so.0 => not found
    libptformat.so.0 => not found
    libcanvas.so.0 => not found
    libwidgets.so.0 => not found
    libgtkmm2ext.so.0 => not found
    libpbd.so.4 => not found
    libtemporal.so.0 => not found
    libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6
            libbz2.so.1 => /lib64/libbz2.so.1
            libpng16.so.16 => /usr/lib64/libpng16.so.16
            libz.so.1 => /lib64/libz.so.1
        libexpat.so.1 => /usr/lib64/libexpat.so.1
        libuuid.so.1 => /lib64/libuuid.so.1
            ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2
    libglibmm-2.4.so.1 => /usr/lib64/libglibmm-2.4.so.1
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0
            libdl.so.2 => /lib64/libdl.so.2
    libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0
        libffi.so.7 => /usr/lib64/libffi.so.7
    libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0
        libpcre.so.1 => /lib64/libpcre.so.1
    libsigc-2.0.so.0 => /usr/lib64/libsigc-2.0.so.0
    libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0
            libmount.so.1 => /lib64/libmount.so.1
                libblkid.so.1 => /lib64/libblkid.so.1
            libresolv.so.2 => /lib64/libresolv.so.2
    libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0
        libXrender.so.1 => /usr/lib64/libXrender.so.1
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1
        libXi.so.6 => /usr/lib64/libXi.so.6
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1
        libXext.so.6 => /usr/lib64/libXext.so.6
    libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0
    libcairo.so.2 => /usr/lib64/libcairo.so.2
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0
        libEGL.so.1 => /usr/lib64/libEGL.so.1
            libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0
        libxcb-shm.so.0 => /usr/lib64/libxcb-shm.so.0
        libxcb.so.1 => /usr/lib64/libxcb.so.1
            libXau.so.6 => /usr/lib64/libXau.so.6
            libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6
                libbsd.so.0 => /usr/lib64/libbsd.so.0
        libxcb-render.so.0 => /usr/lib64/libxcb-render.so.0
        libGL.so.1 => /usr/lib64/libGL.so.1
            libGLX.so.0 => /usr/lib64/libGLX.so.0
    libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0
            libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3
    libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0
        libfribidi.so.0 => /usr/lib64/libfribidi.so.0
    libcurl.so.4 => /usr/lib64/libcurl.so.4
        libnghttp2.so.14 => /usr/lib64/libnghttp2.so.14
        libssl.so.1.1 => /usr/lib64/libssl.so.1.1
        libcrypto.so.1.1 => /usr/lib64/libcrypto.so.1.1
    libgtkmm-2.4.so.1 => /usr/lib64/libgtkmm-2.4.so.1
        libgiomm-2.4.so.1 => /usr/lib64/libgiomm-2.4.so.1
    libatkmm-1.6.so.1 => /usr/lib64/libatkmm-1.6.so.1
    libgdkmm-2.4.so.1 => /usr/lib64/libgdkmm-2.4.so.1
    libpangomm-1.4.so.1 => /usr/lib64/libpangomm-1.4.so.1
    libcairomm-1.0.so.1 => /usr/lib64/libcairomm-1.0.so.1
    libfftw3f.so.3 => /usr/lib64/libfftw3f.so.3
    libfftw3f_threads.so.3 => /usr/lib64/libfftw3f_threads.so.3
    liblo.so.7 => /usr/lib64/liblo.so.7
    libpthread.so.0 => /lib64/libpthread.so.0
    libxml2.so.2 => /usr/lib64/libxml2.so.2
        libicuuc.so.67 => /usr/lib64/libicuuc.so.67
            libicudata.so.67 => /usr/lib64/libicudata.so.67
    liblilv-0.so.0 => /usr/lib64/liblilv-0.so.0
        libserd-0.so.0 => /usr/lib64/libserd-0.so.0
        libsord-0.so.0 => /usr/lib64/libsord-0.so.0
        libsratom-0.so.0 => /usr/lib64/libsratom-0.so.0
    libsuil-0.so.0 => /usr/lib64/libsuil-0.so.0
    libX11.so.6 => /usr/lib64/libX11.so.6
    libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/libstdc++.so.6
    libm.so.6 => /lib64/libm.so.6
    libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/libgcc_s.so.1
    libc.so.6 => /lib64/libc.so.6

what does your look like? and what version of fftw you have installed? mine is sci-libs/fftw-3.3.8-r1.
Comment 6 Michelangelo Scopelliti 2020-08-13 10:47:26 UTC
(In reply to Miroslav Šulc from comment #5)
> i have ardour-9999 installed atm and this is the linking which also contains
> libfftw3f_threads.so.3:
> 
> # lddtree /usr/lib64/ardour6/ardour-6.2.165

[CUT]

# lddtree /usr/lib64/ardour6/ardour-6.2.0

ardour-6.2.0 => /usr/lib64/ardour6/ardour-6.2.0 (interpreter => /lib64/ld-linux-x86-64.so.2)
    libboost_system.so.1.73.0 => /usr/lib64/libboost_system.so.1.73.0
        librt.so.1 => /lib64/librt.so.1
    libardourcp.so => not found
    libwaveview.so.0 => not found
    libardour.so.3 => not found
    libmidipp.so.4 => not found
    libevoral.so.0 => not found
    libaudiographer.so.0 => not found
    libptformat.so.0 => not found
    libcanvas.so.0 => not found
    libwidgets.so.0 => not found
    libgtkmm2ext.so.0 => not found
    libpbd.so.4 => not found
    libtemporal.so.0 => not found
    libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6
            libbz2.so.1 => /lib64/libbz2.so.1
            libpng16.so.16 => /usr/lib64/libpng16.so.16
            libz.so.1 => /lib64/libz.so.1
            libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0
                libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3
        libexpat.so.1 => /usr/lib64/libexpat.so.1
        libuuid.so.1 => /lib64/libuuid.so.1
            ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2
    libglibmm-2.4.so.1 => /usr/lib64/libglibmm-2.4.so.1
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0
            libdl.so.2 => /lib64/libdl.so.2
    libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0
        libffi.so.7 => /usr/lib64/libffi.so.7
    libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0
        libpcre.so.1 => /lib64/libpcre.so.1
    libsigc-2.0.so.0 => /usr/lib64/libsigc-2.0.so.0
    libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0
            libmount.so.1 => /lib64/libmount.so.1
                libblkid.so.1 => /lib64/libblkid.so.1
            libresolv.so.2 => /lib64/libresolv.so.2
    libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0
        libXrender.so.1 => /usr/lib64/libXrender.so.1
        libXi.so.6 => /usr/lib64/libXi.so.6
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1
        libXext.so.6 => /usr/lib64/libXext.so.6
    libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0
    libcairo.so.2 => /usr/lib64/libcairo.so.2
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0
        libEGL.so.1 => /usr/lib64/libEGL.so.1
            libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0
        libxcb-shm.so.0 => /usr/lib64/libxcb-shm.so.0
        libxcb.so.1 => /usr/lib64/libxcb.so.1
            libXau.so.6 => /usr/lib64/libXau.so.6
            libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6
                libbsd.so.0 => /usr/lib64/libbsd.so.0
        libxcb-render.so.0 => /usr/lib64/libxcb-render.so.0
        libGL.so.1 => /usr/lib64/libGL.so.1
            libGLX.so.0 => /usr/lib64/libGLX.so.0
    libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0
    libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0
        libfribidi.so.0 => /usr/lib64/libfribidi.so.0
    libcurl.so.4 => /usr/lib64/libcurl.so.4
        libnghttp2.so.14 => /usr/lib64/libnghttp2.so.14
        libssl3.so => /usr/lib64/libssl3.so
        libsmime3.so => /usr/lib64/libsmime3.so
        libnss3.so => /usr/lib64/libnss3.so
        libnssutil3.so => /usr/lib64/libnssutil3.so
        libplds4.so => /usr/lib64/libplds4.so
        libplc4.so => /usr/lib64/libplc4.so
        libnspr4.so => /usr/lib64/libnspr4.so
        libssl.so.48 => /usr/lib64/libssl.so.48
        libcrypto.so.46 => /usr/lib64/libcrypto.so.46
    libgtkmm-2.4.so.1 => /usr/lib64/libgtkmm-2.4.so.1
        libgiomm-2.4.so.1 => /usr/lib64/libgiomm-2.4.so.1
    libatkmm-1.6.so.1 => /usr/lib64/libatkmm-1.6.so.1
    libgdkmm-2.4.so.1 => /usr/lib64/libgdkmm-2.4.so.1
    libpangomm-1.4.so.1 => /usr/lib64/libpangomm-1.4.so.1
    libcairomm-1.0.so.1 => /usr/lib64/libcairomm-1.0.so.1
    libfftw3f.so.3 => /usr/lib64/libfftw3f.so.3
    liblo.so.7 => /usr/lib64/liblo.so.7
    libpthread.so.0 => /lib64/libpthread.so.0
    libxml2.so.2 => /usr/lib64/libxml2.so.2
        libicuuc.so.67 => /usr/lib64/libicuuc.so.67
            libicudata.so.67 => /usr/lib64/libicudata.so.67
        liblzma.so.5 => /lib64/liblzma.so.5
    liblilv-0.so.0 => /usr/lib64/liblilv-0.so.0
        libserd-0.so.0 => /usr/lib64/libserd-0.so.0
        libsord-0.so.0 => /usr/lib64/libsord-0.so.0
        libsratom-0.so.0 => /usr/lib64/libsratom-0.so.0
    libsuil-0.so.0 => /usr/lib64/libsuil-0.so.0
    libX11.so.6 => /usr/lib64/libX11.so.6
    libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/libstdc++.so.6
    libm.so.6 => /lib64/libm.so.6
    libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/libgcc_s.so.1
    libc.so.6 => /lib64/libc.so.6

> 
> what does your look like? and what version of fftw you have installed? mine
> is sci-libs/fftw-3.3.8-r1.

mine is also 3.3.8-r1.

I have just had an idea: I will try to switch from gold to bfd, then I'll post again.
Comment 7 Michelangelo Scopelliti 2020-08-13 11:24:28 UTC
... and no problems with ld.bfd .

Should we add this to gold blocker?
Comment 8 Miroslav Šulc gentoo-dev 2020-08-13 11:30:52 UTC
(In reply to Michelangelo Scopelliti from comment #7)
> ... and no problems with ld.bfd .
> 
> Should we add this to gold blocker?

thank you for testing it.
Comment 9 Miroslav Šulc gentoo-dev 2020-08-23 09:42:38 UTC
guys. what is the proper fix for this? shall we file it upstream or we need to patch the sources ourselves or there's something else that has to be done to fix it?
Comment 10 Michelangelo Scopelliti 2020-09-07 18:20:56 UTC
(In reply to Miroslav Šulc from comment #9)
> guys. what is the proper fix for this? shall we file it upstream or we need
> to patch the sources ourselves or there's something else that has to be done
> to fix it?

As far as I can tell, there are two conditions necessary to trigger the issue:

1. fftw has to be built with threads and/or openmp
2. the user is using gold as default linker

waf detects the library and delegate the linker to do the right sequence; it seems to me the failure is on gold side.

A warning in the ebuild if conditions 1 and 2 are meet (and a blocker in the gold tracker) may be enough for now.

Just my 2¢.
Comment 11 Miroslav Šulc gentoo-dev 2020-09-07 18:29:04 UTC
(In reply to Michelangelo Scopelliti from comment #10)
> As far as I can tell, there are two conditions necessary to trigger the
> issue:
> 
> 1. fftw has to be built with threads and/or openmp
> 2. the user is using gold as default linker
> 
> waf detects the library and delegate the linker to do the right sequence; it
> seems to me the failure is on gold side.
> 
> A warning in the ebuild if conditions 1 and 2 are meet (and a blocker in the
> gold tracker) may be enough for now.
> 
> Just my 2¢.

thank you for the insight.
Comment 12 Larry the Git Cow gentoo-dev 2020-09-07 18:55:03 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3f350748216259e2f4e5b97fe3516e28cabbc182

commit 3f350748216259e2f4e5b97fe3516e28cabbc182
Author:     Miroslav Šulc <fordfrog@gentoo.org>
AuthorDate: 2020-09-07 18:54:46 +0000
Commit:     Miroslav Šulc <fordfrog@gentoo.org>
CommitDate: 2020-09-07 18:54:46 +0000

    media-sound/ardour: added gold linker warning to 6.2-r1
    
    Bug: https://bugs.gentoo.org/733972
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

 media-sound/ardour/ardour-6.2-r1.ebuild | 5 +++++
 1 file changed, 5 insertions(+)