Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733464 - x11-libs/gtk+:3 should not depend on media-libs/mesa
Summary: x11-libs/gtk+:3 should not depend on media-libs/mesa
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-21 23:34 UTC by Yaroslav Isakov
Modified: 2021-05-01 02:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Isakov 2020-07-21 23:34:02 UTC
Hello! I've found that gtk+:3 is using libepoxy to load OpenGL library, so there is no need to have mesa dependency. I cannot find any mentions of libGL in gtk sources and compiled libraries. Also, Ubuntu and Fedora packages does not have any mesa deps.
Comment 1 Yaroslav Isakov 2020-07-21 23:35:59 UTC
Probably, for wayland, gtk+ is also missing media-libs/libepoxy[egl] dep, but I'm not 100% sure.
Comment 2 Yaroslav Isakov 2020-08-13 12:11:04 UTC
Right now I have system with gtk[X] and without libGL.so and libGLX.so, and everything works, including gtkglarea example, firefox, chromium, other GTK apps.
Comment 3 Matt Turner gentoo-dev 2021-05-01 02:53:11 UTC
Write some patches? :)