Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733300 - net-misc/dhcp-4.4.2-r2 with net-misc/networkmanager-1.18.6 - DHCPv6 connection fails to set up routing
Summary: net-misc/dhcp-4.4.2-r2 with net-misc/networkmanager-1.18.6 - DHCPv6 connectio...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-20 10:08 UTC by nvaert1986
Modified: 2020-07-30 10:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nvaert1986 2020-07-20 10:08:08 UTC
We've got a Microsoft Windows DHCPv6 server running and I used to receive a IPv6 address on my laptop and everything used to work fine. Ever since I upgraded to net-misc/dhcp-4.4.2-r2 DHCPv6 stopped working properly. I do receive a DHCPv6 address, but can't ping anything outside of my /64 subnet. Adding a route manually does not resolve the issue either. DHCPv6 does work properly on all Microsoft Windows machines and they can reach devices outside of their /64 subnet. This is configured on a L3 switch with IPv6 DHCPv6 Relay and inter-VLAN routing.

All configuration was done in the Gnome Graphical User Interface

Reproducible: Always

Steps to Reproduce:
1. Start a request to a DHCPv6 with the software mentioned in the summary.
2. Try accessing IPv6 websites
Actual Results:  
I can reach any devices outside of my IPv6 /64 subnet.

Expected Results:  
IPv6 internet access

I was able to resolve the issue by upgrading networkmanager to version to ~amd64 (current cersion 1.26.0), when reading the notes I noted that it has an internal DHCP server and it prefers this if there's no configuration file. It works for me, but I figured I'd still report the bug anyway for others experiencing similar issues. Upgrading networkmanager resolved all issues.

I've tried using both my e1000e and my r8152 interface, but both show the same symptoms
Comment 1 nvaert1986 2020-07-20 10:26:36 UTC
Still not completely resolved. Internet access works, but ping refuses to work. It seems that ping only works when emerging it the first time and shutting down and bringing up the interface. The second time I perform this action I can't ping outside my IPv6 /64 subnet anymore, but IPv6 internet access remains working across reboots.
Comment 2 nvaert1986 2020-07-20 14:56:21 UTC
After some fiddling, I've got it fully working again with the latest networkmanager, but still does not work correctly, with the old version.