Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733206 - net-mail/mpop-1.4.17 version bump
Summary: net-mail/mpop-1.4.17 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: EBUILD, PullRequest
Depends on:
Blocks:
 
Reported: 2020-07-19 09:17 UTC by Herbert Wantesh
Modified: 2022-08-14 20:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mpop ebuild (mpop-1.4.10.ebuild,1.10 KB, text/plain)
2020-07-19 09:19 UTC, Herbert Wantesh
Details
Updated mpop-1.4.10.ebuild (file_733206.txt,991 bytes, text/plain)
2020-07-26 06:33 UTC, Nohemi Tynan
Details
mpop 1.4.16 ebuild (mpop-1.4.16.ebuild,947 bytes, text/plain)
2022-01-21 14:30 UTC, Herbert Wantesh
Details
mpop-1.4.17 ebuild (mpop-1.4.17.ebuild,947 bytes, text/plain)
2022-08-14 20:00 UTC, Herbert Wantesh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Herbert Wantesh 2020-07-19 09:17:51 UTC
net-mail/mpop-1.4.10 version pump

Reproducible: Always
Comment 1 Herbert Wantesh 2020-07-19 09:19:19 UTC
Created attachment 649820 [details]
mpop ebuild
Comment 2 Nohemi Tynan 2020-07-26 06:33:55 UTC
Created attachment 650782 [details]
Updated mpop-1.4.10.ebuild

Dear proxy maintainer,
Dear Herbert,

Thanks, Herbert, for initiating this version bump. I'd like to add one more thing.

Attached you find an updated ebuild for the new mpop version 1.4.10.

I made the ebuild secure by default by disabling the openssl support as this code deprecated by upstream and unmaintained since about 10 years. It lacks newer TLS features and properly contains bugs [0,1].

The package is marked as unstable, the user base is probably small. So the case that someone of the user base wants OpenSSL/LibreSSL-only and no GnuTLS on the system seems neglectable.

[0] https://marlam.de/mpop/news/openssl-discouraged/
[1] https://marlam.de/msmtp/news/openssl-discouraged/
Comment 3 Herbert Wantesh 2022-01-21 14:30:13 UTC
Created attachment 763005 [details]
mpop 1.4.16 ebuild

latest ebuild
Comment 4 Herbert Wantesh 2022-08-14 20:00:20 UTC
Created attachment 799623 [details]
mpop-1.4.17 ebuild