Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 733078 - arm profile: unmask virtual/rust and dev-lang/rust
Summary: arm profile: unmask virtual/rust and dev-lang/rust
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Profiles (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Rust Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-17 14:16 UTC by Craig Andrews
Modified: 2020-07-18 20:27 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Andrews gentoo-dev 2020-07-17 14:16:01 UTC
In https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ea04a1d2939affe00cea7dbf57dbbede5c1c6481
these packages were masked:
dev-lang/rust-bin
dev-lang/rust
virtual/rust

Only dev-lang/rust-bin should be masked.
dev-lang/rust and virtual/rust should not be masked; users can still build rust from source for these architectures.


Reproducible: Always
Comment 1 tt_1 2020-07-17 14:22:00 UTC
prove me wrong, but this mask has been added because there is no rustc stage for armv4/5, and that means no rust-bin but also no dev-lang/rust because there's nothing to bootstrap from in the first place! 

rust-std is available for armv4/5, so users are able to cross compile binaries if they want to from other and more powerfull devices.
Comment 2 Sam James archtester gentoo-dev Security 2020-07-17 14:41:42 UTC
(In reply to tt_1 from comment #1)
> prove me wrong, but this mask has been added because there is no rustc stage
> for armv4/5, and that means no rust-bin but also no dev-lang/rust because
> there's nothing to bootstrap from in the first place! 
> 
> rust-std is available for armv4/5, so users are able to cross compile
> binaries if they want to from other and more powerfull devices.

That's exactly it. Let's see what gyakovlev says but we essentially discussed this the other day and the conclusion was there's no point in unmasking (nor would it preserve the integrity of the depgraph) because we can't satisfy virtual/rust on armv4/5.

What we do instead is mask Rust-dependent packages on those earlier arm architectures, while making it available for >= armv6j.
Comment 3 Georgy Yakovlev gentoo-dev 2020-07-17 18:25:57 UTC
yeah it's kinda possible to cross-build rust on those arches now (patches needed and work in progress, but getting close).

but bootstrap problem still stands, like described above. There's no rust-bin/upstream tarball for those arm subarches, hence not possible to emerge rust.

the only possibility is to cross-emerge rust from somewhere else. it does not work by default and that's why it's masked.