Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 732766 - app-metrics/openvpn_exporter-0.3.0 : chown: invalid user: openvpn_exporter:openvpn_exporter
Summary: app-metrics/openvpn_exporter-0.3.0 : chown: invalid user: openvpn_exporter:op...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: William Hubbs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-15 18:33 UTC by Toralf Förster
Modified: 2020-10-07 11:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.30 KB, text/plain)
2020-07-15 18:33 UTC, Toralf Förster
Details
app-metrics:openvpn_exporter-0.3.0:20200715-183004.log (app-metrics:openvpn_exporter-0.3.0:20200715-183004.log,35.28 KB, text/plain)
2020-07-15 18:33 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,109.78 KB, text/plain)
2020-07-15 18:33 UTC, Toralf Förster
Details
environment (environment,34.08 KB, text/plain)
2020-07-15 18:33 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,22.82 KB, application/x-bzip)
2020-07-15 18:33 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-07-15 18:33:23 UTC
>>> Install app-metrics/openvpn_exporter-0.3.0 into /var/tmp/portage/app-metrics/openvpn_exporter-0.3.0/image
chown: invalid user: ‘openvpn_exporter:openvpn_exporter’
 * ERROR: app-metrics/openvpn_exporter-0.3.0::gentoo failed (install phase):
 *   fowners failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-20200713-194636

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.1.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.44.1 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.16.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 15 Jul 2020 06:05:29 PM UTC

emerge -qpvO app-metrics/openvpn_exporter
[ebuild  N    ] app-metrics/openvpn_exporter-0.3.0
Comment 1 Toralf Förster gentoo-dev 2020-07-15 18:33:26 UTC
Created attachment 649316 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-07-15 18:33:29 UTC
Created attachment 649318 [details]
app-metrics:openvpn_exporter-0.3.0:20200715-183004.log
Comment 3 Toralf Förster gentoo-dev 2020-07-15 18:33:32 UTC
Created attachment 649320 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-07-15 18:33:34 UTC
Created attachment 649322 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-07-15 18:33:37 UTC
Created attachment 649324 [details]
etc.portage.tbz2
Comment 6 Thomas Posch 2020-10-06 14:35:02 UTC
The ebuild mistakenly DEPENDs on acct-group/openvpn_exporter twice, while it should depend on acct-user/openvpn_exporter and acct-group/openvpn_exporter.