Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 732680 - dev-perl/GD-2.730.0-r1 fails to link with LLD because of /usr/lib in the link command line
Summary: dev-perl/GD-2.730.0-r1 fails to link with LLD because of /usr/lib in the link...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LD-is-lld perl-gd
  Show dependency tree
 
Reported: 2020-07-15 07:05 UTC by Agostino Sarubbo
Modified: 2021-12-20 18:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,10.47 KB, text/plain)
2020-07-15 07:05 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-15 07:05:38 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-perl/GD fails to link with LLD because of /usr/lib in the link command line.
Discovered on: amd64  (internal ref: tinderbox)

NOTE:
This PR gives an idea about a fix: https://github.com/PhotoFlare/photoflare/pull/248/files.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-15 07:05:43 UTC
Created attachment 649246 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-12-20 08:40:28 UTC
tinderbox has reproduced this issue with version 2.730.0-r1 - Updating summary.
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2021-12-20 18:11:10 UTC
This should be fixed with perl-5.34.0-r4 and later. 
If not, please attach a new log.