Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 732260 - www-servers/lighttpd calls cc directly
Summary: www-servers/lighttpd calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-07-11 19:11 UTC by Agostino Sarubbo
Modified: 2020-07-11 21:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,11.10 KB, text/plain)
2020-07-11 19:11 UTC, Agostino Sarubbo
Details
config.log (config.log,15.86 KB, text/plain)
2020-07-11 21:00 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-11 19:11:54 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: www-servers/lighttpd calls cc directly.
Discovered on: amd64  (internal ref: tinderbox)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-11 19:11:59 UTC
Created attachment 648942 [details]
build.log

build log and emerge --info
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-07-11 20:49:02 UTC
please attach config.log. build log is useless.
Comment 3 Agostino Sarubbo gentoo-dev 2020-07-11 21:00:14 UTC
Created attachment 648980 [details]
config.log

config.log
Comment 4 Larry the Git Cow gentoo-dev 2020-07-11 21:42:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3b0e5e3d45daef36c94729f2dda9a3f83a38b827

commit 3b0e5e3d45daef36c94729f2dda9a3f83a38b827
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-07-11 21:39:53 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-07-11 21:42:10 +0000

    www-servers/lighttpd: respect CC_FOR_BUILD
    
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=732260
    Package-Manager: Portage-2.3.99, Repoman-2.3.23
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 www-servers/lighttpd/lighttpd-1.4.55.ebuild | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)