Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730416 - net-misc/curl-7.71.0 with <=net-libs/quiche-0.4.0 - /work/curl-7.71.0/lib/vquic/quiche.c:220:5: error: implicit declaration of function ‘quiche_conn_set_keylog_path’; did you mean ‘quiche_conn_set_qlog_path’? [-Werror=implicit-function-declaration]
Summary: net-misc/curl-7.71.0 with <=net-libs/quiche-0.4.0 - /work/curl-7.71.0/lib/vqu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-01 21:24 UTC by Михаил
Modified: 2020-07-17 13:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,22.96 KB, application/gzip)
2020-07-05 18:43 UTC, skobk.in
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Михаил 2020-07-01 21:24:35 UTC
net-misc/curl/curl-7.71 use functions missed in net-libs/quiche-0.4.0 if USE=quiche

Reproducible: Always

Steps to Reproduce:
1. emerge curl with USE=quiche
Actual Results:  
/var/tmp/portage/net-misc/curl-7.71.0/work/curl-7.71.0/lib/vquic/quiche.c: In function ‘Curl_quic_connect’:
/var/tmp/portage/net-misc/curl-7.71.0/work/curl-7.71.0/lib/vquic/quiche.c:220:5: error: implicit declaration of function ‘quiche_conn_set_keylog_path’; did you mean ‘quiche_conn_set_qlog_path’? [-Werror=implicit-function-declaration]
  220 |     quiche_conn_set_keylog_path(qs->conn, keylog_file);
      |     ^~~~~~~~~~~~~~~~~~~~~~~~~~~
      |     quiche_conn_set_qlog_path


Issue disappears with net-libs/quiche-9999
Comment 1 skobk.in 2020-07-05 18:43:20 UTC
Created attachment 647842 [details]
build.log.gz

Due to missing build.log adding build log for curl-7.71.1 which still have the same problem.
Comment 2 Anthony Basile gentoo-dev 2020-07-07 19:45:29 UTC
(In reply to skobk.in from comment #1)
> Created attachment 647842 [details]
> build.log.gz
> 
> Due to missing build.log adding build log for curl-7.71.1 which still have
> the same problem.

This is a known issue.  It is stable masked on amd64, so if KEYWORD=~amd64 then you can test it, but when KEYWORD=amd64 its masked.

This should not block stabilization.
Comment 3 Craig Andrews gentoo-dev 2020-07-17 13:55:56 UTC
Fixed:

15dd8ceb79b9087cc499c17e2a252ae3b87f168c
net-misc/curl: 7.71.0 and 7.71.1 require quiche 0.5.0 or later