Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730390 - dev-perl/Crypt-Eksblowfish - Error: no compiler detected to compile 'lib/Crypt/Eksblowfish.c'. Aborting
Summary: dev-perl/Crypt-Eksblowfish - Error: no compiler detected to compile 'lib/Cryp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on: perl-toolchain
Blocks:
  Show dependency tree
 
Reported: 2020-07-01 14:32 UTC by Agostino Sarubbo
Modified: 2020-07-01 16:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.86 KB, text/plain)
2020-07-01 14:33 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-01 14:32:59 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: dev-perl/Crypt-Eksblowfish fails to compile.
Discovered on: amd64

NOTE:
If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-01 14:33:08 UTC
Created attachment 647314 [details]
build.log

build log and emerge --info
Comment 2 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2020-07-01 14:37:44 UTC
Can you confirm whether dev-perl/ExtUtils-CBuilder is installed or not?
Comment 3 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2020-07-01 14:38:46 UTC
(In reply to Kent Fredric (IRC: kent\n) from comment #2)
> Can you confirm whether dev-perl/ExtUtils-CBuilder is installed or not?

Scratch that, its in dev-lang/perl. 

*Sigh* I need to work out why I couldn't reproduce this myself, given I also have the same no-direct stack you have.
Comment 4 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2020-07-01 14:40:44 UTC
oooh. I see. Its an "LD=ld" problem. 

x86_64-pc-linux-gnu-ld: unrecognised emulation mode: arch=native
Comment 5 Larry the Git Cow gentoo-dev 2020-07-01 16:43:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a0d233bae81d75aedfb873be9914bbc6d049adee

commit a0d233bae81d75aedfb873be9914bbc6d049adee
Author:     Kent Fredric <kentnl@gentoo.org>
AuthorDate: 2020-07-01 16:42:33 +0000
Commit:     Kent Fredric <kentnl@gentoo.org>
CommitDate: 2020-07-01 16:43:05 +0000

    dev-perl/Crypt-Eksblowfish: Avoid breaking w/ LD=ld bug #730390
    
    This is probably the most sensible way I can handle this presently,
    as the concept of CCLD is not well established in the gentoo toolchain,
    and all the perl build tools expect their LD to be a CCLD, and become
    broken when its an _ACTUAL_ LD.
    
    A workaround for experts is left in its stead, as long as you set CCLD,
    then it will get passed to perl using the LD environment variable.
    
    Its a strange reality, but that's how it is.
    
    Closes: https://bugs.gentoo.org/730390
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Kent Fredric <kentnl@gentoo.org>

 dev-perl/Crypt-Eksblowfish/Crypt-Eksblowfish-0.9.0-r3.ebuild | 12 ++++++++++++
 1 file changed, 12 insertions(+)