Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730388 - net-dialup/freeradius-client calls ar directly
Summary: net-dialup/freeradius-client calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alarig Le Lay
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-07-01 14:32 UTC by Agostino Sarubbo
Modified: 2020-09-02 20:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,30.76 KB, text/plain)
2020-07-01 14:32 UTC, Agostino Sarubbo
Details
other.tar.bz2 (other.tar.bz2,253 bytes, application/x-bzip-compressed-tar)
2020-07-01 14:32 UTC, Agostino Sarubbo
Details
patched version shell session (file_730388.txt,48.86 KB, text/plain)
2020-07-08 17:40 UTC, Alarig Le Lay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-07-01 14:32:29 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: net-dialup/freeradius-client calls ar directly.
Discovered on: amd64

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-01 14:32:41 UTC
Created attachment 647310 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-07-01 14:32:47 UTC
Created attachment 647312 [details]
other.tar.bz2

other logs
Comment 3 Alarig Le Lay 2020-07-01 15:02:09 UTC
Hi,

Did you used the last git version of the tree? https://gitweb.gentoo.org/repo/gentoo.git/commit/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild?id=6c35e0080c2fcd69c99bee94e7d96c82d555558a has been merged five hours ago, and it should fix this issue.
Comment 4 Agostino Sarubbo gentoo-dev 2020-07-01 15:23:01 UTC
At the beginning of the build log you will see a link to the git head at the time of emerging.
Comment 5 Alarig Le Lay 2020-07-08 17:40:16 UTC
Created attachment 648442 [details]
patched version shell session

Hi,

I wasn’t able to do a full fix with my old patch, so I used a totaly opposite fix. I patched configure.ac to look for x86_64-pc-linux-gnu-ar if ar is not found.

checking for ar... no
checking for x86_64-pc-linux-gnu-ar... /usr/bin/x86_64-pc-linux-gnu-ar

See attachment for the complete shell session of the emerge.

If it’s OK, I can open a PR on github.
Comment 6 Sam James archtester gentoo-dev Security 2020-08-30 23:39:42 UTC
(In reply to Alarig Le Lay from comment #3)
> Hi,
> 
> Did you used the last git version of the tree?
> https://gitweb.gentoo.org/repo/gentoo.git/commit/net-dialup/freeradius-
> client/freeradius-client-1.1.7-r1.
> ebuild?id=6c35e0080c2fcd69c99bee94e7d96c82d555558a has been merged five
> hours ago, and it should fix this issue.

This should be fine? You don't want to assume /usr/bin/ar because even if it exists, it may not be the preferred implementation.

Try it out by doing:
"To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar."

... you may want to mv /usr/bin/ar /usr/bin/ar.bak too btw.
Comment 7 Alarig Le Lay 2020-08-31 19:33:37 UTC
Thanks!

I tested it on an LXC with those USE flags and it compiled (while with my first flag it didn’t).

I created the PR on github, as always don’t hesitate to make comments if you want me to change things.
Comment 8 Larry the Git Cow gentoo-dev 2020-09-02 20:41:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=97cf65fd933a09edc3bd7282c4d8f10ab27fb227

commit 97cf65fd933a09edc3bd7282c4d8f10ab27fb227
Author:     Alarig Le Lay <alarig@swordarmor.fr>
AuthorDate: 2020-08-31 19:27:17 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-02 20:40:06 +0000

    net-dialup/freeradius-client: respect AR
    
    Closes: https://bugs.gentoo.org/730388
    Package-Manager: Portage-3.0.4, Repoman-2.3.23
    Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
    Closes: https://github.com/gentoo/gentoo/pull/17351
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/freeradius-client-1.1.7-ar-configure.in.patch    | 10 ++++++++++
 .../freeradius-client/freeradius-client-1.1.7-r1.ebuild    | 14 ++++++--------
 2 files changed, 16 insertions(+), 8 deletions(-)