Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 730246 - dev-python/matplotlib-python2 fails to build with linker LLD: ld.lld: error: /usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../lib64/crti.o is incompatible with elf_x86_64
Summary: dev-python/matplotlib-python2 fails to build with linker LLD: ld.lld: error: ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LD-is-lld
  Show dependency tree
 
Reported: 2020-06-30 12:43 UTC by Agostino Sarubbo
Modified: 2020-10-11 14:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,102.84 KB, text/plain)
2020-06-30 12:43 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-30 12:43:48 UTC
@@This is an auto-filed bug@@
Feel free to change the summary at your convenience.

Issue: dev-python/matplotlib-python2 fails to compile.
Discovered on: amd64

NOTE:
This machine uses a clang/LLVM toolchain.
If you think that this issue is strictly related to clang/LLVM please mention it in the summary and block bug 408963. If you need further logs, feel free to ask.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-30 12:43:53 UTC
Created attachment 647214 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-10-11 14:29:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fb157138b11030afff7cde5b2a5636cb0f13d09d

commit fb157138b11030afff7cde5b2a5636cb0f13d09d
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-10-11 14:28:13 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-10-11 14:29:38 +0000

    dev-python/matplotlib-python2: remove last-rited pkg.
    
    Closes: https://bugs.gentoo.org/730246
    
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 dev-python/matplotlib-python2/Manifest             |   1 -
 .../files/matplotlib-2.2.4-doc-fix.patch           |  18 --
 .../matplotlib-python2-2.2.5-r2.ebuild             | 208 ---------------------
 dev-python/matplotlib-python2/metadata.xml         |  26 ---
 4 files changed, 253 deletions(-)