Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729676 - sys-auth/elogind: ninja: error: manifest 'build.ninja' still dirty after 100 tries
Summary: sys-auth/elogind: ninja: error: manifest 'build.ninja' still dirty after 100 ...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM64 Linux
: Normal normal (vote)
Assignee: Chromium Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-26 04:03 UTC by xuanloct4
Modified: 2020-07-14 17:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log of the sys-auth/elogind package (build.log.xz,4.65 KB, application/x-xz)
2020-06-26 04:03 UTC, xuanloct4
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xuanloct4 2020-06-26 04:03:59 UTC
Created attachment 646460 [details]
build log of the sys-auth/elogind package

Portage 2.3.99 (python 3.7.7-final-0, default/linux/arm64/17.0/desktop/plasma, gcc-9.3.0, glibc-2.30-r8, 4.14.0 aarch64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.0-aarch64-with-gentoo-2.6
KiB Mem:     4039076 total,   3044648 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 19 May 2020 00:45:01 +0000
Head commit of repository gentoo: 86d8d03b76dd557bcaa6395c49d54a4eafbdc24e
Head commit of repository genpi64: 7f94dfa1218e9960cf0aa3f4cead5aaec63a69c8

Head commit of repository sakaki-tools: 2e992c350ed5f3e212cfae8dc7c5573192268cd2

sh bash 5.0_p17
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
distcc 3.3.3 aarch64-unknown-linux-gnu [disabled]
app-shells/bash:          5.0_p17::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.18::gentoo, 3.7.7-r2::gentoo, 3.8.2-r2::gentoo
dev-util/cmake:           3.16.5::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            9.3.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1

local
    location: /var/db/repos/local
    masters: gentoo

crossdev
    location: /var/db/repos/crossdev
    masters: gentoo
    priority: 10

genpi64
    location: /var/db/repos/genpi64
    sync-type: git
    sync-uri: https://github.com/sakaki-/genpi64-overlay.git
    masters: gentoo
    priority: 20

sakaki-tools
    location: /var/db/repos/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="arm64"
ACCEPT_LICENSE="*"
CBUILD="aarch64-unknown-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="aarch64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa arm64 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups dbus declarative dri dts dvdr elogind emboss encode exif flac fortran gdbm gif gpm gtk iconv icu ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc mad mng mp3 mp4 mpeg ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt5 readline seccomp semantic-desktop spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xml xv xvid zlib" ADA_TARGET="gnat_2018" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_ARM="edsp thumb thumb2 v4 v5 v6 v7 v8 vfp vfp-d32 vfpv3 vfpv4" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="fbdev dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sam James gentoo-dev Security 2020-06-26 11:48:52 UTC
Please check your system clock. This problem is almost always because of an incorrect clock, as many arm(64)/embedded devices do not have a hardware clock.
Comment 2 xuanloct4 2020-06-29 09:43:14 UTC
I have tried syncing system clock with ntpdate pool.ntp.org
and emerge sys-auth/elogind again.
But the error still remains.
Comment 3 xuanloct4 2020-06-29 09:43:44 UTC
(In reply to Sam James (sec padawan) from comment #1)
> Please check your system clock. This problem is almost always because of an
> incorrect clock, as many arm(64)/embedded devices do not have a hardware
> clock.

I have tried syncing system clock with ntpdate pool.ntp.org
and emerge sys-auth/elogind again.
But the error still remains.
Comment 4 Sam James gentoo-dev Security 2020-06-29 20:26:16 UTC
(In reply to xuanloct4 from comment #3)
> (In reply to Sam James (sec padawan) from comment #1)
> > Please check your system clock. This problem is almost always because of an
> > incorrect clock, as many arm(64)/embedded devices do not have a hardware
> > clock.
> 
> I have tried syncing system clock with ntpdate pool.ntp.org
> and emerge sys-auth/elogind again.
> But the error still remains.

Please compare the 'date' command value with your current time.
Comment 5 xuanloct4 2020-06-30 03:48:44 UTC
I already did that and I confirm the system clock is correct.
Comment 6 xuanloct4 2020-06-30 03:49:00 UTC
(In reply to Sam James (sec padawan) from comment #4)
> (In reply to xuanloct4 from comment #3)
> > (In reply to Sam James (sec padawan) from comment #1)
> > > Please check your system clock. This problem is almost always because of an
> > > incorrect clock, as many arm(64)/embedded devices do not have a hardware
> > > clock.
> > 
> > I have tried syncing system clock with ntpdate pool.ntp.org
> > and emerge sys-auth/elogind again.
> > But the error still remains.
> 
> Please compare the 'date' command value with your current time.

I already did that and I confirm the system clock is correct.
Comment 7 Andreas Sturmlechner gentoo-dev 2020-07-07 18:28:28 UTC
*** Bug 731056 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Sturmlechner gentoo-dev 2020-07-12 11:26:52 UTC
*** Bug 731056 has been marked as a duplicate of this bug. ***
Comment 9 Andreas Sturmlechner gentoo-dev 2020-07-12 11:28:59 UTC
Is there any ninja maintainer who can help this user?
Comment 10 Stephan Hartmann 2020-07-12 11:36:16 UTC
Are you building on remote filesystem like nfs? If yes, then check that the remote filesystem time is synchronized to build machine time.

Also why is this marked FIXED, if it is still an issue?
Comment 11 xuanloct4 2020-07-12 14:58:24 UTC
(In reply to stha09 from comment #10)
> Are you building on remote filesystem like nfs? If yes, then check that the
> remote filesystem time is synchronized to build machine time.
> 
> Also why is this marked FIXED, if it is still an issue?

No, I am building the system on QEMU and the clock is correct because I used ntp to synchronize the system time.
Comment 12 xuanloct4 2020-07-12 15:02:23 UTC
(In reply to xuanloct4 from comment #11)
> (In reply to stha09 from comment #10)
> > Are you building on remote filesystem like nfs? If yes, then check that the
> > remote filesystem time is synchronized to build machine time.
> > 
> > Also why is this marked FIXED, if it is still an issue?
> 
> No, I am building the system on QEMU and the clock is correct because I used
> ntp to synchronize the system time.

This bug was resolved by running emerge --sync and re-emerge.
But the issue is the same for the bug https://bugs.gentoo.org/731056 but was not resolved!

Thanks
Comment 13 Mike Gilbert gentoo-dev 2020-07-14 17:15:22 UTC
Please try upgrading to the latest ninja release. That is 1.10.0 as of this writing.
Comment 14 Mike Gilbert gentoo-dev 2020-07-14 17:17:09 UTC
Closing since you can no longer reproduce this.