Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 729026 - sys-cluster/galera calls objdump directly
Summary: sys-cluster/galera calls objdump directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 725764 (view as bug list)
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-06-21 16:47 UTC by Agostino Sarubbo
Modified: 2020-09-11 11:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,214.36 KB, text/plain)
2020-06-21 16:47 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-21 16:47:33 UTC
@@This is an auto-filed bug@@
If you think that a different summary clarifies the issue better, feel free to change it.

Issue: sys-cluster/galera calls objdump directly.
Discovered on: amd64

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different OBJDUMP implementation (like llvm-objdump). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the OBJDUMP variable to x86_64-pc-linux-gnu-objdump.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-21 16:47:37 UTC
Created attachment 645530 [details]
build.log

build log and emerge --info
Comment 2 Thomas Deutschmann gentoo-dev Security 2020-09-11 10:30:42 UTC
*** Bug 725764 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2020-09-11 11:53:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cb511555ca37e2ae023f4de885508d4c9ef73450

commit cb511555ca37e2ae023f4de885508d4c9ef73450
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-09-11 11:49:54 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-09-11 11:52:57 +0000

    sys-cluster/galera: don't call objdump directly
    
    Closes: https://bugs.gentoo.org/729026
    Package-Manager: Portage-3.0.6, Repoman-3.0.1
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 .../files/galera-26.4.5-respect-toolchain.patch    | 55 ++++++++++++++++++++++
 sys-cluster/galera/galera-26.4.5.ebuild            |  4 +-
 2 files changed, 57 insertions(+), 2 deletions(-)