Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 728364 - dev-perl/Devel-CallChecker broken by LD!=ccld
Summary: dev-perl/Devel-CallChecker broken by LD!=ccld
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly perl-toolchain
  Show dependency tree
 
Reported: 2020-06-15 13:45 UTC by Agostino Sarubbo
Modified: 2021-04-30 21:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.05 KB, text/plain)
2020-06-15 13:45 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-15 13:45:07 UTC
@@This is an auto-filed bug@@
If you think that a different summary clarifies the issue better, feel free to change it.

Issue: dev-perl/Devel-CallChecker calls cc directly.
Discovered on: amd64

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-15 13:45:12 UTC
Created attachment 644834 [details]
build.log

build log and emerge --info
Comment 2 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2020-07-05 21:14:43 UTC
Should be Fixed in 0.8.0-r1, please test.

commit cc65cad1d9492d7f3959a554d2084980f0ab49db
Author: Kent Fredric <kentnl@gentoo.org>
Date:   2020-07-04 06:53:30 +1200

    dev-perl/Devel-CallChecker: -r bump for EAPI7 + Toolchain love
    
    - EAPI7
    - Don't break when LD=!ccld
    - Ensure CFLAGS passed through to compiler
    
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Comment 3 Andreas K. Hüttel gentoo-dev 2021-04-30 21:57:36 UTC
Let's assume its fixed.