Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 727896 - dev-python/pbr-5.1.1 fails test pbr.tests.test_packaging.TestRequirementParsing.test_requirement_parsing
Summary: dev-python/pbr-5.1.1 fails test pbr.tests.test_packaging.TestRequirementParsi...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2020-06-11 00:56 UTC by Jonathan Lovelace
Modified: 2020-10-28 20:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-python:pbr-5.1.1:20200610-234843.log (dev-python:pbr-5.1.1:20200610-234843.log,280.08 KB, text/x-log)
2020-06-11 00:56 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2020-06-11 00:56:29 UTC
Created attachment 644330 [details]
dev-python:pbr-5.1.1:20200610-234843.log

=dev-python/pbr-5.1.1 fails one test in its test phase under Python 3.6 (the first, and thus with the failure only, implementation other than Python 2.7 it ran under):

==============================
Failed 1 tests - output below:
==============================

pbr.tests.test_packaging.TestRequirementParsing.test_requirement_parsing
------------------------------------------------------------------------

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    b'Traceback (most recent call last):'
    b'  File "/usr/lib64/python3.6/site-packages/fixtures/fixture.py", line 197, in setUp'
    b'    self._setUp()'
    b'  File "/var/tmp/portage/dev-python/pbr-5.1.1/work/pbr-5.1.1/pbr/tests/test_packaging.py", line 186, in _setUp'
    b'    virtualenv.create_environment(path, clear=True)'
    b"AttributeError: module 'virtualenv' has no attribute 'create_environment'"
    b''

Captured traceback-1:
~~~~~~~~~~~~~~~~~~~~~
    b'Traceback (most recent call last):'
    b'  File "/usr/lib64/python3.6/site-packages/fixtures/fixture.py", line 197, in setUp'
    b'    self._setUp()'
    b'  File "/var/tmp/portage/dev-python/pbr-5.1.1/work/pbr-5.1.1/pbr/tests/test_packaging.py", line 186, in _setUp'
    b'    virtualenv.create_environment(path, clear=True)'
    b"AttributeError: module 'virtualenv' has no attribute 'create_environment'"
    b''
    b'During handling of the above exception, another exception occurred:'
    b''
    b'Traceback (most recent call last):'
    b'  File "/usr/lib64/python3.6/site-packages/fixtures/fixture.py", line 208, in setUp'
    b'    raise SetupError(details)'
    b'fixtures.fixture.SetupError: {}'
    b''


My emerge --info:
Portage 2.3.99 (python 3.7.7-final-0, default/linux/amd64/17.0/hardened, gcc-8.3.0, glibc-2.30-r8, 5.4.28-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.4.28-gentoo-x86_64-Intel-R-_Core-TM-_i5-2435M_CPU_@_2.40GHz-with-gentoo-2.6
KiB Mem:    16304496 total,   2035484 free
KiB Swap:   33553404 total,  33445628 free
Timestamp of repository gentoo: Wed, 10 Jun 2020 00:45:01 +0000
Head commit of repository lovelace: dff2743d4149c2728d86a835661529ac2fe8f68e

Head commit of repository steam-overlay: ae3e928b83b722ae6197fc1bc78859b592b819e5

sh bash 5.0_p17
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          5.0_p17::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.17-r2::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.2-r2::gentoo
dev-util/cmake:           3.16.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            8.3.0-r3::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: webrsync
    sync-uri: tar+http://lug.mtu.edu/gentoo/snapshots/portage-latest.tar.xz
    priority: -1000
    sync-webrsync-verify-signature: true

localoverlay
    location: /usr/local/portage
    masters: gentoo lovelace dlang
    priority: 0

dlang
    location: /var/lib/layman/dlang
    sync-type: laymansync
    sync-uri: https://github.com/gentoo/dlang.git
    masters: gentoo
    priority: 50

eclipse
    location: /var/lib/layman/eclipse
    sync-type: laymansync
    sync-uri: https://github.com/gentoo/eclipse-overlay.git
    masters: gentoo
    priority: 50

lovelace
    location: /var/lib/layman/lovelace
    sync-type: git
    sync-uri: https://github.com/kingjon3377/lovelace-overlay.git
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    sync-type: git
    sync-uri: https://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

Installed sets: @archivers, @backup-options, @class, @devel, @dicts, @doc-conv, @docs, @emulation, @fonts, @laptop, @looked-interesting, @maintenance, @ocr, @office, @sp-devel
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=generic -fno-unwind-tables -fno-asynchronous-unwind-tables -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -mtune=generic -fno-unwind-tables -fno-asynchronous-unwind-tables -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --binpkg-respect-use=n --autounmask-keep-masks --misspell-suggestions n --verbose-conflicts --complete-graph"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe -march=native -mtune=generic -fno-unwind-tables -fno-asynchronous-unwind-tables -fomit-frame-pointer"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy collision-protect config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict strict-keepdir test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=native -mtune=generic -fno-unwind-tables -fno-asynchronous-unwind-tables -fomit-frame-pointer"
GENTOO_MIRRORS="https://mirrors.lug.mtu.edu/gentoo/ http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j6 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acpi aes alsa amd64 avx bash-completion bzip2 cddb crypt dri gnat_2017 hardened iconv ipv6 java java5 java6 jpeg libnotify libsecret libtirpc lm-sensors mmx mmxext multilib ncurses nls nptl ogg openmp pam pclmul pcre pic pie png popcnt readline seccomp split-usr sse sse2 sse3 sse4_1 sse4_2 ssl ssp ssse3 startup-notification test theora truetype unicode vorbis xattr xcomposite xdg xft xtpax zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="sheets words plan kexi braindump flow" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev libinput wacom" KERNEL="linux" L10N="en en_US en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="intel i915 vesa fbdev modesetting i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-python/pbr-4.2.0-r1::gentoo was built with the following:
USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 (-pypy3)"
FEATURES="news strict-keepdir usersync binpkg-docompress ebuild-locks sandbox xattr fakeroot distlocks userpriv qa-unresolved-soname-deps config-protect-if-modified binpkg-dostrip sfperms unknown-features-warn usersandbox ipc-sandbox multilib-strict binpkg-logs merge-sync network-sandbox protect-owned userfetch collision-protect assume-digests pid-sandbox preserve-libs strict unmerge-logs candy parallel-fetch unmerge-orphans fixlafiles test-fail-continue parallel-install"


dev-python/fixtures-3.0.0::gentoo was built with the following:
USE="test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 (-pypy3) (-python3_8)"


dev-python/virtualenv-20.0.18::gentoo was built with the following:
USE="test -doc" ABI_X86="(64)" PYTHON_TARGETS="(python2_7) python3_6 python3_7 -pypy3 -python3_8"
Comment 1 Jannik Glückert 2020-06-20 11:52:49 UTC
Tests pass fine with python3_7 here
Comment 2 Jonathan Lovelace 2020-10-26 11:13:34 UTC
5.4.5 passed its tests (on python3_7) fine back in July, but 5.4.5-r1 is now apparently-reliably failing this same test in the same way (also on python3_7).
Comment 3 Louis Sautier (sbraz) gentoo-dev 2020-10-26 11:54:58 UTC
(In reply to Jonathan Lovelace from comment #2)
> 5.4.5 passed its tests (on python3_7) fine back in July, but 5.4.5-r1 is now
> apparently-reliably failing this same test in the same way (also on
> python3_7).

What version of dev-python/virtualenv do you have installed?
Comment 4 Jonathan Lovelace 2020-10-26 21:12:51 UTC
dev-python/virtualenv is 16.7.10-r1, the current stable.
Comment 5 Louis Sautier (sbraz) gentoo-dev 2020-10-27 00:27:12 UTC
(In reply to Jonathan Lovelace from comment #4)
> dev-python/virtualenv is 16.7.10-r1, the current stable.

Can you attempt to do:
git clone https://github.com/openstack/pbr
cd pbr
git checkout 5.1.1
pytest -vv pbr/tests/test_packaging.py::TestRequirementParsing::test_requirement_parsing

Does it fail too?
Comment 6 Jonathan Lovelace 2020-10-28 03:03:21 UTC
That passes, and it also passes when I run the same command under 'git checkout 5.4.5'.

With that, and noticing that the test failure message talked about timeouts, I first tried running with MAKEOPTS=-j1 (which didn't help), then  with FEATURES="-sandbox -usersandbox", and with that change all the tests passed.

So maybe some timeout value needs to be increased to compensate for the overhead of the sandbox?
Comment 7 Louis Sautier (sbraz) gentoo-dev 2020-10-28 20:02:14 UTC
(In reply to Jonathan Lovelace from comment #6)
> That passes, and it also passes when I run the same command under 'git
> checkout 5.4.5'.
> 
> With that, and noticing that the test failure message talked about timeouts,
> I first tried running with MAKEOPTS=-j1 (which didn't help), then  with
> FEATURES="-sandbox -usersandbox", and with that change all the tests passed.
> 
> So maybe some timeout value needs to be increased to compensate for the
> overhead of the sandbox?

If your failure is still the same as in the initial message, it's not a timeout. I don't really see why the sandbox would have anything to do with it. Does it also fail with sys-apps/sandbox 2.20 if you can pull it on your stable system?