Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 727178 - www-client/firefox-77.0.1 - error: could not compile `gkrust`. (ppc64 big-endian)
Summary: www-client/firefox-77.0.1 - error: could not compile `gkrust`. (ppc64 big-end...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-05 00:28 UTC by ernsteiswuerfel
Modified: 2020-08-10 19:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_727178.txt,6.27 KB, text/plain)
2020-06-05 00:28 UTC, ernsteiswuerfel
Details
build.log.xz (firefox-77.0.1:20200604-235028.log.xz,370.00 KB, application/x-xz)
2020-06-05 00:33 UTC, ernsteiswuerfel
Details
build.log.xz (built with rust-bin-1.41.1) (firefox-77.0.1:20200605-131212.log.xz,379.50 KB, application/x-xz)
2020-06-07 11:27 UTC, ernsteiswuerfel
Details
build.log.xz (built with rust-1.44.0) (firefox-77.0.1:20200607-133159.log.xz,89.70 KB, application/x-xz)
2020-06-07 13:55 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2020-06-05 00:28:51 UTC
Created attachment 643478 [details]
emerge --info

[...]
24:09.88 error: could not compile `gkrust`.
24:09.88   process didn't exit successfully: `CARGO=/opt/rust-bin-1.43.1/bin/cargo-bin-1.43.1 CARGO_MANIFEST_DIR=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/toolkit/library/rust CARGO_PKG_AUTHORS='nobody@mozilla.org' CARGO_PKG_DESCRIPTION='Rust code for libxul' CARGO_PKG_HOMEPAGE= CARGO_PKG_NAME=gkrust CARGO_PKG_REPOSITORY= CARGO_PKG_VERSION=0.1.0 CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_VERSION_MINOR=1 CARGO_PKG_VERSION_PATCH=0 CARGO_PKG_VERSION_PRE= LD_LIBRARY_PATH='/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/release/deps:/opt/rust-bin-1.43.1/lib' /usr/bin/rustc --crate-name gkrust toolkit/library/rust/lib.rs --error-format=json --json=diagnostic-rendered-ansi --crate-type staticlib --emit=dep-info,link -C opt-level=2 -C panic=abort -Clto --cfg 'feature="cubeb-remoting"' --cfg 'feature="cubeb_pulse_rust"' --cfg 'feature="moz_memory"' --cfg 'feature="moz_places"' --cfg 'feature="new_cert_storage"' --cfg 'feature="quantum_render"' --cfg 'feature="services_sync"' --cfg 'feature="webgpu"' --cfg 'feature="webrtc"' -C metadata=5996b974c5ea2c76 -C extra-filename=-5996b974c5ea2c76 --out-dir /var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps --target powerpc64-unknown-linux-gnu -C linker=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/build/cargo-linker -L dependency=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps -L dependency=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/release/deps --extern gkrust_shared=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps/libgkrust_shared-a152a7cff8afe6ba.rlib --extern mozglue_static=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps/libmozglue_static-a1add8d5990c306e.rlib --extern mozilla_central_workspace_hack=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps/libmozilla_central_workspace_hack-117f4d66a5e9d47d.rlib -C opt-level=2 --cap-lints warn -C codegen-units=1 -L native=/usr/lib64 -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/build/lmdb-rkv-sys-7a5bb73f20890c44/out -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/build/mozglue-static-ae1a18485b563dfe/out -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/dist/bin -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/security/nss/lib/nss/nss_nss3 -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/security/nss/lib/ssl/ssl_ssl3 -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/config/external/nspr/pr -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/build/swgl-7c399807b9af2705/out -L native=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/build/libloading-487825c86ac4bb69/out -L native=/usr/lib64` (signal: 11, SIGSEGV: invalid memory reference)
24:09.90 gmake[4]: *** [/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/config/makefiles/rust.mk:294: force-cargo-library-build] Error 101
24:09.90 gmake[3]: *** [/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/config/recurse.mk:74: toolkit/library/rust/target] Error 2
Comment 1 ernsteiswuerfel 2020-06-05 00:33:55 UTC
Created attachment 643480 [details]
build.log.xz
Comment 2 Georgy Yakovlev gentoo-dev 2020-06-05 04:48:46 UTC
stating obvious, works fine on little-endian.

I can try giving it a spin in a big-endian VM, but judging by https://bugzilla.mozilla.org/buglist.cgi?quicksearch=ppc64

it will not build anyway.
do you know if anybody builds/uses it in BE mode?
Comment 3 Georgy Yakovlev gentoo-dev 2020-06-05 04:59:55 UTC
since it's a SIGSEGV in rust, I can suggest trying dev-lang/rust with system-llvm and llvm10.
Comment 4 ernsteiswuerfel 2020-06-07 11:22:16 UTC
firefox-77.0.1 builds fine if rust-bin-1.41.1 is used. Also opens it's window at startup but crashes if an URL is entered and it's trying to load the page:

[...]
Crash Annotation GraphicsCriticalError: |[0][GFX1]: Unknown image format 1 (t=2.82622) |[4801][GFX1]: Unknown image format 1 (t=105.058) |[4802][GFX1]: Unknown image format 0 (t=105.06) |[4803][GFX1]: Unknown image format 1 (t=105.075) |[4804][GFX1]: Unknown image format 1 (t=105.075) |[4805][GFX1]: Unknown image format 0 (t=105.075) |[4806][GFX1]: Unknown image format 0 (t=105.075) |[4807][GFX1]: Unknown image format 1 (t=105.092) |[4808][GFX1]: Unknown image format 1 (t=105.092) |[4794][GFX1]: Unknown image format 1 (t=105.004) |[4795][GFX1]: Unknown image format 1 (t=105.005) |[4796][GFX1]: Unknown image format 0 (t=105.008) |[4797][GFX1]: Unknown image format 1 (t=105.041) |[4798][GFX1]: Unknown image format 1 (t=105.042) |[4799][GFX1]: Unknown image format 0 (t=105.042) |[4800][GFX1]: Unknown image format 1 (t=105.058) [GFX1]: Unknown image format 1
Crash Annotation GraphicsCriticalError: |[0][GFX1]: Unknown image format 1 (t=2.82622) |[4801][GFX1]: Unknown image format 1 (t=105.058) |[4802][GFX1]: Unknown image format 0 (t=105.06) |[4803][GFX1]: Unknown image format 1 (t=105.075) |[4804][GFX1]: Unknown image format 1 (t=105.075) |[4805][GFX1]: Unknown image format 0 (t=105.075) |[4806][GFX1]: Unknown image format 0 (t=105.075) |[4807][GFX1]: Unknown image format 1 (t=105.092) |[4808][GFX1]: Unknown image format 1 (t=105.092) |[4809][GFX1]: Unknown image format 0 (t=105.092) |[4795][GFX1]: Unknown image format 1 (t=105.005) |[4796][GFX1]: Unknown image format 0 (t=105.008) |[4797][GFX1]: Unknown image format 1 (t=105.041) |[4798][GFX1]: Unknown image format 1 (t=105.042) |[4799][GFX1]: Unknown image format 0 (t=105.042) |[4800][GFX1]: Unknown image format 1 (t=105.058) [GFX1]: Unknown image format 0
Crash Annotation GraphicsCriticalError: |[0][GFX1]: Unknown image format 1 (t=2.82622) |[4801][GFX1]: Unknown image format 1 (t=105.058) |[4802][GFX1]: Unknown image format 0 (t=105.06) |[4803][GFX1]: Unknown image format 1 (t=105.075) |[4804][GFX1]: Unknown image format 1 (t=105.075) |[4805][GFX1]: Unknown image format 0 (t=105.075) |[4806][GFX1]: Unknown image format 0 (t=105.075) |[4807][GFX1]: Unknown image format 1 (t=105.092) |[4808][GFX1]: Unknown image format 1 (t=105.092) |[4809][GFX1]: Unknown image format 0 (t=105.092) |[4810][GFX1]: Unknown image format 0 (t=105.092) |[4796][GFX1]: Unknown image format 0 (t=105.008) |[4797][GFX1]: Unknown image format 1 (t=105.041) |[4798][GFX1]: Unknown image format 1 (t=105.042) |[4799][GFX1]: Unknown image format 0 (t=105.042) |[4800][GFX1]: Unknown image format 1 (t=105.058) [GFX1]: Unknown image format 0
Crash Annotation GraphicsCriticalError: |[0][GFX1]: Unknown image format 1 (t=2.82622) |[4801][GFX1]: Unknown image format 1 (t=105.058) |[4802][GFX1]: Unknown image format 0 (t=105.06) |[4803][GFX1]: Unknown image format 1 (t=105.075) |[4804][GFX1]: Unknown image format 1 (t=105.075) |[4805][GFX1]: Unknown image format 0 (t=105.075) |[4806][GFX1]: Unknown image format 0 (t=105.075) |[4807][GFX1]: Unknown image format 1 (t=105.092) |[4808][GFX1]: Unknown image format 1 (t=105.092) |[4809][GFX1]: Unknown image format 0 (t=105.092) |[4810][GFX1]: Unknown image format 0 (t=105.092) |[4811][GFX1]: Unknown image content format 0 (t=105.097) |[4797][GFX1]: Unknown image format 1 (t=105.041) |[4798][GFX1]: Unknown image format 1 (t=105.042) |[4799][GFX1]: Unknown image format 0 (t=105.042) |[4800][GFX1]: Unknown image format 1 (t=105.058) [GFX1]: Unknown image content format 0
Exiting due to channel error.
Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=106.418) Exiting due to channel error.
[GFX1-]: Receive IPC close with reason=AbnormalShutdown
Exiting due to channel error.
Exiting due to channel error.
Crash Annotation GraphicsCriticalError: |[C0][GFX1]: Unknown image format 1 (t=2.08392) |[C31][GFX1]: Unknown image format 1 (t=93.1428) |[C32][GFX1]: Unknown image format 1 (t=93.1431) |[C33][GFX1]: Unknown image format 1 (t=93.1437) |[C34][GFX1]: Unknown image format 0 (t=93.144) |[C35][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=106.558) |[C21][GFX1]: Unknown image format 1 (t=15.0162) |[C22][GFX1]: Unknown image format 1 (t=15.0163) |[C23][GFX1]: Unknown image format 1 (t=15.0165) |[C24][GFX1]: Unknown image format 0 (t=15.0169) |[C25][GFX1]: Unknown image format 1 (t=80.088) |[C26][GFX1]: Unknown image format 1 (t=80.0894) |[C27][GFX1]: Unknown image format 1 (t=80.0899) |[C28][GFX1]: Unknown image format 1 (t=80.0904) |[C29][GFX1]: Unknown image format 0 (t=80.0908) |[C30][GFX1]: Unknown image format 1 (t=93.1417) Speicherzugriffsfehler (Speicherabzug geschrieben)
Comment 5 ernsteiswuerfel 2020-06-07 11:27:55 UTC
Created attachment 643826 [details]
build.log.xz (built with rust-bin-1.41.1)
Comment 6 ernsteiswuerfel 2020-06-07 13:55:04 UTC
Created attachment 643832 [details]
build.log.xz (built with rust-1.44.0)

firefox-77.0.1 built with rust-1.44.0 (which was built with USE='system-llvm', llvm-10.0.1_rc1)

[...]
 7:19.48 error: could not compile `ffi-support`.
 7:19.48 Caused by:
 7:19.49   process didn't exit successfully: `CARGO=/usr/bin/cargo-1.44.0 CARGO_MANIFEST_DIR=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/third_party/rust/ffi-support CARGO_PKG_AUTHORS='Thom Chiovoloni <tchiovoloni@mozilla.com>' CARGO_PKG_DESCRIPTION='A crate to help expose Rust functions over the FFI.' CARGO_PKG_HOMEPAGE= CARGO_PKG_NAME=ffi-support CARGO_PKG_REPOSITORY='https://github.com/mozilla/application-services' CARGO_PKG_VERSION=0.4.0 CARGO_PKG_VERSION_MAJOR=0 CARGO_PKG_VERSION_MINOR=4 CARGO_PKG_VERSION_PATCH=0 CARGO_PKG_VERSION_PRE= LD_LIBRARY_PATH='/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/release/deps:/usr/lib' /usr/bin/rustc --crate-name ffi_support --edition=2018 /var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/third_party/rust/ffi-support/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts --crate-type lib --emit=dep-info,metadata,link -C opt-level=2 -C panic=abort --cfg 'feature="default"' -C metadata=6ed68e4c8fe5c11d -C extra-filename=-6ed68e4c8fe5c11d --out-dir /var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps --target powerpc64-unknown-linux-gnu -C linker=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/build/cargo-linker -L dependency=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps -L dependency=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/release/deps --extern lazy_static=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps/liblazy_static-5de3f57e568bbb73.rmeta --extern log=/var/tmp/portage/www-client/firefox-77.0.1/work/firefox-77.0.1/ff/powerpc64-unknown-linux-gnu/release/deps/liblog-5e99d7637ab82225.rmeta --cap-lints warn -C opt-level=2 --cap-lints warn -C codegen-units=1` (signal: 6, SIGABRT: process abort signal)
Comment 7 ernsteiswuerfel 2020-08-10 19:05:00 UTC
www-client/firefox-79.0-r2 (finally!) builds again on ppc64 BE with current toolchain and following rdeps:

sys-devel/llvm-10.0.1:10::gentoo  USE="debug gold libffi ncurses xml -doc -exegesis -libedit -test -xar -z3" LLVM_TARGETS="AMDGPU BPF (PowerPC) -AArch64 -ARC -ARM -AVR -Hexagon -Lanai -MSP430 -Mips -NVPTX -RISCV -Sparc -SystemZ -WebAssembly -X86 -XCore" 0 KiB
dev-lang/rust-1.45.2:stable/1.45::gentoo  USE="libressl system-llvm -clippy -debug -doc -miri -nightly -parallel-compiler -rls -rustfmt -system-bootstrap -wasm" LLVM_TARGETS="AMDGPU BPF (PowerPC) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -NVPTX -RISCV -Sparc -SystemZ -WebAssembly -X86 -XCore" 0 KiB
net-libs/nodejs-14.5.0::gentoo  USE="icu npm snapshot ssl -debug -doc -inspector -pax_kernel -system-ssl -systemtap -test" 0 KiB
www-client/firefox-79.0-r2::gentoo  USE="gmp-autoupdate openh264 pulseaudio screenshot system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-web"

It still crashes when trying to view anything other than settings pages, but build is ok now.