Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72708 - Reiser4 causes /sbin/rc segmentation fault
Summary: Reiser4 causes /sbin/rc segmentation fault
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All All
: High major (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-11-28 05:02 UTC by crusaderky
Modified: 2004-11-29 18:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description crusaderky 2004-11-28 05:02:11 UTC
1)I unpack the 2004.3 stage1 in my athlonxp 2000+, mount /proc and chroot in it
2)I go through stage1, stage2 and stage3 without problems and emerge everything I need
3)I compile and install the kernel sources (see below)
4)I unmount /proc
5)I boot my laptop (pentium 2 333Mhz) with the latest Reiser4 LiveCD (stable; using nitro-sources)
6)I create a Reiser4 partition on /dev/hda1 and mount it
7)I mount the chrooted partition via NFS
8)I launch cp -afv to copy everything on the Reiser4 partition
9)launch lilo and reboot

everything is perfectly fine until now. However, at boot I get

/sbin/rc: line 397: 1087 Segmentation fault

and the system goes into manteinance mode.

$ cat etc/make.conf
CFLAGS="-Os -march=pentium2 -mmmx -fomit-frame-pointer -pipe"
USE="-gnome -qt -kde -oss -arts alsa directfb dvb erandom fbcon fortran gtk gtk2 kerberos ldap mmx mozilla ncurses network nls no_wxgtk1 nptl offensive pcre pic real rtc skey slang ssl xvid xvmc"
FEATURES="sandbox ccache digest distcc fixpackages userpriv"

bash-2.05b$ cat etc/portage/package.keywords
sys-kernel/mm-sources ~x86
sys-kernel/nitro-sources ~x86
media-video/mplayer ~x86
media-libs/win32codecs ~x86
sys-apps/hibernate-script ~x86
sys-apps/baselayout ~x86
app-shells/bash ~x86
sys-apps/sysvinit ~x86

before upgrading to ~x86 baselayout, I tried with the x86 version obtaining the same result.

I've both tried with the latest mm-sources and nitro-sources.

Yes, I already did etc-update.
Comment 1 crusaderky 2004-11-28 11:40:49 UTC
I've switched to ReiserFS v3 and all goes ok.
Comment 2 Luca Barbato gentoo-dev 2004-11-28 23:29:38 UTC
Try w/out Reiserfs4 and using a livecd we provide.
I'm afraid that the problem is due the kernel you are using.
Marked as invalid, reopen if still applies using other kernels/fs

if you are aiming at performance try ext3+dir_index
Comment 3 SpanKY gentoo-dev 2004-11-29 18:21:28 UTC
reiser4 bug -> not Gentoo problem

file bugs upstream