Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726884 - media-libs/mesa-19.3.5 - ld: src/mesa/drivers/dri/r200/libr200.a(radeon_debug.c.o):(.bss+0x0): multiple definition of `radeon_enabled_debug_types'; src/mesa/drivers/dri/radeon/libr100.a(radeon_debug.c.o):(.bss+0x0): first defined here
Summary: media-libs/mesa-19.3.5 - ld: src/mesa/drivers/dri/r200/libr200.a(radeon_debug...
Status: RESOLVED DUPLICATE of bug 706234
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-06-03 10:02 UTC by Thomas
Modified: 2020-06-03 10:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,38.32 KB, application/x-xz)
2020-06-03 10:02 UTC, Thomas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2020-06-03 10:02:55 UTC
Created attachment 643200 [details]
build.log.xz

Linux gentoo 5.7.0-x86_64 #1 SMP Tue Jun 2 17:22:52 CEST 2020 x86_64 Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz GenuineIntel GNU/Linux

# emerge mesa

/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: src/mesa/drivers/dri/r200/libr200.a(radeon_debug.c.o
):(.bss+0x0): multiple definition of `radeon_enabled_debug_types'; src/mesa/drivers/dri/radeon/libr100.a(radeon_debug.c.o):(.bss+0x0
): first defined here                                                                                                               
collect2: error: ld returned 1 exit status                                                                                          
ninja: build stopped: subcommand failed.                                                                                            
 * ERROR: media-libs/mesa-19.3.5::gentoo failed (compile phase):                                                                    
 *   ninja -v -j1 -l0 -C /var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64 failed                           
 *                                                                                                                                  
 * Call stack:                                                                                                                      
 *     ebuild.sh, line  125:  Called src_compile                                                                                    
 *   environment, line 4169:  Called multilib-minimal_src_compile                                                                   
 *   environment, line 2793:  Called multilib_foreach_abi 'multilib-minimal_abi_src_compile'                                        
 *   environment, line 3043:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'   
 *   environment, line 2728:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'              
 *   environment, line 2726:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_compile'                                
 *   environment, line  921:  Called multilib-minimal_abi_src_compile                                                               
 *   environment, line 2787:  Called multilib_src_compile                                                                           
 *   environment, line 3263:  Called meson_src_compile                                                                              
 *   environment, line 2605:  Called eninja '-C' '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64'        
 *   environment, line 1750:  Called die                                                                                            
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 * 
 * If you need support, post the output of `emerge --info '=media-libs/mesa-19.3.5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/mesa-19.3.5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/mesa-19.3.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/mesa-19.3.5/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5'

>>> Failed to emerge media-libs/mesa-19.3.5, Log file:

>>>  '/var/tmp/portage/media-libs/mesa-19.3.5/temp/build.log'

 * Messages for package media-libs/mesa-19.3.5:

 * ERROR: media-libs/mesa-19.3.5::gentoo failed (compile phase):
 *   ninja -v -j1 -l0 -C /var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64 failed
 * 
 * Call stack:
 *     ebuild.sh, line  125:  Called src_compile
 *   environment, line 4169:  Called multilib-minimal_src_compile
 *   environment, line 2793:  Called multilib_foreach_abi 'multilib-minimal_abi_src_compile'
 *   environment, line 3043:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 2728:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 2726:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_compile'
 *   environment, line  921:  Called multilib-minimal_abi_src_compile
 *   environment, line 2787:  Called multilib_src_compile
 *   environment, line 3263:  Called meson_src_compile
 *   environment, line 2605:  Called eninja '-C' '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64'
 *   environment, line 1750:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 * 
 * If you need support, post the output of `emerge --info '=media-libs/mesa-19.3.5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/mesa-19.3.5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/mesa-19.3.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/mesa-19.3.5/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-libs/mesa-19.3.5/work/mesa-19.3.5'
Comment 1 Jeroen Roovers gentoo-dev 2020-06-03 10:15:18 UTC

*** This bug has been marked as a duplicate of bug 706234 ***