Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726632 - app-misc/fdupes does not respect CFLAGS
Summary: app-misc/fdupes does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-06-01 11:22 UTC by Agostino Sarubbo
Modified: 2020-06-21 07:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.08 KB, text/plain)
2020-06-01 11:22 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-01 11:22:28 UTC
This is an auto-filed bug because app-misc/fdupes does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-01 11:22:33 UTC
Created attachment 643016 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-21 07:24:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=789193af5fdab1cb39ed3fdc06efe7db3e3d33b2

commit 789193af5fdab1cb39ed3fdc06efe7db3e3d33b2
Author:     Patrice Clement <monsieurp@gentoo.org>
AuthorDate: 2020-06-21 07:24:37 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-06-21 07:24:47 +0000

    app-misc/fdupes: honour CFLAGS.
    
    Closes: https://bugs.gentoo.org/726632
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 app-misc/fdupes/fdupes-1.6.1-r1.ebuild | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)